SQL Server Express on a Multiple core installation

I have an ESXi server running with a Windows 2008 installation on it. It has 2 vCPU's and it runs a SQL Express installation for a database wich is used for my ERP software.

For some reasy 1 core is peaking 100% and the other one is doing nothing mainly.

How can tell my SQL server to use both cores or even more cores if needed?

I have read the SQL Express can use 4 cores on 1 processor, but i can't find it how to enable this.

Anyone with an idea?
RemcoViCEOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tigin44Commented:
if you have SQL Server Manegement Studio Expres installed you can configure the CPU usage of your instance by this steps.
1. open SSMS
2. connect to you database server instance
3. right click on the server and choose properties
4. there you will see a link named "Processors", click it
5. you get a screen showing the CPU's used by your machine.
6. the CPU core used by your SQL server should be marked.. Mark the other one too
7. make sure that the "Configured Values" radio button also checked
8. save your changes by clicking the OK button
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Anthony PerkinsCommented:
SQL Server Express only supports 1 CPU.
0
RemcoViCEOAuthor Commented:
@tigin44
Automatically set processor affinity mask for all processors is marked
Automatically set I/O affinity mask for all processors is marked

I can't set any options in the white screen where you select the CPU.
I only see CPU0

@acperkins
What i have found by reading was that Express edition supports 1 CPU but up to 4 cores.

This virtual machines has 2 vCPU, but my taskmanager shows 100 CPU on 1 core.

So the only option i have is upgrade to SQL standard? I have an MS Action Pack so that wouldn't be a problem, but can i just simple upgrade it?
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

Anthony PerkinsCommented:
I have an MS Action Pack so that wouldn't be a problem, but can i just simple upgrade it?
You should be able to do an Edition Upgrade.
0
Ramesh Babu VavillaCommented:
SQL Server Express supports
1 CPU
10 GB database base size .and ldf max size is 4 GB


to check the processor run this command in SSMS
xp_readerrorlog 0,1,'CPU'
0
RemcoViCEOAuthor Commented:
Sorry for my really really late response, but because some private issues i couldn't respond earlier.

@SQLSERVR
Where do i need to run that command "xp_readerrorlog 0,1,'CPU'" ?

Still didn't find any solution to get this up and working on multiple cores / vCPU
0
RemcoViCEOAuthor Commented:
Still have the problem, but i am creating a new virtual machine with MS SQL standard edition, hopefully that would solve the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.