Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 675
  • Last Modified:

Outlook Drive Letter Data Folder

I am running Outlook 2010 on a Windows 7 laptop, and I keep my PST file on an external drive.  Normally, when I plug the drive in and it gets assigned a different drive letter than the default folder in Outlook I am given the opportunity to select the location of the PST file (after which it "remembers" the location until the drive letter changes).

Tonight I plugged in my external drive - which was previously Drive D:/, and the computer made it Drive E:/.  When I tried to open Outlook I got the attached message, but when I hit "OK" the dialogue box closed, Outlook did not open, and I was not given the opportunity to select the new location of the PST folder.  I am unable to open Outlook.   Since the default folder Outlook is looking for is in Drive D:/, I tried renumbering the external drive using Disk  Management, but the letter "D" is not in the list of choices (which is another issue I would like to get resolved).

Can you help me open my Outlook so I can change the default location of my PST data file?

Thank you,

Philip SimmonsOutlook Opening Error Message
0
philsimmons
Asked:
philsimmons
1 Solution
 
RinilCommented:
Hi,

The default pst location in outlook can be changed using any one of the 2 methods suggested as in the below forum.

http://www.techimo.com/forum/applications-operating-systems/33124-default-location-outlook-pst-file.html

one method involves the changes in registry , which can be harmful for a computer. So please backup the registry before doing it, else you can use CIW(custom installation wizard)
0
 
AnuroopsunddCommented:
firstly make changes to your outlook so that you connect to your new drive letter\
Clost the outlook to make these changes.

1. Go to control panel
2. open Mail
3. Click on Data File Button
4. Click on the file showing in the list. and click on remove button
5.Click on Add button and browse to your drive and pst file.
6. Click Ok.

Also click on the Set as default button to make this pst as default file.
Click close button and start outlook
0
 
rindiCommented:
You probably installed some hardware which uses the drive-letter D:, maybe a printer with card-reader, or a card-reader, or another USB drive or similar. Or maybe some software that emulates a drive and thus gives it the next available drive-letter, which is probably D if you didn't have your external drive with the PST file attached when you installed that hardware or software.

First change that drive-letter to something else, after that drive D should again become available for your USB drive with the PST file.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
philsimmonsAuthor Commented:
I just noticed this comment (after I had already accepted the foregoing solution).  I wonder if I can re-open the issue.  It turns out that when I tried to delete the previous location of the default data I get the attached error message.  I assumed it would just (as it says) take awhile to load the configuration settings, but now it's been an hour and the old default drive is still there.  I WAS able to create a new default location for the PST file to the proper drive, and WAS able to open Outlook, but my email won't work until I can delete the other setting.Cannot Delete Outlook File
0
 
philsimmonsAuthor Commented:
ALL,

I think my problem can be resolved if I can figure out how to get back my D:/ drive availability in my Disk Management.  I tried plugging in every external drive I have and NONE of them register as the D:/ drive.  If rindi is correct, and the D:/ drive is not available because at some point I assigned it to a different drive, I don't have that drive anymore ... which begs the question ... how did I get my Outlook set to a default D:/ drive location last week?

Is there any way to "reset" my Disk Management so that the D:/ drive is once again available.  That way I am hoping that I can set the drive with my PST folder to D:/ and Outlook won't be confused anymore.

Thanks,

Phil
0
 
rindiCommented:
Check if that drive letter is used by something else, then either disable that something else or change it's letter mapping from D to another letter (maybe your DVD drive has D:?).
0
 
philsimmonsAuthor Commented:
I plugged in everything I can find, and I am currently showing B:, C:, E:, F:, G:, H:, I:, J:, M:, and my Q: (rescue virtual drive).  No D:/
0
 
rindiCommented:
There may also be some software, like a virtual CD drive or something similar that has reserved the drive letter. Even if such a drive isn't currently mounted that drive letter is still reserved. But normaly you can change those letters and settings somewhere within that software. If you aren't aware of having installed anything between when you had Driveletter D available and when not, you could also try using a restore point in the OS.
0
 
philsimmonsAuthor Commented:
Thank you, rindi.  It's worked out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now