Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 550
  • Last Modified:

Date Format in old XLW Files gets corrupted

I am helping somebody after a computer upgrade. This means I don't know much about the history of these files. Here is what I know: Importing old XLW files results in
- a warning message when opening it in Office 2010 ("The file you are trying to open, 'test.sheet.xlw', is in a different format than specified by the file extension. Verify that the file is not corrupted and is from a trusted source before opening the file. Do you want to open the file now? Yes|No|Help"). After clicking "Yes", the file does open without any further warning or error.
- Date fields in the file are not shown correctly. The attached sample shows e.g. "0-Jan-00", and when I highlight the cell, I see "=11/21/2011" as the data entered, but I cannot remove the "=" to make it a valid date.
- When I try to enter a new date (e.g. 1/1/2012), a '=' is prepended to my date again, and the cell displays again a corrupt date.
- When I open the file in Office 2011 on a Mac or LibreOffice, I can remove the leading '=' and the date gets displayed correctly.

Is there a way to correctly open those files? Is there a method to convert them to current version files? Are there potentially more problems than just the dates to expect?

I am attaching a file that had all it's data removed with the exception of three date fields to show the problem. For EE to accept the file, I had to add a ".xls" to the filename. To work with the original file, remove the .xls extension, so that the filename is test-sheet.xlw again. From what I can tell, it does not seem to make a difference in the behavior - besides the warning message is gone.

Thanks.
test-sheet.xlw.xls
0
Karl Heinz Kremer
Asked:
Karl Heinz Kremer
  • 2
1 Solution
 
redmondbCommented:
Hi, khkremer.

(1) The file is an XLS not an XLW. At some point, someone renamed it to XLW but that doesn't change its underlying reality.

(2) "Lotus compatibility settings" were turned on for this sheet (see the bottom of "Advanced" in the "Excel Options" dialog). I've turned them off in the attached and successfully re-typed the dates.

Regards,
Brian.test-sheet-V2.xls
0
 
Karl Heinz KremerAuthor Commented:
I don't think I've ever seen these options :) It is possible that these files were originally created in Lotus.

Thanks for your help.
0
 
redmondbCommented:
Thanks, khkremer. (First time I'd ever seen them set, too.)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now