Solved

Mac Wireless problem

Posted on 2012-04-08
15
702 Views
Last Modified: 2012-05-14
Hi,
I have two Macs, an iMac and and a MacBook Air, on my local home network using a TP-Link wireless router. For several weeks I have believed that the router has gone bad as both Macs lose their wireless connection frequently. Restarting the Wi-Fi service on the Macs does not usually restore the connection. Rebooting the router usually does.

I upgraded the firmware on the router to the latest available and that did not resolve the problem. It has gone on for several weeks just because I have not gotten around to replacing the router.

Just now I am working online on the iMac and it lost its connection again. Before rebooting the router I pulled out my Droid, which is set to use the local network when I am here, to see if it too was unable to use the local router. Wonder of all wonders, it was connected to the router and I was able to browse the internet on it just fine.

So maybe the issue is with the Macs, and maybe nothing is necessarily wrong, it is just that they don't get along well with the router. I don't know. I do know that I am not about to run out and by a new router when I have at least one device that works fine with it when the two Macs don't.

Any suggestions or thoughts as to what the actual issue might be?

All advice appreciated.
0
Comment
Question by:westone
15 Comments
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
I do not know for MAC, but I do know Windows machines do this because the Wireless turns off to save power. Check if you have power management, and then see if you can make Wireless High Performance (or some like setting).

If not that, then a new router may be next. I had to do that as well when moving beyond Windows XP.   .... Thinkpads_User
0
 
LVL 2

Assisted Solution

by:JonyHolt
JonyHolt earned 167 total points
Comment Utility
Its most definitely the router. Its actually probably tied to a macaddress issue. You may want to go in and assign the macs a static IP on the router.
0
 

Author Comment

by:westone
Comment Utility
I haven't come across or read anything about a "sleep" or power save setting for the wireless card in the Mac, though I have once or twice found it necessary to turn that feature of under Windows.

Since posting here I did read of the possible solution to this issue being to create a new "location" in the OS X wireless network properties. If the problem doesn't improve today  as a result, I'll assign permanent addresses and see if that helps.
0
 
LVL 2

Assisted Solution

by:Lonbox
Lonbox earned 166 total points
Comment Utility
Before replacing the Wireless router try changing the wireless channel on it. You may be experiencing wireless interference from some other device in the area e.g. a cordless phone or a baby monitor.
log into the router TP-Link in general 192.168.1.1
there should be 13 different wireless channels operating at different frequencies.
At the moment the device is probably set to auto select the channel, change this to a manual channel (try 7 or 8 ),
Then check the wireless on you Mac again.

It may also be worthwhile changing the wireless security on your router , I have had issues before connecting Mac's to WEP security make sure you are using WPA
0
 

Author Comment

by:westone
Comment Utility
So far today, since adding a new wireless "Location" in the Mac OS X networking properties, in addition to the default "Automatic" location, I have not experienced any disconnects. It's a little early yet to call it resolved. I'll let it ride as is for a day or two and see how it goes. And I'll let you know.

Thanks for the suggestions.
0
 

Expert Comment

by:goncalogirao
Comment Utility
try the change channel suggestion. This usually hapens when cordless phones are near.
0
 

Author Comment

by:westone
Comment Utility
The location solution greatly improved the issue, but did not eliminate it entirely. The Static IP solution made the issue much worse, with connectivity being lost more often than the original problem.

I am trying the channel solution now, though there are no landlines or radio handsets here. Just a cell phone.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Based on your posts thus far, a new router might be your best solution. You might try getting one, explain your objectives, and ask for the ability to return it if it does not work.

With my new(ish) wireless router, I have no issue with cell phones, landlines or other such gear.

.... Thinkpads_User
0
 

Author Comment

by:westone
Comment Utility
Maybe, but I am not thinking so at this point. Only Apple  OS X Lion wireless devices are experiencing this issue. Android and iOS wireless devices are stable.
0
 

Author Comment

by:westone
Comment Utility
Since setting the wireless router to use a specific channel, instead of "Automatic", the Mac does not connect when waking up. This was not a problem before.
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
>>> the Mac does not connect when waking up  <--- And this is true now of all devices (including Adroid) ?  

... Thinkpads_User
0
 

Author Comment

by:westone
Comment Utility
No, just the Macs. Through all of this the Android has had no problem connecting. Nor has the iPod (iOS), as far as I know. That is my son's device, and he would likely register a complaint if there were an issue.
0
 
LVL 90

Accepted Solution

by:
John Hurst earned 167 total points
Comment Utility
I had an issue (as noted above) where a router would cause issues with some machines and not others. I had to replaced the router to provide long term and permanent fix.

I do not know for MAC's (but I do know for Windows, of course) how you might go about upgrading or replacing the wireless drivers in the MAC. What replacing the driver should do is to replace the wireless profiles and TCP/IP information and settings. It is worth a try.

.... Thinkpads_User
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Thank you, and I was pleased to assist. .... Thinkpads_User
0
 

Author Comment

by:westone
Comment Utility
Update: I never got around to replacing the router after closing this thread. At some point one or more significant updates for OS X came out and were installed, and after that this issue was resolved, no more searching for wireless networks that were already set to be remembered. The Macs and iOS devices now just wake up and are instantly connected to the LAN. Wanted to post this change here in case anyone experiencing the same issue comes across this thread.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

The error "There was an error performing the update" occurred on a Mac OS X client workstation running  Symantec AntiVirus for Mac (http://www.symantec.com/business/products/purchasing.jsp?pcid=pcat_security&pvid=825_1) - the Enterprise product vers…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now