rdp disconnects in windows 7

Posted on 2012-04-08
Last Modified: 2012-06-21
I have a problem where connecting to my system at the office over our vpn results in varying disconnects.  In the system log, I see event 56 for termdd that there was an error in the protocol stream and the client was disconnected.

I've looked at the event data and determined the nt status code is STATUS_IO_TIMEOUT (C00000B5).  It often times does occur when the session is idle, but has also happened when I'm actively using it.  Does anyone know how to fix it?  Registry setting perhaps?

I've already tried updating my network drivers and didn't make a difference.  The adapter is set to auto and connected at 1gb.  The fact that my putty connections to the remote data center don't get disconnected tells me it looks more like something specific to the rdp connection.
Question by:Seth Simmons
  • 3
  • 2

Expert Comment

ID: 37821732
By Any chance are you using a DSL connection? DSL connections by default are prone to jitter. I had a lot of problems with one of our clients accessing our servers. As soon as the jitter goes beyond 600 ms that is lethal for RDP connections. Putty connections usually remain unaffected.

Try a ping - t to the IP where you are trying to connect if you see an inconsistent behavior that it is definitely your internet connection. If this continues, i strongly suggest switching to cable.
LVL 34

Accepted Solution

Seth Simmons earned 0 total points
ID: 37822173
I do have dsl at home connecting through our office vpn (though the vpn connection itself doesn't drop).

I ran a ping test through a batch file with -n 1 and the time stamp so I can see what happened.  The error occurred just after 7pm.  I found the rdp window hadn't updated since then (clock was 2 hours behind) and after clicking around inside it finally said (as it usually does) that the connection was lost and was reconnecting.  I found that event id in there and looking at the ping log (several entries a second), the time was fluctuating between 38-42 then when the connection was lost, it timed out for about 20 seconds then continued at the same time rate (about 40).

One other thing I forgot to mention, when the connection breaks, I notice the network icon has either a yellow ! or a blue circle so it's possible it could be an adapter issue but doesn't break long enough for putty to lose connectivity.  I'm going to try taking my system out of the docking station (it's a dell latitude e6520) and see if it continues using it's own nic.  Open to other ideas if anyone has any.

Expert Comment

ID: 37822673
The fluctuation you have mentioned seems quite normal.

In my opinion, it has come down to two possibilities:

- The ISP
- and your NIC

Now that you'l be using the laptop out of the docking station we will probably get some better verdict on the NIC and after that it will only be the ISP.

Also just eliminate the following possibilities. if you have a wireless router, make sure that it is password protected (WPA2 and not WEP). Also look at Resource Monitor (under All Programs/Accessories/System Tools) and look under the network Tab. You will get to look at the processes consuming your bandwidth. This is just to find out if some piece of software is flooding your network causing you NIC to crash.
LVL 34

Author Comment

by:Seth Simmons
ID: 37840522
i do have wireless router but not connecting that way
since the problem is intermittent, will let it run for a few days and see if it breaks
LVL 34

Author Closing Comment

by:Seth Simmons
ID: 37877357
i took it out of the docking station and hasn't been an issue since; that appears to have been the issue

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
cant ping a windows 10 computer 12 61
ASP.NET 5 Templates 2 77
Problem Copying Folder from Windows 7 Desktop To VMware Workstaton 12 23 60
Cannot Change Local DNS 9 41
One of the features I've come to appreciate about Windows 7 and Windows Server 2008 R2 is the ability to pin applications to the task bar. As useful a feature as I've found this, it does have some quirks.  For example, have you ever tried pinning an…
OfficeMate Freezes on login or does not load after login credentials are input.
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

816 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now