BESX 5.0.3 on SBS 2011 and cannot display webpage (BAS)

Hello, we have a newly installed BESX 5.0.3 on a SBS 2011 server.  We were able to get everything installed accordingly, including SQL 2005, without any errors during installation.  After completion, we tried to open both the Blackberry Administration Service as well as Blackberry Web Desktoop Manager sites; however they both say "Internet Explorer cannot display the webpage"

I checked the BB server configuration and am able to connect to the Database as well as BES online services.  I also updated all BB services in the services list with the BESAdmin AD profile I created as well as logon to SQL server DB, restarted all services; however same issue happens and cannot access BAS.  Anyone have any ideas what else to look for and/or how to fix?  Thanks
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Check the SQL Server Browser service is set to Automatic and is running, think this is a known issue with installing BESx on SBS2011

Open Start - Administrative Tools - Services
Check SQL Server Browser and set to Automatic
bns-nycAuthor Commented:
Thanks for the suggestion smckeown777, but unfortunately it did not work.  I also tried changing the logon profile to using both the Local System account as well as BesAdmin account, but same issue with BAS unable to display.

What's weird is after rebooting the SBS server, I decided to check the services upon startup.  All was started except Blackberry Mail Store now...and it prompts me with a 5406 error now for some reason.  On top of that, when I open up Blackberry Server Configuration and clicked on Edit Mapi Profile to check; it now prompts an error saying "The BES server requires a MAPI profile with appropriate permissions".  This is weird because it didnt say this before the reboot and the BesAdmin looks to have the right permissions from what I can see.

Any other suggestions?  I really want to try and avoid uninstalling / reinstalling BESX again on the SBS 2011 server if possible.  Thanks again
Ok have you seen this link -

Looks like the same error you are receiving, unfortunately his fix was to reinstall I think, but there are multiple links given by other experts to try in that posting...
OWASP: Avoiding Hacker Tricks

Learn to build secure applications from the mindset of the hacker and avoid being exploited.

SriHarsha KTechnical Services SpecialistCommented:
Hi ,
I was the open who created the above link.

- Check if BESAdmin account isn't hidden in GAL.
- Check the versions of MAPI and CDO.dll.
- Check the MAST logs for error ,
Failed to read 001e6602 reg value from the BlackBerry MAPI profile.

- try to delete the MAPI profile from registry and try recreating it..
Note- Do take the registry backup.

---Check the 3 links before performing the activity.

Wish you can solve the issue without reinstalling.

Keep us posted.

bns-nycAuthor Commented:
Ok thanks for the link smckeown777. I guess i'll try re-nstalling BESx again and see the outcome.  Just a quick question though, can I just un-install BESx you think? Or should I uninstall SQL 2005 as well, since I installed it, along with BESx.  

The server already has SQL 2008, but figure I'd go with the defaults and just install everything via the wizard within the BESAdmin domain account.  Thanks
SriHarsha KTechnical Services SpecialistCommented:
before doing the above activity, kindly check if you have met all the required permissions.To be in safe side.

- Also remember not to give any special characters for BESAdmin password.
I'd uninstall 2005 as well, least then you are installing from scratch so nothing else will be missed

I have a working system with 2005 and 2008(which was previously installed as well) running so you should be ok

Also check out @doertalk link as well...
SriHarsha KTechnical Services SpecialistCommented:
-You can gohead with a fresh installation from the start and remember to start the SQLBrowser service after the installation as bydefault it will be stopped and in disabled mode.So you need to change it to Automatic and in started state.

-If you have time then follow my previous update of trying to recreate the MAPI profile.

- Before going for reinstallation,Check the MAST logs for error - "Failed to read 001e6602 reg value from the BlackBerry MAPI profile"
- I got the error so I had to go for re-installation.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bns-nycAuthor Commented:
thanks for the assistance guys. Looks like I'm going to have to un-install / re-install unfortunately.  After deleting and trying to recreate the MAPI, I received a new error and just about had it.  Going to remove and re-install tonight during off hours and hope for the best.  Will advise how it goes and whether or not I run into any other problems..fingers crossed.
SriHarsha KTechnical Services SpecialistCommented:
all the best...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.