Solved

trouble with RWW

Posted on 2012-04-08
11
477 Views
Last Modified: 2012-12-21
Hi
I'm experiencing an issue with remote web workplace on an SBS 2008 server. When I try to connect from outside the office I get the error "Terminal services gateway service is not running".  When I log into the server itself I can connect through that to any machine in the office. I've gone through getting a certificate and setting up a rap but I still get that error. I'm not sure what else to do. Anyone know?
0
Comment
Question by:drewmun
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 14

Expert Comment

by:RickEpnet
ID: 37822331
When you set everything up including when you added the certificate did you use the SBS Wizards?
0
 

Author Comment

by:drewmun
ID: 37822345
I ran through the wizards when I initially set up the server, but have since tweaked some of the settings without using wizards.  The whole set up was somewhat messed up though, because a different company had recovered their previous sbs 2003 setup after a bad crash and everything was somewhat messed up at that point. I took over and did an upgrade to sbs 2008, but kept running into trouble and somewhat ducktaped things together. My plan is to make a new virtual image of their set up at some point, but at the moment I need to get
rww working this week and have not been able to find the right set up.
0
 
LVL 14

Expert Comment

by:RickEpnet
ID: 37822366
Have you checked these services and made sure they are running?
Remote Desktop Configuration
Remote Desktop Gateway
Remote Desktop Services
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 5

Accepted Solution

by:
wtandrews earned 500 total points
ID: 37823148
After having the same problem and driving myself nuts, I ended up contacting Microsoft and working with them for several days. the following is the short version of the resolution. Ultimately, it was the last thing in the resolution that fixed it. Hope it helps. TO my knowledge only the tier 3 MS guys can fix the problem with the applicationhost.config file:


PROBLEM

-      Unable to do RWW, Error: The Terminal Services Gateway Service is not running.

TROUBLESHOOTING

-      Checked the binding on the SBS Web Application they were correct

-      Checked the Certificate on SBS Web Application and Terminal Server, both are same and valid

-      Also followed http://blogs.technet.com/b/sbs/archive/2009/06/15/how-to-configure-the-rww-timeout.asp 
 
"How to Configure the RWW Timeout"

-      Rebooted the server after making the change in the registry, Still we had the same error:-

-      Checked the Event Vwr, shaw Error:- 400
"The TS Gateway service is shutting down. To diagnose possible causes for this problem, verify whether the following services are installed and started: (1) World Wide Web Publishing Service (2) Internet Authentication Service (IAS) (3) RPC/HTTP Load Balancing Service. Also, check Event Viewer for Network Policy Server (NPS) and IIS events that might indicate problems with NPS or IIS."

-      Researched on the issued and got KB 2368713
"SBS2008: Error "The Terminal Services Gateway Service service is not running" when you attempt to connect to a computer through Remote Web Workplace"

-      Followed the article but the configuration was correct.

-      Checked registry key HKLM\Software\Microsoft\Rpc\RpcProxy\Website with the value "SBS Web Applications" was present

-      Researched on the issue found Trend Micro and GFI could be cause, did a clean boot, still had the issue

-      Re-Created RPC and RpcWithCert

1. Remove RPC/HTTP proxy feature from server manager (Rpc and Rpc with Cert v-dirs no longer exist in IIS)

2. Reboot

3. Add the following registry key:

HKLM\SOFTWARE\MICROSOFT\RPC\RpcProxy

String value called "Website" and specify "SBS Web Applications" for the data.

4. Install the RPC/HTTP proxy feature from Server Manager

5. Check the IIS. They should have only been created on the SBS Web Applications site. Make sure that the RPC VDir’s have not been created under Default Web Site.

6. Once this is done RPC should be fixed. But when you remove the RPC feature, you have to remove TSGateway because it is dependent upon it.

7. Install the TSGateway Role Service, select the proper SSL certificate, and create the connection and resource authorization policies as such:

I. General Connection Authorization Policy: User Groups: <Domain>\Domain Users Supported Windows authentication methods: Password, Smart Card

II. General Resource Authorization Policy (2): User Groups: <Domain>\Domain Users Allowed Resources: <Domain>\Domain Computers Port: 3389

III. General Resource Authorization Policy (1): User Groups: <Domain>\Domain Users Allowed Resources: <Domain>\Domain Controllers Port:3389

-      Took C:\Inetpub\Logs\LogFiles\W3SVC3 and Microsoft-Windows-TerminalServices-Gateway/Operational logs

-      Corrected the SSL and Auth. on all the Virtual Directories of SBS Web Application

-      Worked on applicationhost.config file to set the permission to default, issued resolved.


Issue Resolved
0
 

Author Comment

by:drewmun
ID: 37824000
I don't even see these services in the list.

"Have you checked these services and made sure they are running?
Remote Desktop Configuration
Remote Desktop Gateway
Remote Desktop Services"
0
 
LVL 14

Expert Comment

by:RickEpnet
ID: 37824053
Sorry that was SBS 2011 here they are for 2008.

Terminal Services
Terminal Services Configuration
Terminal Services Gateway
Terminal Services UserMode Port Redirector
0
 

Author Comment

by:drewmun
ID: 37824063
Yep all running
0
 
LVL 14

Expert Comment

by:RickEpnet
ID: 37824077
Then I would take a good look at wtandrews post.
0
 

Author Comment

by:drewmun
ID: 37824111
I'm going through the steps now
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 37835845
If you still haven't resolved this, please review http://support.microsoft.com/kb/2368713

Jeff
TechSoEasy
0
 
LVL 8

Expert Comment

by:vSolutionsIT
ID: 38714822
@ wtandrews : Thanks a ton for sharing the solution. In my case the  "Website"  registry key was missing. After hours of work found ur link and bingo :)
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Written by Glen Knight (demazter) as part of a series of how-to articles. Introduction One of the biggest consumers of disk space with Small Business Server 2008(SBS) is Windows Server Update Services, more affectionately known as WSUS. For t…
I work for a company that primarily works with small businesses as their outsourced IT vendor. As such the majority of these customers utilize some version of Small Business Server. Due to the economics of running a small business, many of these cus…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question