SharePoint 2010 Alert Me not sending email notification

There are 2 Web Applications 1) Organization web app;  2) MySite web app.  

Users are able to successfully subscribe Alert Me's and receive email notification from both Web Applications.
 
Email notification is received on the MySite web app when changes occur on announcements, lists and document libraries.

However, no email notification is received on the organization web app when changes occur on any announcement, list or library.  

Both web apps use the same WFE, SMTP and Index servers.
 
I have cleared the Timer Cache and executed the STS ADM commands.

I am perplexed as to why the Alert Me’s work correctly on one web app and not the other when they are both using the same WFE, SMTP and Index servers.  

Any ideas from the experts?
carlosbracamonteAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael CarrilloInformation Systems ManagerCommented:
Have you checked your permissions on the Organization web app?
I would compare the permissions on the My Site web app to the Organization Web app and look for differences.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
carlosbracamonteAuthor Commented:
I compared both web apps and both have contributor and/or read access.  Any other thoughts?
Michael CarrilloInformation Systems ManagerCommented:
What does the 'User Alerts' in the 'Site Settings' show for this web app? (Site Setting, under Site Administration, User Alerts).
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

carlosbracamonteAuthor Commented:
I see  "Display alerts for" users who subscribed to lists for that particuliar site.
Michael CarrilloInformation Systems ManagerCommented:
Can you drill down on any of the users to see if they are in any way configured differently than the users who's alerts are working.
carlosbracamonteAuthor Commented:
Users are domain users and have the same configuration. They have either conributor or read only access for both organization and mysite web apps.  I tested a user with full control and even then list change email notifications are not received on the organization web app and are generated on the mysite web app.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.