ASP .NET site not opening

I am hosting an ASP website developed in VB and back-ended by SQL Express 2005 from a 2003 server.  All was working well until someone uninstalled SQL and the .NET SDK to free up space.  I have reinstalled both, and uninstalled and reinstalled IIS but I can't get any .aspx pages to open- even if I browse from within IIS I get "The page cannot be found".
LVL 2
STS-TechAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
STS-TechConnect With a Mentor Author Commented:
Got it.  The solution was here:
Web Service Extension activation
0
 
Meir RivkinFull stack Software EngineerCommented:
check if the physical path is correct (point to where your aspx pages are).
make sure app pool is running and you sire is configured to run with this app pool.
0
 
Meir RivkinFull stack Software EngineerCommented:
if you navigate to "localhost" in your browser,do you see the default IIS page?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
STS-TechAuthor Commented:
I did check the path and then created a new folder on the root of C: and added a new virtual directory pointing to it- same result.  I can open the default IIS "Under Contruction" page and can even open html and jpg files from the virtual directory just not aspx.
0
 
Meir RivkinFull stack Software EngineerCommented:
IIS 7?
0
 
STS-TechAuthor Commented:
IIS 6... which I uninstalled last night- but when trying to reinstall (all remotely) I got tired of hunting down dll files so I will have to have that done today.
0
 
Meir RivkinFull stack Software EngineerCommented:
do u have web.config in the folder where the aspx resides?
0
 
STS-TechAuthor Commented:
I do not.  There was one there but I removed it and now that I have reinstalled IIS (again) and re-ran the aspnet_regiis (again) aaaaaand re-created the virtual directory...

There is no webconfig either in the app folder (C:\JobMananger) or in the default location (C:\inetpub\webroot).
0
 
STS-TechAuthor Commented:
More info:

Attempting to open http://localhost gives me "The website declined to show this webpage"

Attempting to open http://localhost/localstart.asp produces "Page could not be found".
0
 
Meir RivkinFull stack Software EngineerCommented:
was it prohibited by default?
0
 
STS-TechAuthor Commented:
Yes- which I found curious.  You'd think installing the SDK or adding a Virtual Directory would let IIS know you wanted those things to work.
0
 
STS-TechAuthor Commented:
Information on the needed setting was found online.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.