Exchange 2010 redirect /Exchange to /OWA

After installing SBS 2011 and moving all our users mailboxes to Exchange 2010, when I access https://www.domain.com/exchange I get the "Server Error in '/' Application..." page.  When I access https://www.domain.com/owa, I can login fine.  /Exchweb & /Public throw the same error.

 I've redirected the default web site to OWA and gone through this tech article (and many others I might add):

Still no luck.  Hoping someone can offer up some suggestions other than what I've tried for past two hours!
ThinkNetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DLeaverCommented:
I had this recently and despite the content out there on this it took some finding to get a solution, I can't find the article I was using but I think it was as follows

Browse to the Exchange install directory C:\program files\microsoft\Exchange server\v14\client access and create a folder here called Exchange

Then go to IIS7 >> expand default web site and select Exchange VD >> then from the action pane choose advanced.  By default this will be set to the same path but finishing with OWA

Remove the OWA part and enter Exchange at the end so it points to the new folder (C:\program files\microsoft\Exchange server\v14\clientaccess\Exchange)

Make sure your redirection for Exchange points to just /OWA

IIsreset

I checked over my Exchange box just to confirm Im not giving you duff instructions

*Original credit goes to a Technet post but I can't locate it - if I do I'll post it

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ThinkNetAuthor Commented:
Tried your suggestion but /Exchange now shows a 500 error and /OWA breaks telling me that the webpage cannot be displayed.
ThinkNetAuthor Commented:
If I change the redirect for Exchange and point it to /OWA, then /OWA, /Exchweb & /Public all change to to /OWA.  Opening the https://www.domain.com/OWA in Firefox now reports that the page is causing a loop.  So I'm back to no redirect on any of the above virtual directories and the origian "Server Error in '/' Application..." page.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

DLeaverCommented:
???????????????

Well OWA shouldn't have any redirection, it may have the URL in there (https://mail.mydomain.com/owa) but shouldn't have redirection

Public and Exchweb should have the full URL and redirection enabled to OWA

And Exchange should be setup as I outline above

*Also the default web site should have no redirection
ThinkNetAuthor Commented:
What I tried to explain in my previous post is that when I change the redirect settings for the OWA directory, the settings for Public and Exchweb also change.  It's as if they are one and the same.  I cannot change them independently.  I might add that I'm using the IIS Manager GUI to make these changes.  Should I be using appcmd commands instead?
DLeaverCommented:
No the GUI is fine

If you set the OWA redirect to https://internalserver.domain.local/owa, then this will apply to the other two directories as well - the only difference is you don't put a tick in the box of the OWA redirection settings - if it goes in after setting it then take it out, the other two directories should stay valid.

Ensure there is nothing set in the Default web sites redirection as this may get inherited
ThinkNetAuthor Commented:
OK, something has changed.  I'm now getting a the 500 - Internal Server Error on /Exchange, but my /OWA directory seems fine.
DLeaverCommented:
Cool, now try the Exchange setup as I outline in my first post

None of the other VD's or VA's redirects should be edited or changed
ThinkNetAuthor Commented:
I already had the Client Access/Exchange directory in place and the virtual directory's physical path was pointing there.  I checked the permissions on the directory and granted Authenticated Users read permissions and bingo the redirect works!
ThinkNetAuthor Commented:
/Exchweb and /Public have the same issue.  Should I employ the same tactic on these virtual directories?  One user has /exchweb bookmarked and they are still seeing the error.
DLeaverCommented:
Happy Days!!...despite the slightly brown trouser moment when I thought I had bust your CAS it was all good:-)

I think the permission element was the missing part from the article, I still can't find it.......
DLeaverCommented:
I haven't tried it so I won't say go for it but you can se how siple the redirect setup is now that if it fails then failing back to how it was before isn't too hard if it doesn't succeed...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.