Companyweb isn't working on sbs 2008 server

I installed and sbs 2008 server and at first the companyweb was working.  Then, a few days later, it stopped as follows:

I type http://companyweb in a browser, and it responds "Cannot connect to the configuration database"

This is the response on the server.  Naturally, none of the client computers get the companyweb anymore either.

How do I bring it back?

The internet is working and connected in general.  The firewall is turned off.
ken_bAsked:
Who is Participating?
 
ken_bConnect With a Mentor Author Commented:
So, re sharepoint, i have confirmed that the server is running Sharepoint 3.0.  I don't know how to confirm whether a sharepoint update or service pack has run or not.  I looked at the SBS tech article mentioned and attempted the troubleshooting described in the ariticle.  Ran into a wall when I entered the string in paragraph b but it wouldn't connect because I didn't have the password.  I will try to locate the password and try again unless someone know of a way without.

Re the last comment posted, I did not see a screenshop attached, and so don't understand the comment.  I am operating directly from the server (inside the lan).

More help would be appreciated.
0
 
tobywestonCommented:
Have you just installed Sharepoint 3 SP2?

I had this happen to me after that and used the following to remedy it:

http://blogs.technet.com/b/sbs/archive/2009/05/06/companyweb-inaccessible-after-sharepoint-3-0-service-pack-2.aspx
0
 
sbodnarCommented:
check the binding for :987 in IIS

and also make sure your firewall port is open for port 987
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
ken_bAuthor Commented:
Thank you for the two responses.  

I am going to check on a sharepoint update and will report back.  This is possible.

Re IIS 987,  I will go into IIS but it would be helpful if you could kindly describe more of what to look for there.  Screen shots possibly?  I find the IIS somewhat confusing.

Re the firewall port, can this still be a problem if my server firewall is off?
0
 
sbodnarCommented:
I have attached a screen shot.

Make sure that it is pointing to the IP address of your Sharpoint server which I am assuming is a 192.168. **.** address.

Even though its turned off the firewall may still block. Are you trying to connect from outside or inside your LAN?
0
 
ken_bAuthor Commented:
I never really got the question answered
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.