Mac connecting to Windows server

I have a Mac on a Windows network. We recently upgraded from a Microsoft SBS 2003 server to a MS SBS 2011. Now I am unable to log in to the server. I can see it and am prompted for the password, but it doesnt work.
zelfanetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kanalQkoTechnical Support EngineerCommented:
could you provide more details, what do u mean "I am unable to log in to the server"? Are you connecting via Remote Desktop or samba share?
please write more details what are you doing.

you must use:

domain\username
password

i don`t have sbs 2011, i`m using win2k8r2 sp1, several osx are connecting to shares, to AD, etc, and I`m not facing any issue
0
zelfanetAuthor Commented:
I am trying to connect on the same network, not with remote desktop. I click on 'go' then find the server, then it prompts me for me credentials (just like with sbs 2003) but it wont let me connect.
0
kanalQkoTechnical Support EngineerCommented:
now it`s more clear, so you are trying to access share via Finder, okay open Console (Go > Utilities > Console), connect to server again, if it will refuse connection in console should be some error, paste this error log here. Are you able to authenticate to server from windows workstations?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

zelfanetAuthor Commented:
Yes, all of the windows pc's are fine.
0
kanalQkoTechnical Support EngineerCommented:
okay, so it`d be issue related only to osx, please do the things I wrote you above. Then we will able to continue
0
R. Andrew KoffronCommented:
somtimes you have to put the dot local in the username.

DomainName.Local\UserName

you can also join the SBS VPN if you need secure access.
0
kanalQkoTechnical Support EngineerCommented:
@Harell66 ... I wrote the same DomainName\Username, off course it would be better to use FQDN, full domain name could be also contoso.com, etc..not only "domainname.local" as you wrote

;-)
0
zelfanetAuthor Commented:
Menu
GO
Connect to Server
Address: SMB://192.168.1.12
Connect
Connecting ….
Prompt: SMB/CIFS File System authentication
 
Asks for:
Workgroup or Domain:
smithco
 
Name:
Msmith
 
PW:
Smitty210
 
 
Prompt:  Could not connect to the server because the name or pw is not correct
 
 
That’s it
Tried various things but same msg

I tried domain.local on the top, domain\name and other configs. This worked perfectly with the old server. Has something changed in 2011 SBS ??
0
kanalQkoTechnical Support EngineerCommented:
which version of osx are u using, it seems to be tiger, am I right?

try tow different ways

1. In field Workgroup or Domain enter FQDN of your domain name and then enter username and password again
2. Leave field Workgroup or Domain blank, and in field username enter "smithco\Msmith" and then password again

could you copy paste "ipconfig /all from your server"

please let us know results

thanks
0
R. Andrew KoffronCommented:
as kanalQko suggested in 2:

also try field username enter "smithco.local\Msmith" or "smithco.com\Msmith" witch-ever is appropriate.
0
zelfanetAuthor Commented:
Any other ideas, anything else? I gotta see this stuff from the Mac?
0
kanalQkoTechnical Support EngineerCommented:
try reset Finder to default, also provide output of "ipconfig /all" or let us what`s your dns suffix
0
zelfanetAuthor Commented:
suffix is .local
0
zelfanetAuthor Commented:
I did this, which I got from another forum and it worked perfectly:

To do so, all you have to do is add the following registry key: REG_DWORD named “smb2” with a value of 0 to HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters.  Reboot the server and you’re all set.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kanalQkoTechnical Support EngineerCommented:
good to know, that you have already solved it, I`m using OS X Lion, and there`s no such issue as you had
0
zelfanetAuthor Commented:
Nobody else gave the correct answer so I found it on my own.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.