iPad not working with Exchange 2010 and ActiveSync

I have an iPad with IOS 5.1 on it.  I have configured Mail to work with an exchange server and when I got to verify the account settings everything works fine.  However, when I go into the Mail app the email never downloads and eventually I get an error that States: "Cannot Get Mail.  The connection to the server failed."

What am I missing here?  Is the device automatically being accepted in the ActiveSync portion of Exchange?  How do I tell?  And why does all the account verification work, but I don't receive email to the iPad?
TPBPITAsked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
There is a supposed workaround listed in the following link:

http://retrohack.com/enable-activesync-outlook-anywhere-exchange-2010/

The following page discusses Quarantine settings:

http://blogs.technet.com/b/exchange/archive/2010/11/15/3411539.aspx
0
 
Alan HardistyCo-OwnerCommented:
Please check your inherited permissions / group membership as per my article:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2861-Activesync-Working-But-Only-For-Some-Users-On-Exchange-2007-2010.html

If all checks out okay - then please visit https://testexchangeconnectivity.com and run the Exchange Activesync test and post the results (hiding your domain name / IP Address.

Alan
0
 
TPBPITAuthor Commented:
That was it as I'm a domain admin.  Is there anyway around that setting being change back beside to have two accounts?

Second, ActiveSync sees my device, but it is put into Quarantine.  How do I stop devices from going to Quarantine and have the automatically accepted?
0
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
If you run the following EMS command you should see the default domain settings:

Get-ActiveSyncOrganizationSettings -Identity "Yourdomain.com"

You can then set the server to allow / block or quarantine by running the following command:

Set-ActiveSyncOrganizationSettings -DefaultAccessLevel {allowed / blocked / quarantined}

So to allow all devices, run the following command:

Set-ActiveSyncOrganizationSettings -DefaultAccessLevel allowed
0
 
TPBPITAuthor Commented:
Thanks for the quick responses.  These worked great!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.