Solved

Site to site tunnel between two ASAs

Posted on 2012-04-09
3
986 Views
Last Modified: 2012-04-11
I'm trying to set up a site to site tunnel between two ASA's, one version 8.4 and the other 8.2.

I've attached the configs. If someone can tell me what I'm doing wrong I'd appreciate it!

ASA Version 8.2(1)
!
hostname ASA2
enable password frQcREklRfuG2ckI encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.10.2 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 30.31.32.2 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list firewall-in extended permit icmp any any
access-list CRYPTO extended permit ip 10.10.10.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list TUNNELACL standard permit 10.10.10.0 255.255.255.0
pager lines 24
logging console debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPOOL 10.10.20.5-10.10.20.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list CRYPTO
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 88.88.88.88 10.10.10.5 netmask 255.255.255.255
access-group firewall-in in interface outside
route outside 0.0.0.0 0.0.0.0 30.31.32.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set MYSET esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map CRYPTOMAP 1 match address CRYPTO
crypto map CRYPTOMAP 1 set pfs group1
crypto map CRYPTOMAP 1 set peer 20.21.22.2
crypto map CRYPTOMAP 1 set transform-set MYSET
crypto map CRYPTOMAP 1 set reverse-route
crypto map CRYPTOMAP interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.10.10.5-10.10.10.15 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DfltGrpPolicy attributes
 split-tunnel-policy tunnelspecified
 default-domain value test.com
group-policy ASAVPN internal
group-policy ASAVPN attributes
 ip-comp enable
 split-tunnel-policy tunnelspecified
username synapse password 2ltSVs6IjNh.KXY8 encrypted privilege 15
tunnel-group 20.21.22.2 type ipsec-l2l
tunnel-group 20.21.22.2 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:8f8222765bec3801e3844508c46e8bd0
: end
========================================================================
ASA Version 8.4(3)
!
hostname ASA1
enable password 3a57ZsZ4Kgc.ZsL0 encrypted
passwd 3a57ZsZ4Kgc.ZsL0 encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif INSIDE
 security-level 100
 ip address 192.168.1.2 255.255.255.0
!
interface Vlan2
 nameif OUTSIDE
 security-level 0
 ip address 20.21.22.2 255.255.255.0
!
ftp mode passive
object network ALL
 subnet 0.0.0.0 0.0.0.0
object network LOCAL
 subnet 192.168.1.0 255.255.255.0
object network REMOTE
 subnet 10.10.10.0 255.255.255.0
access-list firewall-in extended permit icmp any any
access-list firewall-in extended permit ip any any
access-list CRYPTO extended permit ip 192.168.1.0 255.255.255.0 10.10.10.0 255.255.255.0
pager lines 24
mtu INSIDE 1500
mtu OUTSIDE 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any INSIDE
icmp permit any OUTSIDE
asdm image disk0:/asdm-647.bin
no asdm history enable
arp timeout 14400
nat (INSIDE,OUTSIDE) source dynamic ALL interface
nat (INSIDE,OUTSIDE) source static LOCAL LOCAL destination static REMOTE REMOTE
access-group firewall-in in interface OUTSIDE
route OUTSIDE 0.0.0.0 0.0.0.0 20.21.22.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 0.0.0.0 0.0.0.0 INSIDE
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set MYSET esp-3des esp-sha-hmac
crypto map CRYPTOMAP 1 match address CRYPTO
crypto map CRYPTOMAP 1 set pfs group1
crypto map CRYPTOMAP 1 set peer 30.31.32.2
crypto map CRYPTOMAP 1 set ikev1 transform-set MYSET
crypto map CRYPTOMAP interface OUTSIDE
crypto ikev1 enable OUTSIDE
crypto ikev1 policy 1
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd address 192.168.1.10-192.168.1.33 INSIDE
dhcpd enable INSIDE
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy ASAVPN internal
group-policy ASAVPN attributes
 vpn-tunnel-protocol ikev1
username synapse password 2ltSVs6IjNh.KXY8 encrypted
tunnel-group 30.31.32.2 type ipsec-l2l
tunnel-group 30.31.32.2 general-attributes
 default-group-policy ASAVPN
tunnel-group 30.31.32.2 ipsec-attributes
 ikev1 pre-shared-key *****
!
!
prompt hostname context
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:63576b0a2af0109f9d6bf21b96ba3975
: end
ASA1#
0
Comment
Question by:jtipton
  • 2
3 Comments
 

Author Comment

by:jtipton
ID: 37825989
Attached is the lab drawing I threw together. It is basically just a router (Internet) in between two ASA's.
VPN-LAB.png
0
 
LVL 17

Accepted Solution

by:
Kvistofta earned 500 total points
ID: 37826447
These 2 lines:


nat (INSIDE,OUTSIDE) source dynamic ALL interface
nat (INSIDE,OUTSIDE) source static LOCAL LOCAL destination static REMOTE REMOTE


They are processed from top to bottom in specified order. That means that the second line is never used. Change like this:

no nat (INSIDE,OUTSIDE) source dynamic ALL interface
object network LOCAL
 nat (inside,outside) dynamic interface
clear xlat

... and try again. For further support, make sure that you enable "deb cry isakmp" and "deb cry ipsec", and post the output here after  generating traffic that should go into the vpn-tunnel.

Best regards
Kvistofta
0
 

Author Closing Comment

by:jtipton
ID: 37835650
Great, thanks a lot Kvistofta. That was the problem! That is something I've read before, but knowing about something and knowing how to use it are two different things.

Thanks again!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Some of you may have heard that SonicWALL has finally released an app for iOS devices giving us long awaited connectivity for our iPhone's, iPod's, and iPad's. This guide is just a quick rundown on how to get up and running quickly using the app. …
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now