GBIC doesn't come up on Cisco WS-C3560G-48TS-S

I have two offices next to each other.  I ran two fiber lines between them.  One connects to a WS-C3560G-48TS-S and the other connects to a  WS-C2960G-48TC-L.  The C2960's GBIC works and when I connect it, but when I connect that same connection to the 3560G it doesn't come up.  Both interfaces are configured the same.  I've tried the GBIC in all 4 of the 3560's ports all with the same configuration, but they don't come up.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sergsystem administratorCommented:
What type of GBIC are you using?
Don't forget: each port must match the wave-length specifications on the other end of the cable, and for reliable communications, the cable must not exceed the stipulated cable length.
LrdKanienAuthor Commented:
The GBIC is a GLC-LH-SM.

Cisco site says 1000BASE-LX/LH SFP transceiver module for MMF and SMF, 1300-nm wavelength, dual LC/PC connector.

What do you think my config for the interface should be?

One side is configured like this:

interface GigabitEthernet 0/49
switchport trunk encapsulation dot1q
switchport trunk native vlan 600
switchport mode trunk
               speed nonegotiate
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
               mls qos trust dscp
               auto qos voip trust
Sergsystem administratorCommented:
(Sorry for my English)
For troubleshooting try to replace "speed nonegotiate" to "speed auto".
And don't forget "no shut" of course =)
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Can you plug the GBIC into the 3560 and do a "show interface status" command and post the output? What GBIC do you have on the other side of the link?
LrdKanienAuthor Commented:
Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/49                       notconnect   1            auto   auto 1000BaseLX SFP

I believe they are the same GBIC's on all devices.

Follow me with this, I take the working GBIC from the 2960 and plug it into the 3560 and it doesn't work.  Why?  

I take the not working GBIC from the 3560 and plug it into the 2960 and it works.  Why?

We solve that and this is done.
The 3560 does seem to recognize the SFP. When you say that the SFP works on the 2960: what device is on the other side of the link? Do you use the same fibre cable for the link test?
LrdKanienAuthor Commented:
Yes, same fiber cable.  I simply unplugged the gbic and plug it into the 3560.  Neither work on the 3560, both work on the 2960.  I have two 3560's and neither work on either 3560, all of 4 of the slots on both all don't work.

There has to be some kind of configuration change specific to the 3560.  Whether I enable a trunk, specific encaps, etc.  It never comes up as connected.
Sorry, I still don't see how your connections look. You have two connections that end on a 2960. What device(s) is on the other side of the fiber cables? Is this a router, another switch, a firewall or something else?

Can you post a show version and show run of the 3560 and a show run of the fiber interfaces of the 2960?
LrdKanienAuthor Commented:
Ok, let me try to explain again.  There are 2 fibers ran between my offices.  On each side are switches.  The fiber that works on my 2960 doesn't work on my 3560.  If I take the fiber that was ran into my 3560 and plug it into my 2960 it works.

side a                                                          side b
3560 <-------------------- fiber ---------------> switch (doesn't work when connected to 3560, works when connected to 2960)
2960 <-------------------- fiber ---------------> switch (works when connected to 2960, doesn't work when connected to 3560)

That help?  Neither of the interfaces have any configuration on side a.
I sure understand that it does not work with the 3560. But what I am interested in is the switch in side b. What brand and type of switch is this? How does its configuration look?

And again: please send show version and show run of 3560 and 2960.
What is the brand of the GBIC? I've seen issues where a 6500 will not support 3rd  party GBICs. Might be the same.
LrdKanienAuthor Commented:
added speed nonegotiate on the 3560 and it came up.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LrdKanienAuthor Commented:
it was the solution
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.