Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1020
  • Last Modified:

Subform won't allow additions on MS Access 2010 but will in MS Access 2007

I have an MS Access application that was developed in 2003, then further enhanced in 2007 and now being run on 2010. One of my forms has a subform that in versions 2003 and 2007 will allow additions but when run in MS Access 2010 the subform won't allow additions. Does anyone know what may have changed to cause this odd behaviour and what I can do to fix?
0
Rob4077
Asked:
Rob4077
5 Solutions
 
als315Commented:
Never had this problem with Access 2010. May be you can upload your forms and tables with sample data?
0
 
Jeffrey CoachmanCommented:
<One of my forms has a subform that in versions 2003 and 2007 will allow additions but when run in MS Access 2010 the subform won't allow additions. >
Please be clear.
How are you adding New records?
    Via a button you inserted? (If so, what is the code)
    Via the built in New record button?
        If so, is the button active, or greyed out.
            If it is active, what happens when you click it?
Any errors?
Record added, but not saved...

Just saying "Subform won't allow additions", does not tell the whole story...

JeffCoachman
0
 
Rob4077Author Commented:
Hi Jeff. Sorry to be unclear. The sub form has the standard access record selectors and a add new record button button at the end of the list of records. When I run the app using 2007 the button is active and works. When I run it on 2010 the button is inactive. I am using the same backend and front end on both.

Based on comments coming back this shouldn't be happening so I will need to completely review my table structures and see if there's something that's creeping through on older versions but being captured by the latest version access.
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
Jeffrey CoachmanCommented:
Also is the button "always" greyed out, or only under certain circumstances?
What if you open the subform on its own?

Is this an issue for all users?
For all Computers?

Look for any code that sets "Allow Additions" to False


I am curious as well...

Keep us posted...


;-)

JeffCoachman
0
 
Boyd (HiTechCoach) Trimmell, Microsoft Access MVPCommented:
I have seen others having similar issues with Access 2010.  To help reproduce the issue, do you have the 2010 SP1 update installed?
0
 
Rob4077Author Commented:
I am relieved to hear that others have had similar issues. Unfortunately this user migrated to MS Access 2010 without telling me and I actually don't have MS Access 2010 on my installation so I need to do all my testing remotely on their system. My remote test machine is using version 14.0.6112.5000 (32 Bit). Now that I look at the version information I note that on the test machine they've allocated to me it is an unlicenced version. Not sure if that means there are some limitations. I will have to check all the other machines having this problem to see if any of them have SP1 installed and to make sure they're running licensed versions.

At this stage I am going to assume that the issue is not a known issue with 2010 that is easily fixed and so it will need considerable additional investigation. I am going to a training course all next week and need to spend the next few days preparing for it so I won't have time to review and fix until week after next. I don't like leaving questions open for that amount of time so I think it best if I close out the question now and thank all of you for your support. I will post an update later when I find out the ultimate cause.

Thanks for your kind assistance.
0
 
Rob4077Author Commented:
Forgot to answer:
>>Is the button "always" greyed out, or only under certain circumstances?
Always greyed out

>>What if you open the subform on its own?
Button is still greyed out

>>Is this an issue for all users?
>>For all Computers?
Only tested on two machines and same problem exists for both

>>Look for any code that sets "Allow Additions" to False
Checked for that and Allow Additions is set to Yes
0
 
Rob4077Author Commented:
In case you're wondering, the record source is not a query but just a table
0
 
Jeffrey CoachmanCommented:
<Will post the resolution later when I discover it>
Then there was no need to close the question...
0
 
Rob4077Author Commented:
Jeff, only closed it out to avoid keeping a question open and unattended for 2 weeks.
0
 
Jeffrey CoachmanCommented:
<Jeff, only closed it out to avoid keeping a question open and unattended for 2 weeks.>
This is not really a reason to accept posts that do not resolve the issue...
Only close a question if it has been resolved.
Nobody here was rushing you...

Otherwise just ask that the Q be deleted.
0
 
Rob4077Author Commented:
I have left questions open before and after a few days I get advised that I should close the question down or it will be closed for me. I try not to clutter the system unnecessarily.

The answers provided did lead to the solution I needed in the immediate term. I knew I had limited time to look into this but I wondered if there may have been an easy and immediate fix  (e.g. I recently discovered that I simply had to change a setting on another software package I use to make it backwards compatible after an upgrade) and I have no knowledge of the differences between 2010 and 2007 Access. There wasn't but there were a few anomalies for me to look into, i.e. SP1. I asked the user to upgrade immediately but he hasn't replied to me yet either.

 I apologise if my closing the question seemingly prematurely has annoyed you but I think its unfair to leave an open question in the system too long while the person asking finds time to work on the suggestions. I value the support I get from EE Experts too much to add to their annoyance by doing that.
0
 
Rob4077Author Commented:
Thanks to helping me work through this one. Will post the resolution later when I discover it
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now