Exchange 2010 and IIS 7

Hi Experts:

I am running a SBS 2011 with Exchange 2010 and IIS 7.  Everything was working very well until I had some trouble installing an SSL Cert. for  I was able to install it, but it would never show up in the pull down to bind it.  After several attempts, I started having problems with the default website.  Now when I execute EMC, I get the following error: "The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available.  This is usually returned by a HTTP server that does not support the WS-Management Protocol."

I have done some searches on this, but was unsuccessful trying the suggestions.  I am familiar with Exchange 2010 and IIS, but am not an expert with them by any means.  Any assistance on this would be greatly appreciated.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Abbas HaidarSenior Infrastructure ManagerCommented:
have you tried to install the SSL certificate using the SBS console?
In a SBS environment the key to it all is to always use the wizards. Though in a regular server 2008R2 environment you "could" do it the way you suggest, the proper way would be to do it through EMC. However, in SBS you always want to use the wizard. My suggestion would be to delete the cert and everything you have done thus far in IIS-as it is going to cause you a large headache and more issues than it is worth. You are going to need to have the cert re-keyed because the wizard will key the CSR for you.

In the console navigate to "Network", "Connectivity", and then select "Add a trusted Certificate". Follow the wizard to key the CSR for you. The main reason you are doing it through the wizard is because it is applying it to places outside of IIS, and if not done correctly can break things-as ou have experienced.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sntrouble07Author Commented:
Ok.  I have deleted the original cert, re-keyed it using the wizard, dowloaded, and installed it (again using the wizard).  Things have changed a bit, but not really any better.  When attempting to access the remote web site, it prompts you with a pop up user name, and password.  Once entered, next page is ie cannot display this page.  The EMC is still giving the original error.  Also.  I cannot complete the "connect to the internet" wizard.  It says it cannot configure my e-mail.  Originally that worked fine, and I was able to setup my .com with the e-mail working well for each user.  Oddly enough, e-mail is still working well.  I've also tried running the fix network wizard, but it will not fix my problem (The original EMC error).

I really wish I had used the ssl cert wizard originally.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Have you run an IISReset as well as restarting your server?

sntrouble07Author Commented:
sntrouble07Author Commented:
Thank you, but they were of no assistance in correcting the problem.  On the second link, my AV popped up immediately with a threat so I chose not to view it.  I generally exaust all possible searches before posting a question.

Anyway, I chose to review a previous SBS 2011 installation that went well and is currently working.  In IIS, I found within the company website there was an https bound to the cert I deleted, rekeyed, and attempted installing on the default website.  I don't know how it got there.  I can only assume I made a mistake.  I chose to remove it, and immediately EMC worked perfectly.  I then removed the Cert again, re-keyed, and installed via the wizard.

I appreciate your help as it pointed me in the right direction.
glad it helped.
sorry about that link... it did the same to me today, but not yesterday.... odd.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.