Solved

Setting up a Trunk for 2 VLAN on Cisco IE3000

Posted on 2012-04-10
2
1,025 Views
Last Modified: 2012-06-26
I have a Ciscio IE3000.  I have ports Fa1/1 - fa1/4 VLAN10 and Fa1/5-1/8 VLAN10.  I am trying to configure Gi1/1 as a Trunk for both VLAN 10 and 20.  Below is my command that i used and when I run the SHO VLAN BRIEF command the switch only assigns VLAN20 to gi1/1.

How do I assign gi1/1 to be a trunk for VLAN10 and VLAN 20.

Thanks!

Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int gi1/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport access vlan 20
Switch(config-if)#switchport trunk native vlan 10
Switch(config-if)#switchport trunk native vlan 20
Switch(config-if)#end
Switch#
Switch#sho vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/2
10   vlan_10                          active    Fa1/1, Fa1/2, Fa1/3, Fa1/4
20   vlan_20                          active    Fa1/5, Fa1/6, Fa1/7, Fa1/8
                                                Gi1/1
1000 xsetup_vlan                      active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Open in new window

0
Comment
Question by:Donald_Gibson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 15

Accepted Solution

by:
Nayyar HH (CCIE RS) earned 250 total points
ID: 37827363
Verify trunk status with

show interface trunk



Interface trunk configuration

int g1/1
switchport mode trunk
switchport trunk encapsulation dot1q


Both ends of the trunk need to be configured symmetrically
0
 
LVL 2

Assisted Solution

by:compbatty
compbatty earned 250 total points
ID: 37831385
There are 2 options available for you. As you also have a port allocated to VLAN 1 if you do not want VLAN 1 trunked you can use the first config alternatively if this does not matter you can use the second.

Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int gi1/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 10,20
Switch(config-if)#end

or

Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int gi1/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#encapsulation dot1q
Switch(config-if)#end

As long as you configure both end of the trunk the same way it will allow both VLANs through.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Layer 3 switch recommendation 15 99
Tracert fails final hop at some client offices 3 47
Router speed limit 7 105
can you connect modem to 2 routers 42 24
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question