Solved

msaccess report hangs when you add several control sources  and delete the text box attached

Posted on 2012-04-10
13
389 Views
Last Modified: 2012-04-10
have a funny problem
have the report set up working fine running off a query, and dispplays ok, then if i add another field from the field list then delete the txt box attached to the field, the report just hangs and does nothing . close it open it do the same again and it hangs again

have rebuilt and also imported the db into a clean data base but makes no difference
any ideas
taserror.png
0
Comment
Question by:sydneyguy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
13 Comments
 
LVL 120

Expert Comment

by:Rey Obrero (Capricorn1)
ID: 37827423
why the need to delete the textbox?, if you don't want to see the field as part of the report, size the textbox to a minimum.
run the report..

could it be that the textbox is referenced in any calculation?
0
 
LVL 74

Expert Comment

by:Jeffrey Coachman
ID: 37827656
Also it is not clear what your screenshot is supposed to be telling us?
(why the overlapping controls?)

FWIW, anytime I make design changes to an object, I run the compact/repair utility.
0
 

Author Comment

by:sydneyguy
ID: 37827669
the text box is not referneced in any calculation, its the text of the bound field, and you may not always need the text and in this case i do not need them, or i may want to move it , and this has never happened before, normally works fine except for this time.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:sydneyguy
ID: 37827683
i have never needed to run the compile any time i have made a change, never needed this before.
the overlaping control is one that i droped on then run it and it displays, then you delete the text associated to the text object and it freezzes never seen this before
0
 
LVL 120

Expert Comment

by:Rey Obrero (Capricorn1)
ID: 37827735
could be a corrupted report.. try to make a new report.
0
 

Author Comment

by:sydneyguy
ID: 37827746
i did, 3rd thing that i did, even rebuilt a system using min components and it still happens
have just found out that if i copy the objects to another report it actiually behaves and alows me to delete the text and still works
0
 
LVL 120

Expert Comment

by:Rey Obrero (Capricorn1)
ID: 37827756
what version of office are you using?
is it updated to the latest SP?
0
 

Author Comment

by:sydneyguy
ID: 37827926
2003,
but dont think this is the problem it wa happening another pc running 2007,
i think i will just rebuild all the reports in question and try and build aroudn the prop and see how that goes, before i strat chasing after updates, just never seen this before
0
 
LVL 74

Accepted Solution

by:
Jeffrey Coachman earned 250 total points
ID: 37827939
<i have never needed to run the compile any time i have made a change, never needed this before.>
That could be part of the problem.
You should always compile your code after editing sessions.
In addition to cleaning up the modules for faster execution, it will identify some common coding syntax errors.
See # 5 and #6 here:
http://www.everythingaccess.com/tutorials.asp?ID=Preventing-corruption

Not saying that this will fix your issue here, only that you should try all the basic troubleshooting techniques, just to be sure...
0
 
LVL 120

Expert Comment

by:Rey Obrero (Capricorn1)
ID: 37827943
ok..
0
 

Author Comment

by:sydneyguy
ID: 37827988
the system probably has some curruption in it, as it is an unstable network and have had to change machines quite oftern under extreme power off situations, so the link page above has been very useful so thanks for that
0
 
LVL 120

Assisted Solution

by:Rey Obrero (Capricorn1)
Rey Obrero (Capricorn1) earned 250 total points
ID: 37828010
<as it is an unstable network and have had to change machines quite oftern under extreme power off situations>

this situation will corrupt your application, tables, forms and reports
0
 

Author Closing Comment

by:sydneyguy
ID: 37828030
thanks for the help
0

Featured Post

Enroll in June's Course of the Month

June's Course of the Month is now available! Every 10 seconds, a consumer gets hit with ransomware. Refresh your knowledge of ransomware best practices by enrolling in this month's complimentary course for Premium Members, Team Accounts, and Qualified Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
It’s the first day of March, the weather is starting to warm up and the excitement of the upcoming St. Patrick’s Day holiday can be felt throughout the world.
The viewer will learn how to simulate a series of coin tosses with the rand() function and learn how to make these “tosses” depend on a predetermined probability. Flipping Coins in Excel: Enter =RAND() into cell A2: Recalculate the random variable…
The view will learn how to download and install SIMTOOLS and FORMLIST into Excel, how to use SIMTOOLS to generate a Monte Carlo simulation of 30 sales calls, and how to calculate the conditional probability based on the results of the Monte Carlo …

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question