msaccess report hangs when you add several control sources and delete the text box attached

have a funny problem
have the report set up working fine running off a query, and dispplays ok, then if i add another field from the field list then delete the txt box attached to the field, the report just hangs and does nothing . close it open it do the same again and it hangs again

have rebuilt and also imported the db into a clean data base but makes no difference
any ideas
taserror.png
sydneyguyAsked:
Who is Participating?
 
Jeffrey CoachmanMIS LiasonCommented:
<i have never needed to run the compile any time i have made a change, never needed this before.>
That could be part of the problem.
You should always compile your code after editing sessions.
In addition to cleaning up the modules for faster execution, it will identify some common coding syntax errors.
See # 5 and #6 here:
http://www.everythingaccess.com/tutorials.asp?ID=Preventing-corruption

Not saying that this will fix your issue here, only that you should try all the basic troubleshooting techniques, just to be sure...
0
 
Rey Obrero (Capricorn1)Commented:
why the need to delete the textbox?, if you don't want to see the field as part of the report, size the textbox to a minimum.
run the report..

could it be that the textbox is referenced in any calculation?
0
 
Jeffrey CoachmanMIS LiasonCommented:
Also it is not clear what your screenshot is supposed to be telling us?
(why the overlapping controls?)

FWIW, anytime I make design changes to an object, I run the compact/repair utility.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
sydneyguyAuthor Commented:
the text box is not referneced in any calculation, its the text of the bound field, and you may not always need the text and in this case i do not need them, or i may want to move it , and this has never happened before, normally works fine except for this time.
0
 
sydneyguyAuthor Commented:
i have never needed to run the compile any time i have made a change, never needed this before.
the overlaping control is one that i droped on then run it and it displays, then you delete the text associated to the text object and it freezzes never seen this before
0
 
Rey Obrero (Capricorn1)Commented:
could be a corrupted report.. try to make a new report.
0
 
sydneyguyAuthor Commented:
i did, 3rd thing that i did, even rebuilt a system using min components and it still happens
have just found out that if i copy the objects to another report it actiually behaves and alows me to delete the text and still works
0
 
Rey Obrero (Capricorn1)Commented:
what version of office are you using?
is it updated to the latest SP?
0
 
sydneyguyAuthor Commented:
2003,
but dont think this is the problem it wa happening another pc running 2007,
i think i will just rebuild all the reports in question and try and build aroudn the prop and see how that goes, before i strat chasing after updates, just never seen this before
0
 
Rey Obrero (Capricorn1)Commented:
ok..
0
 
sydneyguyAuthor Commented:
the system probably has some curruption in it, as it is an unstable network and have had to change machines quite oftern under extreme power off situations, so the link page above has been very useful so thanks for that
0
 
Rey Obrero (Capricorn1)Commented:
<as it is an unstable network and have had to change machines quite oftern under extreme power off situations>

this situation will corrupt your application, tables, forms and reports
0
 
sydneyguyAuthor Commented:
thanks for the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.