Exchange 2010 OWA, Activesync

Yesterday I created a self-signed certificate using my Exchange Server. I was able to install and then deleted the old expired cert and two certs with no services assigned. Outlook clients are no longer getting "expired cert" message but OWA and Activesync have quit working. Also, now I can't get to cert web enrollment site. Please help!
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

have you enabled the certifcate?

Get-Exchangecerticate | FL
Enable-ExchangeCertificate -thumbprint (pastethumbprint) -services IIS

Open in new window

DL197Author Commented:
[PS] C:\Windows\system32>Enable-ExchangeCertificate -thumbprint (71917B6EB8DBDA82FB367C201DE523D5191030DC) -services IIS

Bad numeric constant: 71917.
At line:1 char:46
+ Enable-ExchangeCertificate -thumbprint (71917 <<<< B6EB8DBDA82FB367C201DE523D5191030DC) -services IIS
    + CategoryInfo          : ParserError: (71917:String) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : BadNumericConstant
DL197Author Commented:
[PS] C:\Windows\system32>Get-ExchangeCertificate | FL

AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule,
CertificateDomains : {belton.local, mail.belton.local, mail.beltontexas.g
           , beltonpd.local,, c
HasPrivateKey      : True
IsSelfSigned       : True
Issuer             : C=US, S=TX, L=Belton, O=City of Belton, OU=Belton, C
NotAfter           : 4/9/2013 5:11:18 PM
NotBefore          : 4/9/2012 4:51:18 PM
PublicKeySize      : 2048
RootCAType         : None
SerialNumber       : 4657376577E2329B437E7251904AD6D7
Services           : None
Status             : Valid
Subject            : C=US, S=TX, L=Belton, O=City of Belton, OU=Belton, C
Thumbprint         : 704B3ADA43B4FA89B254AD06F6280A0A6D12FB62

AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule,
                     ule, System.Security.AccessControl.CryptoKeyAccessRu
CertificateDomains : {belton-CITY-EX2-CA}
HasPrivateKey      : True
IsSelfSigned       : True
Issuer             : CN=belton-CITY-EX2-CA, DC=belton, DC=local
NotAfter           : 4/9/2017 3:46:37 PM
NotBefore          : 4/9/2012 3:36:38 PM
PublicKeySize      : 2048
RootCAType         : Registry
SerialNumber       : 2708CB79F0F7909648B3C2D3A7EDBB31
Services           : IMAP, IIS, SMTP
Status             : Valid
Subject            : CN=belton-CITY-EX2-CA, DC=belton, DC=local
Thumbprint         : 71917B6EB8DBDA82FB367C201DE523D5191030DC
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

remove the brackets from the thumb print sorry
DL197Author Commented:
Command completed successfully. OWA site still doesn't come up. Neither HTTP or HTTPS...... Restarted IIS, no luck.
What shows in the IIS access logs?
DL197Author Commented:
Where do I find those?
DL197Author Commented:
Found them @ c:\windows\system32\errorlogs\httperr. They are really long, not sure what I am looking for. See a lot of "Timer_ConnectionIdle" and "2012-04-10 13:51:20 ::1%0 49496 ::1%0 80 HTTP/1.1 POST /powershell?serializationLevel=Full;PSVersion=2.0 - 1 Connection_Dropped MSExchangePowerShellAppPool
2012-04-10 13:51:20 ::1%0 42795 ::1%0 80 HTTP/1.1 POST /PowerShell?serializationLevel=Full;clientApplication=EMC;PSVersion=2.0 - 1 Connection_Dropped MSExchangePowerShellAppPool
2012-04-10 13:51:20 ::1%0 42810 ::1%0 80 HTTP/1.1 POST /PowerShell?clientApplication=EMC;PSVersion=2.0 - 1 Connection_Dropped MSExchangePowerShellAppPool
2012-04-10 13:51:20 ::1%0 42805 ::1%0 80 HTTP/1.1 POST /PowerShell?serializationLevel=Full;clientApplication=EMC;PSVersion=2.0 - 1 Connection_Dropped MSExchangePowerShellAppPool
2012-04-10 13:51:20 ::1%0 42801 ::1%0 80 HTTP/1.1 POST /PowerShell?serializationLevel=Full;clientApplication=EMC;PSVersion=2.0 - 1 Connection_Dropped MSExchangePowerShellAppPool"
DL197Author Commented:
I set certsrv folder to http access. I was then able to generate second cert which solved my problem. Evidently, first cert was corrupt as I generated second exactly the same.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DL197Author Commented:
It was the method used to solve the problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.