Unable to connect to the clustered SQL DB instance ?

Hi People,

I’ve created SQL Server 2008 R2 SP1 clustered virtual instance on top of my Windows Server 2008 R2 SP1 Enterprise MSCS, one instance is working fine and I can perform:

 
C:\telnet SQLClustername-instance1 1433

Open in new window

--> successfully

However with the other instance I cannot perform the above command and it is not accessible at all ? pinging the SQLClustername-instance2 is fine and reply back, when I do the following command:

C:\netstat –ano | find /I “1433”

Open in new window

 --> I cannot see the SQLClustername-instance2 IP address with port 1433 listening ?

I believe that the MSCS cluster can supports multiple SQL DB instance as long as the IP address is unique therefore port 1433 can be opened multiple times.

Any assistance would be greatly appreciated.

Thanks.
LVL 9
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Senior IT System EngineerIT ProfessionalAuthor Commented:
Hi, so in this case there can be only one instance listening on port 1433 ?
From the SQL configuration manager, the instance2 ip address it is set 0 as dynamic port.

My BiztalkServer 2010 cannot somehow talk to this instance2?
So should I make it explicitly 1433 instead of 0?
0
Senior IT System EngineerIT ProfessionalAuthor Commented:
I've found the official way to do this finally from: http://msdn.microsoft.com/en-us/library/ms177440.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ryan McCauleyData and Analytics ManagerCommented:
You don't have to configure for a specific port - you can use the instance name, like "SERVER1\INSTANCENAME" (or "INSTANCEDNSNAME\INSTANCENAME", in the case of your clustered instance), or you can use the port number like "SERVER1,1440" (or whatever port you assigned). By default, ports are assigned dynamically every time the SQL engine starts up, and  assigning a port explicitly to your SQL Instance can cause problems if another application tries to grab that port on start-up.

With clustered instances, since you have a unique network name and IP address assigned to them, I've never understood why you need to specify the instance name in the connection - with a standard mutli-instance server, there are potentially two dozen instances listening on the same IP address, but with a cluster, each instance has its own IP. Connecting to "INSTANCEDNSNAME" has no confusion to it, and there should be no need to specify the instance name. To that point, I modify the TCP listener settings to allow this type of connection:

http://trycatchfinally.net/2009/05/accessing-a-clustered-sql-server-instance-without-the-instance-name/

Essentially, you tell SQL Server to listen on port 1433 of the cluster instance IP address, so requests to the IP directly (with no instance name) will still connect. Makes life a bit easier :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.