Solved

Exchange 2010 Database Availability group network mis-configured

Posted on 2012-04-10
8
1,413 Views
Last Modified: 2012-04-21
Hi,

We have an Exchange 2010 organisation, over 2 sites/subnets connected via a private mpls.  exsvr1 is in site1 and exsvr2 is in site2.  they are connected via a dag and replicate with each other.

All seems to be ok, but with the exchange system manager, click "organisation/mailbox/database availabilty groups.  then Networks.

it shows dag network01 and dag network02.  in dag network 2 expand subnet and it has a red cross icon with Misconfigured, instead of Up.

can some one help.

Thanks

phil
0
Comment
Question by:philipfarnes
  • 4
  • 4
8 Comments
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37832948
Do you have two IPs on the DAG? You need one IP for each subnet that you have DAG servers on.

Also both networks are configured for MAPI and replication?
Are you using only one network card on each DAG server? be sure that both servers can ping each other.
0
 

Author Comment

by:philipfarnes
ID: 37833112
hi,

Please see attached settings.

thanks

phil
0
 
LVL 15

Expert Comment

by:GreatVargas
ID: 37833127
nothing is attached.
0
 

Author Comment

by:philipfarnes
ID: 37836276
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 15

Expert Comment

by:GreatVargas
ID: 37836785
So both are replication enabled.

do a Get-DatabaseAvailabilityGroupNetwork |fl or Get-DatabaseAvailabilityGroupNetwork | ft name, ReplicationEnabled, IgnoreNetwork

check the replicationenabled and the ignorenetwork values on both subnets. those values should be the same.

use the set command to put the values correctly.
you should not be ignoring any network and the replication enabled should be ok. so if the ignorenetwork parameter is misconfigured set it to false on both subnets.
0
 

Author Comment

by:philipfarnes
ID: 37846846
i ran

[PS] C:\Windows\system32>Get-DatabaseAvailabilityGroupNetwork | ft name, ReplicationEnabled, IgnoreNetwork

Name                                                         ReplicationEnabled                           IgnoreNetwork
----                                                         ------------------                           -------------
DAGNetwork01                                                               True                                   False
DAGNetwork02                                                               True                                   False

not sure whats causing this..
0
 
LVL 15

Accepted Solution

by:
GreatVargas earned 500 total points
ID: 37855086
What sould be causing that is a network being wrongly configured. Does that subnet on both dag networks matches the IP address of the server? (same subnet)
0
 

Author Closing Comment

by:philipfarnes
ID: 37875719
subnet issue
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Read this checklist to learn more about the 15 things you should never include in an email signature.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This video discusses moving either the default database or any database to a new volume.

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now