Unable to SendAs in cached mode Outlook / Exchange 2010 SP1

Hello Experts,

I've granted one user SendAs and FullAccess to two shared mailboxes.  One mailbox works fine, the other generates an error when attempting to SendAs:

You can't send a message on behalf of this user unless you have permission to do so. Please make sure you're sending on behalf of the correct sender, or request the necessary permission. If the problem continues, please contact your helpdesk.

/O=ORG1/OU=EXCHANGE ADMINISTRATIVE GROUP (FYDIBOHF23SPDLT)/CN=RECIPIENTS/CN=<USER1>
#MSEXCH:MSExchangeIS:/DC=local/DC=<DOMAIN>:<SERVER>[578:0x000004DC:0x0000001D] #EX#

I've omitted company specific information from the error and replaced with, USER1, DOMAIN, and SERVER.

Here's what I've tried so far:

1. Deleting/readding SendAs permission
2. Deleting all AutoComplete/NK2 entries in Outlook
3. Verified neither of the mailboxes are hidden from GAL
4. Updated the OfflineAddressBook and FileDistributionService
5. Closed Outlook and deleted all OAB files in user's Outlook folder
6. Restarted Outlook and d/l a fresh, full OAB
7. Verified the proper Identities were included in the msExchDelegateListLink attribute using ADSI Edit

After all this, the user still gets the NDR after trying to SendAs.  When attempting SendAs in online mode, the email routes properly and no NDR is generated so this issue appears to be specific to the Outlook client.  

Any suggestions would be much appreciated.
LVL 2
terminalbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

apache09Commented:
Check to make sure the shared mailboxes are not hidden

Also how Has this mailbox been added? as an additional mailbox?

If it has, try removing it as an additional mailbox

Close outlook
Go to OCntrol Panel
Mail

Open the account settings
You should already see 1 account here

Now choose NEW
EMAIL ACCOUNT
MANUAL CONFIGURE
Exchange Account

Now setup the Mailbox as you normally would

When done, open outlook
Expand the two accounts on the left
Highlight the Shared Mailbox Name
Select NEW Email
Should create new email, populated with the Mailboxes Name
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
terminalbAuthor Commented:
I caught this about 4 hours after posting this question.  It turns out the 'From:' address this user was attempting to SendAs from was cached and needed to be refreshed.  Once we deleted the sender's AutoComplete entry, all was well again.  

Thanks anyway apache09, your solution would have worked as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.