Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Trying to set up failover scenario on Cisco 1921

Posted on 2012-04-10
3
Medium Priority
?
1,549 Views
Last Modified: 2012-04-12
Good Day-
We are attempting to setup failover on a Cisco1921.  In a nutshell, the end user has a T1 as their main connection, and has a cable modem as a backup solution.  The LEC has not been much help with the flaky T1 connection, and it is prone to dropping multiple times throughout the week.

What we are trying to accomplish is setting up failover so that at anytime when the T1 on Serial0/0/0 goes down, the cable modem on gigabitethernet0/0 will takeover.

I have read some forum information on setting the static routes to higher metrics for the gige0/0 interface, but honestly am not sure what that would accompish.

Any help would be appreciated.  I can upload a copy of the current running config if requested.

Thanks,
GS
0
Comment
Question by:gsevolved
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 1

Expert Comment

by:rinkleff
ID: 37828702
A copy of the running config would help a lot and reduce the amount of questions for more information.

Does the ISP that provides the cable modem use DHCP or do both your connections have static IP's assigned?

Is there a requirement for outside availability as in web page hosting or vpn clients?

How large is the user’s network? Is this the only router or just the border router?

I am assuming that the user does not wish to buy any additional hardware.
0
 

Author Comment

by:gsevolved
ID: 37828872
Thanks.  Config will be below.


Yes, we are running Static IPs on both connections.

No, this specific end user does not have a requirement for any connections from the outside.

Network size is small.  We have the 1921, 2 switches, and I believe 39 devices (laptops, phones, etc).  The cisco is the single router in this setup.

We would like to run with just the existing equipment.  If needed, we could add/swap.

Thanks again.

Current configuration : 4556 bytes
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 xxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxxx
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
ip dhcp excluded-address 192.168.100.1
ip dhcp excluded-address 192.168.100.254
ip dhcp excluded-address 10.10.20.1
ip dhcp excluded-address 10.10.20.254
!
ip dhcp pool 1
   import all
   network 192.168.100.0 255.255.255.0
   dns-server 72.237.212.20 72.237.212.21
   default-router 192.168.100.1
   option 66 ascii xxxxxxxxxxxxx
   domain-name LAN
!
ip dhcp pool 2
   import all
   network 10.10.20.0 255.255.255.0
   dns-server 72.237.212.20 72.237.212.21
   default-router 10.10.20.1
   domain-name Voice
   option 66 ascii xxxxxxxxxxxxxxxx
!
!
no ip bootp server
ip domain name yourdomain.com
ip name-server 72.237.212.20
ip name-server 72.237.212.21
multilink bundle-name authenticated
!
!
!
!
class-map match-any VOICE
 match access-group 1
!
!
policy-map VOIP
 class VOICE
    priority percent 75
  set ip dscp ef
 class class-default
    fair-queue
     random-detect
!
!
!
!
!
interface GigabitEthernet0/0
 description TimeWarner
 ip address 72.45.XXX.XXX 255.255.255.248
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description DataLan
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex full
 speed 100
 no mop enabled
!
interface GigabitEthernet0/1.2
 description VoiceLan
 encapsulation dot1Q 2
 ip address 10.10.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Serial0/0/0
 description T1
 ip address 8.224.XXX.XXX 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 no fair-queue
!
ip forward-protocol nd
!
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Serial0/0/0 overload
ip route 0.0.0.0 0.0.0.0 8.224.XXX.XXX
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 2
!
ip access-list extended sdm_telnet
!
access-list 1 permit 10.10.20.0 0.0.0.255
access-list 1 permit 192.168.100.0 0.0.0.255
!
!

snmp-server location
snmp-server contact
!
control-plane
!
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 password xxxxxxxxxx
 login
 transport input all
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
end
0
 
LVL 5

Accepted Solution

by:
andrew1812 earned 2000 total points
ID: 37830898
On the router setup two default routes

ip route 0.0.0.0 0.0.0.0 T1 100 - Where 100 is the metric value
ip route 0.0.0.0 0.0.0.0 cable interface 200 - where 200 is the metric value

When  a packet bounded for the internet comes on the router, it would select the first entry since the metric value is lower. When the link fails (Physically), it would take the second entry , the cable modem.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question