Solved

B-ACD Configuration Help

Posted on 2012-04-10
6
436 Views
Last Modified: 2012-05-05
Hello
Could someone point out , what is wrong with this configuration please? . The CME version is 8.8 and the IOS is 15.2

When i removed the Voice-hunt and call 4067062162 from outside the Phone did not ring , but when i replace Voice-hunt
and called again  it rang , but the BACD & AA did not work.
controller T1 0/0/0
 cablelength long 0db
 pri-group timeslots 1-24
!
controller T1 0/0/1
 cablelength long 0db
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Connection to FIREWALL ETH Port 1
 ip address 10.174.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description Connection to POE Switch Port 47
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.172
 encapsulation dot1Q 172
 ip address 10.172.1.1 255.255.255.0
!
interface GigabitEthernet0/1.173
 encapsulation dot1Q 173
 ip address 10.173.1.1 255.255.255.0
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn outgoing display-ie
!
interface SM1/0
 description Internal switch interface connected to Service Module
 ip address 10.174.1.10 255.255.255.252
 service-module ip address 10.174.1.9 255.255.255.252
 !Application: CUE Running on SM
 service-module ip default-gateway 10.174.1.10
!
interface SM1/1
 description Internal switch interface connected to Service Module
 no ip address
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:GUI
!
ip route 0.0.0.0 0.0.0.0 10.174.1.1
ip tacacs source-interface GigabitEthernet0/0
!


ip dhcp pool Voice
 network 10.173.1.0 255.255.255.0
 domain-name BACD.com
 dns-server 172.29.10.72 172.29.10.73
 default-router 10.173.1.1
 option 150 ip 10.173.1.1
 lease 3
!
ip dhcp pool Data
 network 10.172.1.0 255.255.255.0
 domain-name BACD.com
 dns-server 172.29.10.72 172.29.10.73
 default-router 10.172.1.1
 lease 2

domain-name BACD.com
 dns-server 172.29.10.72 172.29.10.73
 default-router 10.173.1.1
 option 150 ip 10.173.1.1
 lease 3
!
ip dhcp pool Data
 network 10.172.1.0 255.255.255.0
 domain-name BACD.com
 dns-server 172.29.10.72 172.29.10.73
 default-router 10.172.1.1
 lease 2


voice service voip
 ip address trusted list
  ipv4 10.173.1.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  call start slow
 modem passthrough nse codec g711ulaw
 sip
  registrar server

voice iec syslog
voice hunt-group 10 parallel
 final 1003
 list 1002,1003,1004,1005,1006,1007,1008,1009,1010,1011,1017,1018,1019,1020,1021,1022,1023,1024,1025
 timeout 12
 pilot 5000

voice translation-rule 1
 rule 26 /^4067062162$/ /5000/
!
voice translation-rule 3
 rule 1 // // type any international plan any isdn
!
!
voice translation-profile INCOMING
 translate called 2
!
voice translation-profile INTL
 translate calling 1
 translate called 3
!
voice translation-profile OUTGOING
 translate calling 1
!
application
 service aa flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  param number-of-hunt-grps 3
  param handoff-string aa
  param dial-by-extension-option 1
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 4067062162
  paramspace english location flash:
  param second-greeting-time 60
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
  param max-time-call-retry 700
  param voice-mail 1234
  param service-name queue
 !
 service queue flash:app-b-acd-aa-3.0.0.2.tcl
  param aa-hunt3 5003
  param queue-len 15
  param aa-hunt1 5001
  param number-of-hunt-grps 3
  param aa-hunt2 5002
  param queue-manager-debugs 1
 !

dial-peer voice 1 pots
 translation-profile incoming INCOMING
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23


dial-peer voice 4401 voip
 service aa
 destination-pattern 4067062162
 session target ipv4:10.1.173.1
 incoming called-number 4067062162
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 4402 voip
 service aa
 destination-pattern 4067062162
 session target ipv4:10.1.172.1
 incoming called-number 4067062162
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 16 pots
 service aa
 destination-pattern 4067062162
 direct-inward-dial
 port 0/0/0:23

ephone-hunt 1 sequential
 pilot 5001 secondary 4067062162
 list 1003, 1004
 timeout 2, 2
!
!
ephone-hunt 2 sequential
 pilot 5002 secondary 4067062162
 list 1005, 1007
 timeout 3, 3
!
!
ephone-hunt 3 sequential
 pilot 5003 secondary 4067062162
 list 1002, 1006, 1008, 1009, 1010, 1011, 1012
 timeout 6, 6, 6, 6, 6, 6, 6



I would be glad on your Positive support or clear explanation on what to make it works.
Thanks
Gadaze
0
Comment
Question by:Davgadaze
  • 4
  • 2
6 Comments
 
LVL 15

Expert Comment

by:deepdraw
ID: 37833671
interface Embedded-Service-Engine0/0
 no ip address
 shutdown


try this
conf t
interface Embedded-Service-Engine0/0
no shut
0
 

Author Comment

by:Davgadaze
ID: 37834924
Thanks,
 That did not help , I realised that Tcl scripts name in both AA  & Queue  are the same.
"service queue flash:app-b-acd-aa-3.0.0.2.tcl"
I will work on this and get back to you

cheers
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 37839253
can you paste back a show flash please
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Accepted Solution

by:
Davgadaze earned 0 total points
ID: 37910593
Hello All,
Here is the solution;  
param aa-pilot 4067062162  & dial-peers 1 & 16  .
 The Provider use 5 digit for Incoming call number , which are "62162"
 Dial-peer 1 and Dial-peer 16 needs their incoming called-number corrected  
 


CORRECTION
==============

application
 service aa flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  param number-of-hunt-grps 3
  param handoff-string aa
  param dial-by-extension-option 1
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 62162
  paramspace english location flash:
  param second-greeting-time 60
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
  param max-time-call-retry 700
  param voice-mail 1234
  param service-name queue
 !
 service queue flash:app-b-acd-3.0.0.2.tcl
  param aa-hunt3 5003
  param queue-len 15
  param aa-hunt1 5001
  param number-of-hunt-grps 3
  param aa-hunt2 5002
  param queue-manager-debugs 1


dial-peer voice 1 pots
 translation-profile incoming INCOMING
 incoming called-number .%
 direct-inward-dial
 port 0/0/0:23

dial-peer voice 16 pots
 service aa
 incoming called-number 62162
 direct-inward-dial
 port 0/0/0:23

All the Best
0
 

Author Comment

by:Davgadaze
ID: 37910618
SOLUTION
==============

application
 service aa flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  param number-of-hunt-grps 3
  param handoff-string aa
  param dial-by-extension-option 1
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 62162
  paramspace english location flash:
  param second-greeting-time 60
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
  param max-time-call-retry 700
  param voice-mail 1234
  param service-name queue
 !
 service queue flash:app-b-acd-3.0.0.2.tcl
  param aa-hunt3 5003
  param queue-len 15
  param aa-hunt1 5001
  param number-of-hunt-grps 3
  param aa-hunt2 5002
  param queue-manager-debugs 1


dial-peer voice 1 pots
 translation-profile incoming INCOMING
 incoming called-number .%
 direct-inward-dial
 port 0/0/0:23

dial-peer voice 16 pots
 service aa
 incoming called-number 62162
 direct-inward-dial
 port 0/0/0:23
0
 

Author Closing Comment

by:Davgadaze
ID: 37932215
Well explained already in Solution
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In my office we had 10 Cisco 7940G IP phones that were useless as they were showing PROTOCOL APPLICATION INVALID when started. I searched through Google and worked for a week continuously on those phones, and finally got them working. This is a di…
Although VoiceOver IP has been around for a while, internet connections have only recently become fast enough to provide good call quality. Now, VoIP has become a real option for businesses looking at ways to improve their business model. In this ar…
Delivering innovative fully-managed cloud services for mission-critical applications requires expertise in multiple areas plus vision and commitment. Meet a few of the people behind the quality services of Concerto.
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

5 Experts available now in Live!

Get 1:1 Help Now