Group Policy - Screen Saver option

Trying to implement screen locking via screen saver timeout through Group Policy. I've created the user policy to turn on after 60 seconds and to use scrnsaver.scr. I know the policy applies to the workstation because I can go in and see it grayed out with the proper settings .. problem is, the machine never goes into the screensaver. I also tried a setting it to a different screensaver and even let the user choose .. nothing seems to work.

I've read some postings where its a registry key getting stuck but i was hoping there was something else. Anybody experience this before?
LVL 1
ded2545Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

motnahp00Commented:
Try these settings:

User Configuration -> Policies -> Administrative Templates -> Control Panel -> Personalization

Enable screen saver: Enabled
Screen saver timeout: Enabled | 60
Force specific screen saver: Enabled | %your location: either local or UNC%
0
Daryl BamforthTechnical ExpertCommented:
Is this happening on all your systems or just one?
0
ded2545Author Commented:
I have those exact settings (got from another post). I currently only have it set to work on my account before I turn it loose company wide (Windows 7). I know the policy is making it to my computer because the settings are adjusted in the screensaver setting. Plus, I did Group Policy Modeling and it shows up on my account as well. Very confused ..

Things i've tried:

1. Copying the "PolicyDefinitions" to the SYSVOL/Domain/Policies folder
2. Enforcing the policy

I attached an image of what the screensaver is showing on the computer.
Untitled.jpg
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

motnahp00Commented:
What value did you specify for "Force specific screen saver"? -> enabled | ?
0
ded2545Author Commented:
I tried c:\windows\system32\scrnsave.scr and just scrnsave.scr
0
Daryl BamforthTechnical ExpertCommented:
Have you tested the screen saver you want to run directly on the system before adding it to a GPO?
0
motnahp00Commented:
That file and path exists on every machine?
0
Daryl BamforthTechnical ExpertCommented:
They would do for windows 7 it is the default blank screen saver.

If you set this up manually and not through a GPO does it work?

Have you got another box you can test this on?  You may have a process that is preventing the system from becoming idle.

http://support.microsoft.com/kb/913405/en-gb

Although this link talks about wireless devices the concept is the same.  

So... If you can test it manually, and test on another system that should confirm if it is just your system or a wider issue.
0
ded2545Author Commented:
It works without the policy in place. I'm only testing this on my laptop and that path does exist.
0
Daryl BamforthTechnical ExpertCommented:
Was this a clean install of windows 7 or an upgrade from a previous version?
0
ded2545Author Commented:
unOri:

It can't be that because when I remove the policy and set it manually on the computer, the screen saver kicks and and locks the computer like the policy should. I'm going to try and re-enable the policy now and see if that works.
0
ded2545Author Commented:
It was a clean install. Upgrading from a previous version goes against my religion :)
0
Daryl BamforthTechnical ExpertCommented:
:)

Disable the 3 GPOs, retest it to confirm that it is working locally and then set just the forced screen saver

See if that works, if it does set a time out here

 HKCU\Control Panel\Desktop\ScreenSaveTimeOut

See if it works.
0
ded2545Author Commented:
Definitely something screwy with the policy. Reset everything in the policy back to allow control for the user (confirmed and tested on workstation). Had to set the "force specific screen saver" to disabled because "not configured" grayed out the option. Tested it and set the screensaver to begin after 120 seconds and it worked (under user control, not group policy).

So now, I setup each policy as:

Enable screen saver: Enabled
Prevent changing screen saver: Disabled
Password protect the screen saver: Enabled
Screen saver timeout: Enabled (900 seconds)
Force specific screen saver: Disabled
Everything else: Not Configured

The policy works with one exception: it is stuck on 120 seconds that I tested with user control. The policy applied successfully (can see 15 min in the applet) but it switches to screen saver mode after 120 seconds. Checked in the registry (HKCU\Control Panel\Desktop\" and there was an entry for 120 seconds so I deleted it .. but that didn't do anything because it still turns on after 2 minutes.

Any other ideas??? Never thought this would be so difficult...
0
ded2545Author Commented:
Ok .. this is funny but it's not.

I set the group policy for "Screen saver timeout" back to Disabled to allow user control. When I look at the computer, it shows 2 minutes like I originally had it programmed for. So this proves that group policy DOES NOT change the value despite showing that it has. When I had the "screen saver timeout" set to 15 minutes, it showed up as 15 minutes on the computer!!

Am I missing something here??
0
Daryl BamforthTechnical ExpertCommented:
I have come across a number of articles where people are experiencing the same thing.  

http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/9a30ebd0-c172-4685-9acf-843e8f1d7ab4

Another one with wireless mouse was causing the issue

http://absoblogginlutely.net/2010/02/windows-7-screensaver-not-kicking-in-fixed/

In the first case a reboot seemed to cement the problem, the second one required a full install of the mouse software (not just allowing the OS to apply base drivers) followed by a reboot.

When you changed the group policy, did you disable everything first, verify and then just apply the forced screen saver.

Also try a different default screen saver to see if any of them work.  Paths are below.

Bubbles.scr       C:\Windows\System32\Bubbles.scr
Mystify.scr       C:\Windows\System32\Mystify.scr
PhotoScreensaver.scr (Photos)       C:\Windows\System32\PhotoScreensaver.scr
Ribbons.scr       C:\Windows\System32\Ribbons.scr
scrnsave.scr (Blank)       C:\Windows\System32\scrnsave.scr
ssText3d.scr (3D Text)       C:\Windows\System32\ssText3d.scr
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ded2545Author Commented:
I know it's not the mouse issue (laptop with nothing plugged in) plus it's kicking in too fast compared to not at all. Looks like the issue is exactly that of the first link. This has to be a Microsoft bug because a reboot did fix the issue.

Thanks for that link - if nothing else, I know I'm not going crazy!
0
Daryl BamforthTechnical ExpertCommented:
Haha, glad it's working :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.