Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Permission folder/file didnt inheritable

Posted on 2012-04-11
16
Medium Priority
?
353 Views
Last Modified: 2012-05-26
Dear expert

We are having problem with our files permission in windows 2008 r2 server.

Everytime the users create a new folder or a new file, the permission only set to users itself, others cant see it, I need everytimes recheck the inheritable permission to make all the permissions avaliable again.

Could anyone help me through this pain?
Thx
0
Comment
Question by:Handersson75
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 2
  • +1
16 Comments
 
LVL 10

Expert Comment

by:Prashant Girennavar
ID: 37831419
Right click on parent folder unders which user is creating new folders or files-------->Properties-------->Securities------->Advanced Permission-------->Select the security groups where all the users are member of it---------->Change the apply to , TO This folder,subfolder and files---------->Click ok

Once done Ask users to logoff and login back and check.

Regards,

_Prashant_
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37831434
Thx for answering, well under the Advanced Permission of root folders, all got the right permissions and the users dont got problem when they updating the files or folders, only when they create something new.
0
 
LVL 10

Expert Comment

by:Prashant Girennavar
ID: 37831460
Are the users added to Security groups? Is the security group added to the ACL of the parent folder.?

When you go to advanced security tab , there will be Type,Name,Permission, Apply To.

SO I am asking is the Apply to is showing "This folder,subfolder and Files" Or it is just showing "This Folder"

IF possible please take the screen shot of advanced security settings and post it here.

Regards,

_Prashant_
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 7

Assisted Solution

by:David_Hagerman
David_Hagerman earned 1000 total points
ID: 37831461
have you tried apply this

Go to the parent folder --> Properties --> Security --> Advanced --> Under Permissions Click Edit --> then Tick 'Replace all existing inheritable permissions on all descendants with the inheritable permissions from the this object" making sure that your users Permission is set to allow them to create folders and the permissions you want them to have.

Let us know if that helps
0
 
LVL 7

Expert Comment

by:ComputerBeast
ID: 37832151
hi all,

Handersson75, Read the following link and update us:
http://technet.microsoft.com/en-us/library/cc732880.aspx

Thank you
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37859824
Not really working, the problem still occur, person create a new folder and the permission of that folder is set only the creator can see it, others cant, user didnt set this as he wants this way, this happens by default when creating new folder.
0
 
LVL 7

Expert Comment

by:David_Hagerman
ID: 37859880
So when the users creates the folder and you go to Properties --> security --> Advanced what do you see under the permission entries. Please list all entries or maybe give a screen shot

It sounds like you have missed a step or a tick in the right place some where along the way.
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37859903
under Properties -> security I see user's own account, nothing else, under Advanced, I also see user's own account, I need to add everyone in there then all the other accounts, groups show up correctly.
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37923747
I dont know if anyone can help in this, the users still having problem with this, that file permission didnt apply to the file when user created it, the permission need to be reset manually to make it works...
0
 
LVL 7

Expert Comment

by:David_Hagerman
ID: 37923775
Can you replicate the fault by creating a brand new folder, possibly in the root of the server you are working on. Give Everyone access and then remove the access until you get the desired results.

Once this is working then check what you have done differently on the other folder.
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37923942
I did a reset so all the users know got user rights, they all got admin right before, lets see if everything is cool now.
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37941093
I researched the problem and it seems only happen to office saves, I tried save a notepad .txt file, it worked,  but whenever I create Office files like word excel ppt, none of them works, I could see the file when I create one file, but after I hit save, the file reset permission to none.
0
 
LVL 7

Expert Comment

by:David_Hagerman
ID: 37941158
It sounds like the office is maybe corrupt, Have you tried to re install the office package
0
 
LVL 1

Author Comment

by:Handersson75
ID: 37941223
Can office reset the file permission like that?
0
 
LVL 7

Accepted Solution

by:
David_Hagerman earned 1000 total points
ID: 37941260
I have never seen anything like that but it could have something to do with local admin users rights.

the problem seems to be isolated to office as we have already established that it isn't file permissions. Reload the app and lets see if the problem persists
0
 
LVL 1

Author Closing Comment

by:Handersson75
ID: 38014654
FIxed by letting the NTFS permission setup to complete, you need to wait, or it can not set the new permission to the new files.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
A bad practice commonly found during an account life cycle is to set its password to an initial, insecure password. The Password Reset Tool was developed to make the password reset process easier and more secure.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question