Solved

Exchange 2010 anonymous send capability

Posted on 2012-04-11
7
556 Views
Last Modified: 2012-06-21
Hello, I've noticed some odd behavior with my Exchange 2010 box. I was configuring email notifications for my antivirus and virtual machine backup servers and I noticed that my mail server no longer requires authentication to send those alert messages. Essentially all I have to do now is specifiy the Exchange ip address and the recipient email addresses and they'll go through the mail server without prompting for a valid username and password. I'd really like to change this behavior, but I'm not sure where to start. I believe I have all the correct authentication requirments, but I'm not 100% sure. Any help would be greatly appreciated! Thank you!
0
Comment
Question by:jmchristy
  • 4
  • 2
7 Comments
 
LVL 7

Expert Comment

by:BelushiLomax
ID: 37832121
Did you create a service account for those (AV and BU) or are you logging on as Administrator and configuring them? You can check your "Manage Send As Permissions" attribute on the mailbox to see if anything jumps out there. If you are logged on as the user sending the email or that user has an AD acct and an Exchange box with service acct credentials running on the app you are setting up, you shouldnt see the authentication.
0
 

Author Comment

by:jmchristy
ID: 37832140
For the AV I am logged on as the service account which does have the exchange credentials, however, the BU VM device isn't even on the domain. That's the part that confused me. It's a linux based device, not authenticated to the domain. The AV software's authentication is SQL based, so that isn't actually using AD credentials either.
0
 
LVL 2

Expert Comment

by:Xinjitzu
ID: 37832168
jm that only sounds like a problem if your actually relaying mail through the server anonymously. If the alerts are coming from another self-contained system,(like postie for example) to an internal exchange email address, thats fine.

Take a look at your Receive Connecters under Server Configuration > Hub Transport

go to properties > Permission groups of your "Client <servername>" connecter (Assuming you have a default installation and naming scheme here)

Make sure anonymous is NOT checked here. Typically you'd only have "Exchange Users" enabled on this connector

Anonymous should only be checked on your default connector (So you can receive external mail) and on another connector designated for relaying, that only allows specific clients inside your network
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 

Author Comment

by:jmchristy
ID: 37832185
I do have the default install and Anonymous is checked on one of my recieve connectors (Default). I have two defaults: Client and Default. Default has Anonymous, Exchange Users, Exchange Servers, and Legacy Exchange Servers checked. on Client I only have Exchange Users checked. So, it appears that both are configured correctly. Neither alert system is self contained that I know of. Is there a way to check if my server is relaying mail anonymously since I'm not 100% sure that my two alert systems are self-contained?
0
 

Author Comment

by:jmchristy
ID: 37832292
I just went through mxtoolbox and checkor against my MX record and both said that Open Relay was not allowed. Should I assume that I would have no issues internally?
0
 
LVL 2

Accepted Solution

by:
Xinjitzu earned 500 total points
ID: 37832611
if MXtoolbox says your good your definitely ok from the outside. To verify the inside is secure open a telnet session from one of your LAN computers

telnet <mailservername> 25
helo <internaldomainname>
mail from:<you@yourdomain.com>
rcpt to: <someone@externaldomain.com>


You should get 550 5.7.1 Unable to relay

If you do your all set
0
 

Author Comment

by:jmchristy
ID: 37832647
That's what I got! It looks like I'm all set on both ends. Thank you for your continued help!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now