Windows not coming to the front in Windows 7

I use two monitors with my PC running Win7.
With some applications, skype being an example, when I click on them in the taskbar
then don't come to the foreground, the only show when I minimize a window that's in front of them.

Is there some setting I need to change?
LVL 1
wannabecraigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Run5kCommented:
This is actually something that is typically caused by the application itself versus Windows.  Here is a similar discussion from the Microsoft message boards:

How do I keep a window to always stay on top in Windows 7?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wannabecraigAuthor Commented:
Sorry, I don't understand, that discussion is confusing.

Are you saying it's the application that wont pop out on top of the other programs window?
0
Run5kCommented:
The main point was in the selected answer versus reading the entire discussion.

Essentially, yes.  In other words, Windows 7 isn't selective about which windows it does/doesn't allow to be brought to the front.  That's something inherent to the application itself, but as that answer on the Microsoft boards implies, there are software utilities available from computer makers, video card vendors, and third-party software companies that are designed to help in that regard.  For example, that selected answer included a hyperlink to a free utility that allows you to manipulate specific windows in that manner.
0
jcimarronCommented:
wannabecraig--Assuming you are using tabs, click IE Tools|Internet Options|General tab|Tab section|Settings check the box "Always Switch to New Tabs...".
0
wannabecraigAuthor Commented:
HI,

I'm gonna lock up the question cause it was fixed by a reboot which means I didn't need the any apps.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.