Solved

IIS Logs 404 XenApp Web Interface

Posted on 2012-04-11
5
1,111 Views
Last Modified: 2012-04-17
We are receiving following 404 codes in IIS Logs On Web Interface server XenApp 6.5

2012-04-11 13:23:21 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.187 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:23:33 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.9 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:23:41 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.187 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:23:54 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.9 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:24:01 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.187 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0

 X.X.X.11 is the IP address of our Web Interface Server  

we have not created a PNAgent Site (Web Services Site) yet , why we receive these Exit codes then
 

Any Idea ??
0
Comment
Question by:MOQINFRA
  • 3
  • 2
5 Comments
 
LVL 8

Expert Comment

by:didnthaveaname
ID: 37835137
Are X.X.X.9 and X.X.X.187 clients with Citrix Receiver/PNagent  installed? Possibly the PNAgent is checking in for the site even though it does not exist yet.  

If that is the case however i would assume your clients are getting errors as well.
0
 

Author Comment

by:MOQINFRA
ID: 37836916
why is thereceiver trying to get to PNAgenT site when It is not even there
0
 
LVL 8

Accepted Solution

by:
didnthaveaname earned 500 total points
ID: 37838490
When you installed the receiver did it ask you to enter a server address/ did you enter the server address?  

If so this is trying to access the pnagent site.
0
 

Author Comment

by:MOQINFRA
ID: 37847670
I dint install the receiver separately , I just was installing XenApp server and it possibly asks for the Server address That i filled In.

I think it was because PNAgent Site was not there .. I added the site and i havent seen the 404 in IIS logs.

The new citrix receiver doesnt show the published application like the old Citrix Plugin when we right clicked on it , it showed the published apps, in this new receiver when i right click i dont see any thing ..

also as soon as i login to one of the servers I get the message that is in the image attached.
Untitled.jpg
0
 

Author Comment

by:MOQINFRA
ID: 37856042
There was some dns Issue with the PNagent site . Now the Receiver is working fine,. It was not able to resolve the names as there was a old stale PTR record.

Once i put in the IP addres sof The Web Interface server . It worked fine.

thanks
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Citrix XenDesktop 7.6 Citrix Policies Audio
#Citrix #XenApp #Citrix Scout #Citrix Insight Services #Microsoft VMMAP #Microsoft ADEXPLORE #Microsoft RAMMAP #Microsoft TCPVIEW #Microsoft AUTORUNS #Microsoft PROCESS EXPLORER #Microsoft PROCESS MONITOR
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question