Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1141
  • Last Modified:

IIS Logs 404 XenApp Web Interface

We are receiving following 404 codes in IIS Logs On Web Interface server XenApp 6.5

2012-04-11 13:23:21 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.187 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:23:33 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.9 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:23:41 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.187 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:23:54 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.9 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0
2012-04-11 13:24:01 X.X.X.11 GET /Citrix/PNAgent/config.xml - 80 - X.X.X.187 C:\PROGRA~2\Citrix\ICACLI~1\PNAMAIN.EXE 404 0 64 0

 X.X.X.11 is the IP address of our Web Interface Server  

we have not created a PNAgent Site (Web Services Site) yet , why we receive these Exit codes then
 

Any Idea ??
0
MOQINFRA
Asked:
MOQINFRA
  • 3
  • 2
1 Solution
 
didnthaveanameCommented:
Are X.X.X.9 and X.X.X.187 clients with Citrix Receiver/PNagent  installed? Possibly the PNAgent is checking in for the site even though it does not exist yet.  

If that is the case however i would assume your clients are getting errors as well.
0
 
MOQINFRAAuthor Commented:
why is thereceiver trying to get to PNAgenT site when It is not even there
0
 
didnthaveanameCommented:
When you installed the receiver did it ask you to enter a server address/ did you enter the server address?  

If so this is trying to access the pnagent site.
0
 
MOQINFRAAuthor Commented:
I dint install the receiver separately , I just was installing XenApp server and it possibly asks for the Server address That i filled In.

I think it was because PNAgent Site was not there .. I added the site and i havent seen the 404 in IIS logs.

The new citrix receiver doesnt show the published application like the old Citrix Plugin when we right clicked on it , it showed the published apps, in this new receiver when i right click i dont see any thing ..

also as soon as i login to one of the servers I get the message that is in the image attached.
Untitled.jpg
0
 
MOQINFRAAuthor Commented:
There was some dns Issue with the PNagent site . Now the Receiver is working fine,. It was not able to resolve the names as there was a old stale PTR record.

Once i put in the IP addres sof The Web Interface server . It worked fine.

thanks
0

Featured Post

Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now