Solved

Autodiscover issue- No connection could be made because the target machine actively refused it

Posted on 2012-04-11
1
2,775 Views
Last Modified: 2012-05-14
Found the following errors by Running Exchange Connectivity Analyzer
Auto discover test failed for on-premise user  test.365@domain.com
Here is the results:

Please let me know what could be most likely the issue here and how should we tested further
Checking the IIS configuration for client certificate authentication.
      Client certificate authentication wasn't detected.
             Additional Details
      Accept/Require Client Certificates isn't configured.

       Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
      Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
             Test Steps
             ExRCA is attempting to retrieve an XML Autodiscover response from URL https://domain.Com/AutoDiscover/AutoDiscover.xml for user Test.365@domain.com
      ExRCA failed to obtain an Autodiscover XML response.
             Additional Details
      A redirect response was received, but only HTTPS redirect URLs are supported in response to a POST request. The URL that was received was http://www.domain.com/AutoDiscover/AutoDiscover.xml.



Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
      Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
             Test Steps
             ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.domain.Com/AutoDiscover/AutoDiscover.xml for user Test.365@domain.Com.
      ExRCA failed to obtain an Autodiscover XML response.
             Additional Details
      An HTTP 401 Unauthorized response was received from the remote Unknown server. This is usually the result of an incorrect username or password. If you are attempting to log onto an Office 365 service, ensure you are using your full User Principal Name (UPN).





       Attempting to contact the Autodiscover service using the HTTP redirect method.
      The attempt to contact Autodiscover using the HTTP Redirect method failed.
             Test Steps
             Attempting to resolve the host name autodiscover.domain.Com in DNS.
      The host name resolved successfully.
             Additional Details
      IP addresses returned: 63.110.226.242, 199.85.76.131

       Testing TCP port 80 on host autodiscover.domain.Com to ensure it's listening and open.
      The specified port is either blocked, not listening, or not producing the expected response.
       Tell me more about this issue and how to resolve it

             Additional Details
      A network error occurred while communicating with the remote host.



       Attempting to contact the Autodiscover service using the DNS SRV redirect method.
      ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
             Test Steps
             Attempting to locate SRV record _autodiscover._tcp.domain.Com in DNS.
      The Autodiscover SRV record wasn't found in DNS.
       Tell me more about this issue and how to resolve it




Error when running test-webservicesconnectivity
Error contacting https://webmailold.domain/ews/exchange.asmx
No connection could be made because the target machine actively refused it 10.100.70.40:443.
When connecting to https://webmailold.domain/ews/exchange.asmx received the error unable to conenct the remote server

Notes:
1)      Could be issue with the Cert. Need to verify that certificate is configured properly.
2)      Internal and external names are set for all the services correctly would be the first question. (this looks good though)
3)      IIS also sometimes screws up a cert you could remove the cert then re-add it manually to get around this
0
Comment
Question by:claudiamcse
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 12

Accepted Solution

by:
DLeaver earned 500 total points
ID: 37833047
A couple of things stand out

1) Are you running a self signed SSL certificate or have you purchased a a UC SAN cert from a third party provider?
2) You don't appear to have an SRV record in your external DNS for autodiscover, you need to set this up
3) Have you forwarded port 443 through to the Exchange server on your router as it appears to be blocked

An excellent reference document discussing all things Autodiscover

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_9089-See-through-Autodiscover.html
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question