Word 2010 Headings and Styles, Oh My! (Creating Headings)

We are new to using Word in our office and in the process of converting forms from Word Perfect.  (No snide comments, please!)  In order to make use of a Table of Contents and references, I need to use either Headings/Style or Paragraph Lists going forward.  The one place I am stuck is this:  I need to separate the heading ARTICLE I and it's title MY RETIREMENT PLAN on two separate lines, but as one "style".  For example:

ARTICLE I
MY RETIREMENT PLAN

Section 1.1 - Etc.

Is this possible?  I thought perhaps a Line Break would be the answer (my small knowledge from older versions of Word), but I'm not sure this applies.

Your answer will be greatly appreciated!
MariaJoyalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GrahamSkanRetiredCommented:
It isn't clear what the problem is. You can have two sequential paragraphs with the same style. If they are in one line at the moment, just position the cursor where you wish the lines to split, and press Enter.
0
Eric FletcherCommented:
A line break will work (Shift-Enter) to separate the lines but keep them within the same paragraph (and therefore, style). Another alternative for managing how headings get broken across two lines is to use fixed spaces (Ctrl-Shift-Spacebar) between words that need to be locked together. Either method will help manage how a heading ¶ is set on >1 line within the body of a document.

However, it sounds like you are having trouble with how the table of contents function deals with the styled paragraphs. Unfortunately, the TOC field code (which is what generates the table of contents) ignores the line break and lets the 2 lines run together.

One solution is to set the text as 2 different styles, and then use switches in the TOC field to assign the different styles to 2 different TOC levels. The default TOC field simply collects the headings to the level you specify, and associates them with the equivalent TOC style (i.e. Heading 1 ::> TOC 1; Heading 2 ::> TOC 2; etc.). You can reveal the TOC field code with Alt-F9, and then edit it to get much more functionality. Refer to this Microsoft page for a description of available switches.

For example, consider the following edited TOC field code:
{ TOC \t "Heading 1,1,Title,4,Subtitle,1" \n 4-4 \b "forToC" }

The "\t" switch is used to set the relationships of styles within the document to TOC styles in the table of contents. Here I have set both Heading 1 and Subtitle styles to appear in the table of contents as "TOC 1" styled paragraphs -- and any Title styles in the document will appear as "TOC 4" styled ¶s. Further, the "\n" switch turns off page numbering for the level 4 (TOC 4s). The final switch -- \b -- limits the table of contents to just the area of the document within the bookmark named "forToC". This last switch can be useful if you use heading levels within the front- and back-end parts of a document but do not want them included within the table of contents (subheads in an Appendix for example.)

The other way to manage a ToC is to edit the collected content after building it (so in your case, insert the Shift-Enter after the "Article I"). The caution is that you would need to redo any such edits after rebuilding the ToC. Just updating the page numbers won't reformat anything, but rebuilding will recreate it from scratch.
0
MariaJoyalAuthor Commented:
Eric, all I can say is WOW!  I'll work from this angle and see what happens. Thanks for the explanation.
0
MariaJoyalAuthor Commented:
Well... Working between the Multilevel lists and Styles gives me the look in the document I want.  I created Styles that are headings and used the Multilevel list to connect with the styles.

From here, I tried applying the TOC from the default choices.  The formatting isn't close to what I would like to see.  Also, Alt+F9 only shows me the codes on the table page, not the text.

What have I missed?
0
Eric FletcherCommented:
Alt-F9 toggles between showing the field codes and the result of the field code. I always recommend changing Word's "Options, Advanced, Show document control, "Field shading:=Always" so that your field code results are displayed with a grey background. This only shows up on the screen (i.e. not on your printouts) and makes it easy to differentiate between typed and calculated content.

As I noted earlier, the default table of contents settings from the dialog box creates a very basic field code. By default, the dialog will create a field code that looks something like { TOC \o "1-3" }.  This means that Heading 1 ¶s will be formatted with the TOC 1 style in your table of contents (Heading 2s will be set as TOC 2; Heading 3s as TOC 3, etc.)

If you want to include other styles that are not Heading X levels, use the \t switch.

To have specific ¶s within your table of contents formatted differently, change the style definition of the associated TOC X style.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.