Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 503
  • Last Modified:

PasswordAuthentication in sshd_config

I can't get ssh working with no password.  Even though I believe I setup my public and private keys correctly, ssh still prompts for password.

Does PasswordAuthentication in sshd_config really matter?  I noticed in my sshd_config, this parameter is not set at all which means it defaults to yes.  Could this be the cause of my ssh problem?
0
lcor
Asked:
lcor
2 Solutions
 
AnuroopsunddCommented:
PasswordAuthentication yes
The option PasswordAuthentication specifies whether we should use password-based authentication. For strong security, this option must always be set to yes.

PermitEmptyPasswords no
The option PermitEmptyPasswords specifies whether the server allows logging in to accounts with a null password. If you intend to use the scp utility to make automatic backups over the network, you must set this option to yes


http://www.faqs.org/docs/securing/chap15sec122.html
0
 
legolasthehansyCommented:
It might be an error in the way your keys are setup.
See if your .ssh directory has 700 permissions and owned by the right user
See if your authorized_keys file has 600 permissions and owned by the right user
And see if the keys are correct in your authorized_keys file
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now