Outlook 2010 will not connect via TCP/IP but will with HTTP.

So I just built a new terminal server, Windows Server 2008R2sp1.  Outlook will resolve my Exchange CAS array within seconds, but won't actually fire up.  Says the server is unavailable.

HTTP(Outlook Anywhere) works fine.

All of my other clients seem fine, my other terminal server is fine.

I've re-installed Office multiple times, even rebuilt the server entirely(its a VM), same problem.

I'm obviously missing something here... the question is, what?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do the two terminal servers have the same version of Windows and Outlook (updated to the same level)? and the IP settings are the same (i.e. both getting a reserved IP from the same DHCP server, or at least both with the same exact static settings other than their own ip of course)?
SteveKrehbielAuthor Commented:
Well, the one server is quite a bit older, so updates probably were not installed in the same order, and some of the updates on the new server may have been a part of rollups.  

One other thing of note.. The new server uses 32-bit Office, not 64 like the older one.  I use 32-bit Office on servers that need to access SharePoint, or else Excel has issues.

I have yet another terminal server that only one department uses which runs 32 bit Office just fine though.  Just verified that, actually.
Any firewall in use ?
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Have u tried to configure new profile manually
Check that Office 2010 SP1 is installed

There are known issues with TCP and HTTP that were addressed in this SP
have you installed Office on Exchange server ?
SteveKrehbielAuthor Commented:
Firewall is off.

Office sp1 is installed.

No office on Exchange.

Yes, I've tried to create a new profile.  Many, many times.

I'm noticing that while this server can ping the CAS array, it can't actually resolve it in Outlook... odd.
SteveKrehbielAuthor Commented:
Using an E1000 NIC instead of VMXnet solved the issue.  Not sure why.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
What is the result of telnet command from client
telnet <servername> 25
telnet <servername> 110
SteveKrehbielAuthor Commented:
I'm not sure why but the virtual NIC must've been having issues.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.