Solved

Any Ideas Why The System Clock Is Showing Inaccurate Time Settings - Exactly 4 Hours Ahead Each Time - When I Boot Back Into Windows 7 After I Been Just Running Linux Ubuntu For A Long Period Of Time?

Posted on 2012-04-11
7
678 Views
Last Modified: 2012-04-12
Hello. I have a question to ask you. This in some unusual manner involves two operating systems -- Linux Ubuntu v. 11.10 64-bit and especially Windows 7 64-bit.

Hello.  I have had issues only with my Windows 7 64-bit's "Date and Time" settings not accurate, specifically wrong  time clock issues. Every time I reboot and restart back into my Windows 7 after being many (say over 8) hours on my Linux Ubuntu operating system, I see my Windows 7 clock in my notification area is usual 4 hours ahead of the actual real time where I am -- the eastern United States or the Eastern Time Zone. So if it was 7:02 PM in real time, the computer clock states or shows in the notification area 11:02 PM when I first see when the Windows desktop loads. Some time ago I think I recall I saw a 3 hours ahead of my actual real time. This was only one instance I believe.

This date and time issue does not occur with Linux Ubuntu when I have been on Windows 7 for an extended time period and then I reboot/restart back into Linux Ubuntu. The Ubuntu clock in the upper right corner is always correct. I can be off Windows 7 for several hours and then reboot/restart back into Windows 7 by NEVER being on Linux Ubuntu  WITHOUT any Windows 7 time clock issues.  

Strange?

To correct this each time, I have to get into the "Date and Time Settings" window -> "Internet Time" -> "Change settings..." -> "Update now".  This works and the actual real time is corrected without any further issues until I repeat the process -- being back on Linux Ubuntu for extended number of hours.  

My hardware and operating system configuration and setup:
This is on a single desktop PC that has a tower system. It has several internal hard drives with one physical hard drive dedicated with its own partition for each operating system -- Windows 7 64-bit and Linux Ubuntu v11.10 64-bit. When each operating system was installed, they were installed on their own hard drives without any other hard drive connected. Therefore there is no shared booting processes happening. The hard drive are always connected via SATA data cables to the motherboard. In order for me to change the operating system, I have to change it in BIOS boot device priority settings to either hard drive that contains the particular operating system.            

The CMOS battery for my motherboard was changed about 5-6 months ago with a new fresh battery if you are thinking my battery is getting weak and causing potential date and time issues. Also, I would think that the weak battery would provide inaccurate clock time issues in Linux Ubuntu as well when it is not.

So any ideas why the system clock is showing inaccurate time settings (exactly 4 hours ahead each time) when I boot back into Windows 7 after I have been just running Linux Ubuntu for a long period of time on the same computer? Whether a thought, suggestion, recommendation, or a fact; please share with me what you think is going on.

Please reply.

Thank you!
0
Comment
Question by:Bazingeroo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 7

Expert Comment

by:kinecsys
ID: 37835785
Hate to ask this but you didn't mention it: Are both Windows and Linux on the same time zone?
0
 

Author Comment

by:Bazingeroo
ID: 37835831
@ kinecsys:

Hello. Nice to meet you.

Thank you for your comment.

If you are asking if the time zone setting per each operating system is the same time zone which I think you maybe aksing, then yes; both are set to Eastern Time Zone too. I think maybe this is what your previous comment is referring to.  

Please reply.

Thank you!
0
 
LVL 47

Expert Comment

by:David
ID: 37835860
The BIOS clock is probably the culprit.  Changing the O/S time doesn't necessarily update the BIOS clock.   So make sure that is correct.  Also both operating systems allow you to use internet time server.  So configure nntp services and find a local time server close to you.  This will insure clock is correct.  Then enable & set up windows time service to make it match.  Then both operating systems will have correct time no matter what the BIOS says, and they will be synced up to the same fraction of a second.
0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 
LVL 7

Expert Comment

by:kinecsys
ID: 37835891
OK, so if both Operating Systems are configured to the same time zone and the bios time matches as well, then I'm out of ideas. I would try what dlethe proposes and set up the same internet ntp server for both, unless you don't just want to solve the problem but actually figure out what caused it.
0
 
LVL 47

Expert Comment

by:David
ID: 37835898
You also *really* need to get your boot loader working right so you can freely boot between operating systems w/o going to the BIOS.  Lots of linux freebies out there, plus you could create a boot USB if you don't want to risk screwing things up. Then you boot the USB and select what O/S you want to run and the stick boots the appropriate disk.
0
 
LVL 83

Accepted Solution

by:
Dave Baldwin earned 500 total points
ID: 37835935
I just booted up my Ubuntu 8.04 system.  The BIOS clock is 7 hours ahead of the screen time.  I believe that is because Linux or at least Ubuntu sets the system clock to GMT and adjusts the displayed time to the time zone.  And since Ubuntu checks with a time server every time it boots up, it will reset the clock every time you boot into Ubuntu.

Yep, just Googled it.  This search will show you several links to make them sync with each other: http://www.google.com/search?q=Sync+time+on+dual+boot+Ubuntu
0
 

Author Closing Comment

by:Bazingeroo
ID: 37836403
@ DaveBaldwin, kinecsys, & dlethe:

Hello. Nice to see DaveBaldwin and kinecsys again! Nice to meet dlethe!

Okay, I have read all your comments and they are all strong critical analysis of this issue. I do appreciate all your dedication and attention to detail in your presentation and execution to the resolution of this issue as well.

I will begin by saying that the BIOS clock has no issues. I verified the BIOS clock in BIOS after each reboot cycle of each operating system and alternating the reboot cycle between both operating system too. I see through cause and effect, each time I finished using a Linux Ubuntu session, the clock would adjust the BIOS clock (the effect). Therefore the cause is none other than the operating system Linux Ubuntu. Therefore DaveBaldwin's comment gains validity from his premise as he explains the reasoning. I understand the logic of his statement and therefore went to his solution via the weblink. I see from the choice of solutions are all different to arrive at the same conclusion. The weblinks contain various YouTube.com tutorials or printed steps. From the 'latest' version of Linux Ubuntu I am using (v.11.10), I found that the instructions to this resolution varies a great deal if utilizing the GUI methods provided. None of  the GUI methods 'match' my 'latest' particular GUI distribution of Linux Ubuntu. So I ended up resorting to the text line command in Terminal and using and saving the gedit edit as instructed through this weblink:  http://www.youtube.com/watch?v=OmZGEKBDytw titled: [HowTo] Fix Time Synchronization issue on dual booting Ubuntu & Windows. The Terminal text line approach is universal and the method is the same regardless of the distribution version of Linux Ubuntu.  It works!

Summary of steps here:

1. Open Terminal in Linux Ubuntu.
2. Enter: sudo gedit /etc/default/rcS
3. Enter your password.
4. In the new window titled: rcS (/etc/default) – gedit -> change the entry: UTC=yes (by default) to: UTC=no
5. Save the gedit file by clicking on: Save .
6. Reboot/restart Linux Ubuntu to set it permanently.
7. Done. Fixed!    

Per the author of the YouTube.com video states his rationale:

"Ubuntu assumes that your hardware clock is set to UTC (Universal Time Coordinated). Windows assumes your hardware clock is set to the local time. Apparently there is no way for Windows to use UTC for the hardware clock. Instead for the hardware clock you can configure Ubuntu to use the local time (like Windows and keep the time in sinc)."

I have tested this solution through a few operating system reboot/restart cycles for each operating system by alternating reboots/restarts and found Windows 7 retains my actual real clock time each time! Hurray!!!

I have learned something extraordinary on this issue here.  

I have awarded DaveBaldwin the full 500 points and the Accepted Solution, since he is the only one that  provided me the direct answer and solution to this issue.

I want to thank everyone for their help with this question/thread!!!! Excellent work!!!

Again, thank you all!!!
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
Determining the an SCCM package name from the Package ID
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question