Solved

Windows 7 clock is always five minutes fast

Posted on 2012-04-12
19
3,157 Views
Last Modified: 2012-06-21
About a week ago I noticed my W7 Ultimate x64 system time was five minutes fast. I went into the clock and manually triggered a time server update, which corrected the time. A couple of days later it's back to five minutes fast. I changed the time server from windows to the .gov option. One of my problems is I can no longer go in to check the settings or to change them. I get "Unable to continue. You do not have permission." Yet I'm using the same account.

There's no domain. Following the suggestion of another article I went to change the update schedule from weekly to daily, yet the key did not exist in CurrentControlSet, but was in ControlSet002. I'm now wondering if my profile has glitched and I'm not really the user I think I am.

I have an XP unit on my LAN and it is running five minutes fast as well.  The manual sync there just set the time correct, but it will be fast again soon.

Has anyone seen this?
0
Comment
Question by:BillIrwin
  • 10
  • 4
  • 3
  • +1
19 Comments
 

Expert Comment

by:2G33K4U
ID: 37836460
Sound like your time service is reverting back to CMOS clock

from command prompt with admin privelages.

w32tm /config /manualpeerlist:us.pool.ntp.org /update

w32tm /query /status
check source it should point to pool.ntp.org
if it shows Local CMOS Clock you may have to unregister Windows time service and re-register it.

w32tm /unregister
w32tm /register
     Restart windows time service
     play it safe run the command from above again
w32tm /config /manualpeerlist:us.pool.ntp.org /reliable:no
w32tm /resync
w32tm /query /status (cross fingers) and look for us.pool.ntp.org

0
 
LVL 88

Expert Comment

by:rindi
ID: 37836480
Change your CMOS battery, then in the BIOS set the correct time.
0
 

Author Comment

by:BillIrwin
ID: 37836481
Thanks for the quick reply.

The first command returns the error "The system cannot find the file specified".

The second command (query) "The specified service does not exist as an installed service."

I do not show a Windows Time service in my services listing.
0
 

Author Comment

by:BillIrwin
ID: 37836486
Rindi, if it's my battery why is this happening on both computers at the same time?
0
 
LVL 88

Expert Comment

by:rindi
ID: 37836720
I didn't realize you were using two PC's (thought it was the same one with dual boot).
0
 

Expert Comment

by:2G33K4U
ID: 37836880
Alright in Services.msc do you see windows time service at all? test  it

if you type w32tm in a dos box do you get a bunch of help commands? if not

w32tm /register

Check to see if you now have windows time service
If it now shows Set start up type it to (Automatic Delayed)
Log on tab for Windows Time Service should have Local Service and blank out the password boxes if you had to make it say local system do a reboot.

Is this your home PC? Is it part of a Domain?

make sure netlogon is set to automatic it will not hurt you either way.

At dos windows type
w32tm /register
net start w32tm
w32tm /resync

Reboot for safe measures and make sure Netlogon and Windows time settings stayed.

check that time is still working

w32tm /query /status

Logon tab for Windows Time should have
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 37837600
If does not resolve easily, I would simply use an external timesync program.  The NIST.GOV NISTime is small and can be set to run automatically and uses the USA NIST servers by default. It has solved a lot of issues on troublesome machines in the past.

http://www.nist.gov/pml/div688/grp40/its.cfm


I hope this helps !
0
 

Author Comment

by:BillIrwin
ID: 37839337
There is no Windows Time in the Services list. w32tm produces help options.

w32tm will register and unregister, but "net start w32tm" produces "The service name is invalid". I suspect this has something to do with the fact that when I tried to change the timing of the time sync in HKLM/System/CurrentControlSet the Key I needed wasn't there, but it is in ControlSet002. I can't recall the Key or Value that I changed, but the fact that it wasn't where it should be indicates there's something deeper that's wrong.

Also, the symptom of me not being able to go into the Internet Time tab is gone today. I can go in, but when I try to sync I'm told the Windows Time Service can't be started.

There is no DC on this LAN.  Two PCs - one W7/64 and one XP.
w32tm.jpg
0
 

Author Comment

by:BillIrwin
ID: 37839369
SysExpert - Thanks for providing a workaround solution, which I'll use rather than reload Windows. However, I need to know if this is just a unique issue or a symptom of something deeper that will linger and bite me later, somewhere else.
0
Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

 
LVL 63

Expert Comment

by:SysExpert
ID: 37840256
It should not bite you later. You may want to find out what happened to the built in services, but once you get them working, uninstall the NISTime, or disable and test with just WIndows.
0
 

Author Comment

by:BillIrwin
ID: 37840357
This W7 unit has been running for over a year with no time issues.  Now, to be told I can't do a time sync because the Windows Time Service can't be started, indicates that something has broken. While trying to register or unregister the w32tm I sometimes was told I'm not authorized to do this. I think something has gone wacky with my Windows profile and I'm seeing the first two of (perhaps several) symptoms.

I logged into the Administrator profile and got the same error of being unable to start the time service.

I think I'll install the service you provided to see if it fixes the time sync problem, and deal with the Windows configuration with correct time.  Thanks.
0
 

Author Comment

by:BillIrwin
ID: 37840384
I installed NISTIME 32 and when I try to update, after displaying the amount of time to adjust, I'm told the user doesn't have administrator priviledges - even though I can change the time using Windows.

Symptom #3 ...
0
 

Author Comment

by:BillIrwin
ID: 37840447
Now it seems fixed!  I restarted and logged into the Admin profile and set my account to Standard. Then I set it back to Admin. Logged into my account and I can sync using Windows.

Now, when I try to run nistime-32bit.exe, nothing opens.  No error ... just nothing. I see multiple processes running in Task Manager, and I can kill them all, but I can't see how to open the UI to disable it.
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 37844144
See if there is something in the tray.

Also, you may need to login as admin or whomever did the install.
0
 

Author Comment

by:BillIrwin
ID: 37845218
I found that removing the.cfg file, which had been set to process in background, allowed the UI to display. I've turned it off while I diagnose the OS time function.

This morning the time service was still in the list but was not running. It started without error. It is also set to restart twice, so this would mean it had stopped three times since the last reboot last night.

The clock was four minutes slow this morning again and the Windows UI allowed me to correct it. I think I'll follow the suggestion in another article and create a new task in the Scheduler with two actions to start the service and do a resync. I don't see an error in Task  Scheduler, but it's clearly not doing the job.

The three problems are: the service stops running; the scheduled task doesn't actually sync; the time goes about five minutes fast within a few hours.
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 37853981
That makes sense. If you set it to run in the background, no gui is shown.

Regarding the windows time sync not working. it is strange, but not unheard of.
It could be something lie a corrupted profile.

try another user, create one if needed.
0
 

Accepted Solution

by:
BillIrwin earned 0 total points
ID: 37854511
Last night I created a new Task with two Actions, set to run daily.  The first one is the same as the stock time sync Task.

%windir%\system32\sc.exe start w32time task_started

The second Action is:
%windir%\system32\w32tm.exe /resync

Tonight my clock is accurate.  I'm now going to disable the second Action to see if a new Task, with the exact same Action as the original, will function properly, or if it requires the /resync Action.

I agree that it seems likely this issue is due to corruption somewhere.
0
 

Expert Comment

by:2G33K4U
ID: 37854686
Installing a 3rd party app to make clock work is not a fix it is a bandaid or work around The second action you post is a god idea and forces it to periodically update can have it do this 2 times a day. It would hurt nothing. Good luck with your clock. Sorry I haven't been replying here soon as it went to 3rd party app I bowed out.
0
 

Author Closing Comment

by:BillIrwin
ID: 37890987
Although the best solution would be to fix the built-in Windows time sync, adding a custom scheduled Task that performs the sync reliably is a good work-around. I see this as preferable to going to a third-party application, which adds yet one more app to learn and keep available (or remember the location for), in the event of a Windows reload.

Thank you to those who offered their suggestions. Hopefully this solution will be easily available to those who encounter this time issue.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
On some Windows 7 (SP1) computers, Windows Update becomes super slow even the computer is reasonably fast.  There's one solution that seemed to have worked well for me (after trying a few other suggested solutions).
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now