Install BackTrack 5 on MacBook pro partition from VMware fusion

Hello Experts

I am trying to install the BackTrack r5 Linux distribution onto a partition on my MacBook pro.

I have created a 20gb partition and I am using rEFIt as my boot manager (currently only booking to OS X Lion)

I have the backtrack distribution in an .iso file.  When I burn this to a DVD is hangs on the isolinux boot: prompt

However the .iso did install just fine into VMware fusion.

How can I show my spare partition to VMware so that when I virtual boot into backtrack it can install itself to the physical partition I created for it?

Hope that makes sense
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if trying this ensure you have a USB WiFi adaptor, otherwise BT may not function.
wisematAuthor Commented:
As a side comment I have an Alfa USB wifi card, I am not trying to use BackTrak with my internal airport card.
Interested to see where this question goes as im also very interested in getting that same setup.  My existing vmware fusion images and alpha card never seemed to work consistently when using certain wifi pen testing tools.  On a side not i found this that i thought could add some merit to the question:
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

wisematAuthor Commented:
I've tried creating a journaled partition and using carbon copy cloner to burn the iso to the partition, whilst this appears to work I can not boot from it.
Give this a shot, courtesy of

+Download Ubuntu iso
+Use UNetbootin to install the files to the root drive (usb)
+Create 3 new partitions
          -Mac Disk Utility:
               -2gb - for Ubuntu live cd files
               -4gb - for /home and linux swap
               -20gb - Actual Ubuntu (size depends on what you really want but can be changed later on)
+Move iso files (copy) to partition (2gb)
          -dd if=/dev/disk1s0 of=/dev/disk0s3
               -Note: /dev/disk1s0 is your usb. In terminal type: "diskutil list" to see what your usb name is. This is also a good time to make sure that the path to the 2gb partition is correct

+Install rEFIT
          -on restart rEFIT should load
          -go to "set up partitions" (or something similar to that)
               -answer yes to sync and activate FAT partition
+launch Ubuntu (from partition)
          -If you are experiencing graphical errors and no internet go to its terminal and type # Sudo -s and then # gedit /etc/default/grub
               -add nomodeset to GRUB_CMDLINE_LINUX="" nomodeset goes inside the ""
+If you have a macbook air or experience certain errors installing ubuntu later on especially around 15% than follow this next step:
+Dismount CDROM
          -Terminal: sudo gedit /etc/mtab
               -delete line specifying CDROM mount directory
                    -ie /dev/sda3/cdrom vfat
+++Now you are ready to install!

+Go through setup as usual until when it asks for you to partition hdd. Choose advanced!!!
          -at the partitioning list:
               -delete the 4gb partition to free space
                    -with the newly added 4gb free space click "ADD"
                         -choose these options:
                              -size: 3gb
                              -format: EXT4
                              -type: /home
                    -Click "ADD" on the 1gb free space created
                         -choose these options:
                              -size: 1gb
                              -format: swap (something-swap or vice-versa, you'll see it)
                    -With the 20gb selected choose CHANGE
                         -format: EXT4
                         -Type: "/" (this is your root)
+++Cross your fingers and install!
wisemat what error are you getting when trying to boot to that partition?  no operating system found or something to that extent?
wisematAuthor Commented:
Which one?

USB bring up isolinux boot prompt

Pressing return gives me A whirl of the DVD but no further response

I am not able to boot from any partition I try and install/clone the iso to.

Double fail :(
wisematAuthor Commented:
It would appear whatever I do, I cannot create a bootable USB device on the mac?

I'll experiment over the weekend and report back.
Ive had pretty much the same result.  No luck on the bootable usb.  Im able to boot from a backtrack DVD i made however, i get to a certain point and it stops working.  I created a live boot partition on the MBP hard drive ( so Ive got 3 partitions OSX, Linux Main for the install of the OS, and the linux live partition ) and have yet to successfully get it to boot.  Its almost like im missing a init file or something.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wisematAuthor Commented:
so far I have a:

dvd that doesn't boot
usb that doesnt boot
2gb partion that doesnt boot with unbuntu (i think)
4gb partition for swap (no boot)
20 gb partionion waition for BT install

this is becoming quite a project
wisematAuthor Commented:
I've not got anywhere with this, to the point of giving up, but I will award the point becuase the recources you pointed me to were very helpful
I found this link to dual boot ubuntu but, have yet to give it a shot... Previously my preferred reasoning for doing a dual boot with backtrack was due to some driver issues i was experiencing with my Alpha card not working consistently in fusion.  Ive actually figured that out and written a shell script to resolve that issue ( so if your having that type of similar issue ), I would be glad to share the script with you.  Anyways, here is the link that ive found for the ubuntu efi installation:
wisematAuthor Commented:
Thanks, I'll give it a try and report back
This part of the article is particularly interesting in using refit to fix your partition tables...
wisematAuthor Commented:
This could be the answer, everytime I try and boot a linux live cd it hangs at the
prompt, refit installs no problem
wisematAuthor Commented:
Still doesnt work on my mac :(
Ok lets go another route then open up another question asking about the alpha card in backtrack and ill see if maybe we can help get that issue resolved rather than dealing with the EFI mac issue.  Assuming your using vmware fusion.  Maybe post a link to that question here so i can find it easily.
@wisemat accidentally stumbled upon this link today and thought of this question when i saw it:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.