Windows 2008 Permissions issue Local Admins

example error

RUn  Regedit   > Windows cannot access the specified device, path .....etc

if i look at file permissions  it says   administrators and system have full control

my domain account is in administrtors group

but i still get access denied, if i add my name to the regedit.exe directly along side administrators  it works.


any reason why the group doesnt seem to be working?

there are GPOS applied but all Computer based none user.

windows 2008 R2
mhamerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mhamerAuthor Commented:
essentially  If i add a a domain group to have full control  it still doesnt open the file
if i add a domain user it does open

same issue as here.
http://www.experts-exchange.com/Security/Operating_Systems_Security/Windows/Q_24182131.html
0
Minoru7Commented:
In Windows 2008 R2, if you have User Account Control (UAC) still turned on, even if you're an administrator of the computer, you will not open programs as an administrator.  When performing the run, a pop-up box should appear.  Make sure to select Yes, as it's asking you if you want to run the program as an administrator.  Otherwise, it will run in the context of your account.  

I should also mention, since you said you have GPOs, that any GPOs applying rights could have an effect on your access to certain parts of the registry.  You may want to use the Group Policy Management console to verify your GPO settings for possible conflicts.
0
mhamerAuthor Commented:
this is just affceting the fies secured by GPO
eg

%systemroot\regedit.exe
and administrators and system have full control


If i add my name here too i can open the file

dont seem to be any conflicts (rsop)
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Minoru7Commented:
Are you using UAC?  If not, have you rebooted since you turned it off?  See the following as an example:  http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/86e2f00b-ecff-4eb7-820f-5c65bab19760/.
0
mhamerAuthor Commented:
Hi, Minoru

Rebooting  fixed it  thankk you.

but now in a mini dilema, I dont want UAC off or disabled

should I have to turn this off in order to set permissions via GPO???
0
mhamerAuthor Commented:
Also noticed that files that do work have TRUSTEDINSTALLER as an account with rights

but i cant add this to any where  (can you?)
0
Minoru7Commented:
You shouldn't have to have UAC turned off to apply GPOs.  On my servers, I run UAC in the second slider position up, which gives the pop-up message, but doesn't blank out the screen.  Keep in mind that if you change UAC to this position, make sure to reboot again or you'll be back into the same scenario you were before.  You shouldn't need to touch the TRUSTEDINSTALLER account.  That's a built-in system account like the NETWORK account or SYSTEM account.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mhamerAuthor Commented:
ok only way i can resolve at preent is

a: disable UAC
b: add servername\Users group to file permissions (no other groups work)
c: add an individual name

security on the file regedit.exe is servername\administrators   |   System   |TrustedInstaller all full control.

we dont have this on WIn7 so ill try match up the policys in play in win7 see if there are any diffrences  but it does seem odd.
0
Minoru7Commented:
0
mhamerAuthor Commented:
hi, i agree with what the lnk suggests   but it is talking about normal files and folders

I dont think changing ownership of all system files is a resonable fix  (or is it?)
0
mhamerAuthor Commented:
Also another bit of info

Adding.  Built in local users group.   Servername\users

Makes it work

Even if I remove all members of this group!



Which makes me think it's by design.


But does that ring true with anyone?
0
Minoru7Commented:
Are you saying that the local users group hasn't been given rights to the regedit file?  By default, it should have <localcomputer>\Users as having Read & Execute and Read.  Same goes for local administrators and SYSTEM.  Domain users are local users by default, so they will inherit those rights.  Domain admins are local admins by default, so they will inherit those rights.  The Windows directory should have local Users with Read & Execute, List folder contents, and Read.
0
mhamerAuthor Commented:
yep thats what im saying

the security clamp policy  changes rights to files to  local\administrators and system

users is removed

by the fact domain users is in local\users   is that not saying all users have rights to the file?



I didnt create the policy by the way sent in by th esecuirty chaps.


just couldnt understand the behaviour
0
mhamerAuthor Commented:
you got the point's ages ago by the way :-)  just cant see any "microsoft" blurb as to why you cant do what they  did , as there pushing for a resolution rather than "the policy is wrong"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.