Reports wont run via Crystal Report Server XI

Hi,

Error in File C:\Program Files\Business Objects\BusinessObjects Enterprise 11.5\Data\procSched\sirus.reportjobserver\~tmp3cc7043330fd06.rpt: Unable to connect: incorrect log on parameters. Details: [Database Vendor Code: 18456 ]

Im getting the above error and a newly built Crystal Report Server. Its the first report Ive tried to run since the install.

Ive setup the ODBC connections has per our old server and Ive also installed Crystal Report Designer onto the same box and Im able to run the report via the designer. Any ideas why I cannot get the server cannot run the report?

Thanks
D
daiwhyteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

daiwhyteAuthor Commented:
Further info,

The server which has BO on is part of the domain and it has System DSNs setup to the database server. The error indicates its a credentials issue so it must be to do with what BO are trying to pass in terms of credentials, how do I set what parameters are used by BO?
0
mlmccCommented:
Is the ODBC connection a system or user connection?

mlmcc
0
daiwhyteAuthor Commented:
Its a system DSN mlmcc, Ive duplicate what DSNs are on the existing BOE server over to this new server and Ive tested to ensure they can access the databases which are in the report Im trying to schedule.

I think everything points to the DSNs but Im at a loss why the BOE wont run the report??
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

mlmccCommented:
Does everyone have permission to the dsn?

I use them but only on my machine as the only user.  Not sure if there are permissions to grant to non-admin users.

mlmcc
0
daiwhyteAuthor Commented:
Not sure how to grant permissions to the dsn? Ive gone through the config of the dsn but cannot find anything which allows me to set permissions.

Where would I do that change too?
0
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
Are you attempting to schedule the report with an AD User ID rather than a SQL Server User ID
0
daiwhyteAuthor Commented:
The report is being run with AD credentials.
0
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
That's the problem.  I've had issues with this, too.  The easiest fix is to create a SQL Server system account (preferably with non-expiring credentials) and schedule against that.

If you create your ODBC DSN with Windows Authentication then you need to ensure the account that's running Crystal Reports Server also has an account on the database.

By default, Crystal Reports server runs against a Local System Account.  You logon to the server with your own credentials and create an  ODBC DSN with Windows Authentication and test it.   The problem is the DSN is using the ID of whomever is logged in, you in this case.  So, you need to run CRS as an AD system account with non-expiring credentials (a user like "domain\CRSUser", for example).  This should be a domain account that is part of the Administrator's group on the server running CRS.  Then, ensure that the service account has the appropriate rights to the database.

You should then be able to logon to the server as the domain account, and test connectivity through ODBC DSN using Windows Authentication.

Here are the individual steps:

1)  Create a domain account with non-expiring credentials
2) Add this user to the Administrators group on the server running CRS
3) Add this user to the appropriate database(s) with the correct level of permissions
4)  Go into the Central Configuration Manager, stop the SIA, and change the user to the domain user, apply and restart the  SIA
5)  Logoff the server and logon as the domain account and test whether or not the domain account can successfully connect to the database using Windows Authentication in your existing system DSN.
6)  Once you've successfully tested connectivity, logon to the CMC and configure the database connection for the report(s) in question.  You can try using either the domain name by itself or the full domain\user.
7) Test schedule the report to ensure it works..
0
daiwhyteAuthor Commented:
rhinok - thank you for responding.

Im using the domain administrator account which is not set to expire. The account has been added to the administrators group.

The account has been added to the appropriate databases

I can confirm the dsn works with this account.

Point 4 - I cannot find the SIA service to stop?? Where is this?

D
0
daiwhyteAuthor Commented:
also, point 6 - can you add a bit more detail for me?
0
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
Re: #4 - In the program's list, under your Crystal Reports Server folder, you'll see something called Central Configuration Manager (CCM) and there will generally be 2-3 services running:

1)  Tomcat - installed if you selected it
2)  World Wide Web Publishing Service (IIS) - installed if you selected it
3)  Server Intelligence Agent (SIA) - runs Crystal Reports Server

Stop the SIA, right-click it and go into properties.  You'll see it's running under the Local System Account.  You'll need to change this to domain\user and the password appropriate to that user.  Once you've done this and applied the changes, restart the service.

Re: #6 - If you login to the Central Management Console (CMC) and drill down through folders to a report then you can right-click a report and choose "Database Configuration".   This is where you'll enter the credentials for the report to be able to connect to the database.  I would try domain\user as the user with the correct password and apply the changes.
0
daiwhyteAuthor Commented:
Ok, Ive got a report to run via the schedule. I had to drill down to the report and then click on the database and use the NT credentials I created (domain admin account).

I have quick a few reports to do, is there a global setting I can change so all reports which are run on the serevr use the nt credentials? I would be a real pain to set the credentials each time a setup a new report. On my old installation of crystal server - i never had to set the credentials.
0
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
There's no global setting and it's always been necessary to set credentials with all versions of Enterprise/Crystal Reports Server.  The only time it's not necessary is if you have database single-sign on configured or if you don't have a password.

Since you're using XI R2 (version 11.5), however, there's a tool in the Administrator's Launchpad called the Schedule Manager you can use to set the default configuration for multiple reports at once.  The tool is really designed to let you schedule multiple reports at the same time, but there's an option for setting the same database configuration for multiple reports, too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
daiwhyteAuthor Commented:
Ok, thats great - Im able to get into this and set the credentials all at once.<br /><br />Thanks for you help, its appreciated.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.