Solved

File does not exist: /var/www/vhosts/domain.com/httpdocs/wp-content

Posted on 2012-04-12
9
985 Views
Last Modified: 2012-05-30
Hello,

I've got a ton of these errors in the error log (different ips):
File does not exist: /var/www/vhosts/mydomain.com/httpdocs/wp-content

I can only replicate the error if I go directly to: http://www.mydomain.com/wp-content/

The blog is located in: http://www.mydomain.com/blog/
This makes it more perplexing because the wp-content folder is within the /blog/ folder.

I've looked through the settings and I can't find a reference to this link.

Here is the htaccess file that resides in the /blog/ folder.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog/index.php [L]
</IfModule>

Any help is appreciated.

Thanks,

Tim

Open in new window

0
Comment
Question by:tdillon80
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 37841031
Is there an .htaccess file in the / folder too?
0
 

Author Comment

by:tdillon80
ID: 37843455
There is an .htaccess file in:  

mydomain.com/
mydomain.com/blog/
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 37843611
What's in the mydomain.com/ .htaccess file?
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 

Author Comment

by:tdillon80
ID: 37843813
The site was on magento and when we moved away from magento we kept the htaccess file intact for the most part.

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on


############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/
    #RewriteBase /


############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]


############################################
## Make sure we're always going to www.domain.com
## and never see index.php

     
     RewriteCond %{HTTP_HOST} !^www\..*
     RewriteRule ^.*$ http://www.extremebodyworkout.com%{REQUEST_URI} [R=301,L]


     RewriteCond %{REQUEST_URI} \.php/$
     RewriteRule ^(.+)/$ http://%{HTTP_HOST}/$1 [R=301,L]



############################################
## always send 404 on missing files in these folders

    #RewriteCond %{REQUEST_URI} !^/(media|skin|js|)/

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l


############################################
## rewrite everything else to index.php

#     RewriteRule .* index.php [L]	
     #RewriteRule ^(.*)$ lightspeed.php/$1 [L]

	
</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    AddDefaultCharset Off
    #AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires
	ExpiresActive On
    ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none


###########################################
## Deny access to svn folders and rewrite 
## them as 404s

#<Directory ~ "\.svn">
#	Order allow,deny
#	Deny from all
#</Directory>

# RedirectMatch 404 /\\.svn(/|$)


###########################################

Open in new window

0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 37843830
Comment out lines 144 and 145 and see if that resolves the issue:

RewriteCond %{REQUEST_URI} \.php/$
RewriteRule ^(.+)/$ http://%{HTTP_HOST}/$1 [R=301,L]
0
 

Author Comment

by:tdillon80
ID: 37843893
That didn't do it. I deleted everything in the htaccess file and that didn't resolve either. I went to mydomain.com/crap/ to see if that would appear in the error log and it did.

My gut is telling me this isn't an htaccess issue but a reference somewhere in the blog setup. There has to be a file that is referencing that path... or so I think.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 37843922
>> There has to be a file that is referencing that path... or so I think.

Possible.

Did you migrate the WordPress stuff from a testing domain?
0
 

Author Comment

by:tdillon80
ID: 37844112
Yes I did. The testing server is a clone of the live site. All managed through an SVN repo.

The problem is that I can't recreate this error on either the testing or live server unless I go directly to the invalid path. I've clicked on every link, image and form submit in hopes of triggering the error. It's really annoying at this point.

I'm using the grido theme, perhaps it's an error in there...
0
 
LVL 70

Accepted Solution

by:
Jason C. Levine earned 225 total points
ID: 37844117
I would do a search on both the theme and all active plugin files looking for the a hardcoded path.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WordPress is constantly evolving, and with each evolution appears to get better and better.  One of the big drawbacks prior to version 3 was that there was no way to be able to set up a custom menu from the backend. The Old Way Adding menus is…
So you have coded your own WordPress plugin and now you want to allow users to upload images to a folder in the plugin folder rather than the default media location? Follow along and this article will show you how to do just that!
The purpose of this video is to demonstrate how to reset a WordPress password if you are locked out and cannot reset the password. A typical use would be if you cannot access the email to which WordPress would send the password recovery email to…
The purpose of this video is to demonstrate how to integrate Mailchimp with WordPress, by placing a Mailchimp signup form on a WordPress Page or Post. This will be demonstrated using a Windows 8 PC. Mailchimp will be used. Log into your Mailchi…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question