Solved

Internet Explorer Joomla Menu

Posted on 2012-04-12
5
670 Views
Last Modified: 2012-08-18
Hello
I have been working on a site for a doctor, I used Joomla 2.5 and a Rockettheme template(called Clarion). The website looks exactly the way it should in Internet Explorer 9, chrome, Firefox, Safari and Opera. But it is not working correctly in IE6, 7 or 8.
The menu is gone, and the site is alligned to the left.
I noticed there are CSS files that are called template-ie6.css, template-ie7.css , template-ie8.css
inside the template.  
I have no clue where to start fixing this issue.
I attached all css files.
Please help.
Thank you
template.css
template-ie6.css
template-ie7.css
template-ie8.css
0
Comment
Question by:ascherkey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 13

Expert Comment

by:joomla_php
ID: 37841070
You don't have to make it work in IE 6. IE 6 is notoriously horrible. Look for compatability mode in the other versions (I know 8 and 9 have it). IE is so broken.
0
 

Expert Comment

by:yekdc
ID: 37852122
This problem only seems to occur in the non-legal version available through various torrents, though I'll not post the solution to your problem.
0
 

Author Comment

by:ascherkey
ID: 37856496
I did not get this version via torrent, I have a Membership with Rockettheme and downloaded it from there.
I asked my question in their forum as well, here is what they said.

"The problem you are having with IE is because your site is generating Quirks mode. You will need to check to see if anything has been added to the template to cause this as the default template works just fine in IE7,8 & 9. You can read more here - http://en.wikipedia.org/wiki/Quirks_mode

As for IE6 it is dead and buried so stop considering it. Not even supported by Microsoft now. :cheesy:"
0
 

Accepted Solution

by:
ascherkey earned 0 total points
ID: 38287466
Reinstalled Joomla and rebuilt the entire site. Problem is now fixed
0
 

Author Closing Comment

by:ascherkey
ID: 38307426
Problem was not resolved, by any comments
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Browsers only know CSS so your awesome SASS code needs to be translated into normal CSS. Here I'll try to explain what you should aim for in order to take full advantage of SASS.
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
In this tutorial viewers will learn how to customize the background color and font color of highlighted text using the ::selection element in CSS Begin by defining the selected text as an element in CSS by typing "::selection": Style the ::selection…
In this tutorial viewers will learn how to embed custom externally-hosted Google Fonts using the Google Font API in CSS Go to the Google Fonts website at google.com/fonts: Browse or search based on font properties or name to find a suitable font for…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question