Solved

Have to reboot Exchange server every day for Email to start working

Posted on 2012-04-12
72
376 Views
Last Modified: 2012-05-01
About 2 weeks ago my outlook brought up a message about auto discover when I logged in, I accepted this but found that I had to reboot my Exchange 2003 server before email would start to be sent to the workstations, since this has happened I now have to reboot the server every morning in order for my emails to work.

It was fine until about 2 weeks ago.

I spoke to my host who said that as we used our own Exchange server that it was an issue with the Server and we have had an I.T guy in who is unable to resolve the issue, hence me signing up to this website.

Where do I start looking on the server to correct this issue please?
0
Comment
Question by:martialarts-classes
  • 42
  • 26
  • 3
  • +1
72 Comments
 
LVL 47

Expert Comment

by:apache09
ID: 37840462
Are you using OUtlook 2010?
Whats changed in the last two weeks?
Have you upgraded your office suite?

If you and the other users are using Office 2010 check that SP1 is installed
http://support.microsoft.com/kb/2460049

there are known autodiscover connection issues that were resolved

Now in saying that, may also need to check your Exchange Server is up to date.

---

If you are using Office 2010, what client were you using before?

Can you find a 2007, 2003 client and see if it has the same issue?
0
 

Author Comment

by:martialarts-classes
ID: 37841770
Nothing has actually changed in the last few weeks, when the issues started to happen the first we did was make sure that the Exchange 2003 Server was up to date so we did some Windows Updates, in the hope that this would cure things.

The I.T guy that visited said that it was something to do with the Exchange Server and not the workstations.

We have 3 Workstations running Outlook 2007 and 3 Workstations running Outlook 2010 and the AutoDiscover appears on ALL PC's at the same time when the issue first started so it too much of a coincidence not to be related to this message.

Our ISP who hosts the domain names and points them to our Exchange Server said it was related to the Server as well and not the workstations, if this helps?
0
 

Expert Comment

by:Dannylost
ID: 37843484
Check if your server is running any task that can be causing this issue, check the Event Viewer and let us know if there is any problem there.
0
 

Author Comment

by:martialarts-classes
ID: 37852524
I thought I had already posted a reply to your question a few days ago but it appears to not be here so am adding the files again.

I ran the event viewer looking for errors and have attached the following images outlining what it is showing
Screen-Shot-2012-04-16-at-18.46..png
Screen-Shot-2012-04-16-at-18.46..png
Screen-Shot-2012-04-16-at-18.45..png
Screen-Shot-2012-04-16-at-18.45..png
0
 
LVL 47

Expert Comment

by:apache09
ID: 37853801
Can you provide a screen shot of the msg the users get when opening outlook?

Although you were told the issue is on the exchange server, can you verify the Outlook clients have the latest SP installed?

Im not really convinced its a Server issue just yet....

On one of the outlook 2010 Clients, could you open outlook using
start>run>outlook.exe /cleansharing

close and reopen using
Start>run>outlook.exe /safe

Do you still get the Autodiscover msg?
0
 

Author Comment

by:martialarts-classes
ID: 37854416
Hi

The workstations have a mix of Outlook 2007 and Outlook 2010, I just checked one of the workstations this morning running Outlook 2007 and this does not have the latest SP installed.

But it was strange that the AutoDiscover message appeared on ALL workstations (6 of them) at the same time as this issue started happening.

The auto discover messages does not happen every time a workstation logs into the Server, it is completely random
ad.png
0
 

Author Comment

by:martialarts-classes
ID: 37861337
Hi, any update on this issue at all please?

I am now getting more issues with the server since doing a few updates etc, the server has gone really slow and gives a blue screen now, I have to reboot the server and it works for an hour or so and then goes slow again.

Running out of ideas with it now so any help would be great please.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37861428
Your last screenshot shows an error on the security cert - name doens't match the name on the server - has the certificate expired?
Click on the View Certificate option and see what name is on it and what expiry date is showing

Also you mentioned it bluescreened - have you a minidump we can look at?
C:\Windows\Minidump folder see if anything in there and post them here
0
 

Author Comment

by:martialarts-classes
ID: 37864840
I have corrected the blue screen error, this was an issue with out AVG system, a quick uninstall and re-install resolved this issue.

Where do I find the certificate options to check as I cannot seem to locate this anywhere?
0
 
LVL 47

Expert Comment

by:apache09
ID: 37867914
Just reviewing the thread again.

Thought it may be helpful to let you know that just recently somone else has issues with their
Outlook displaying autodiscover messages and was resolved by installing the latest Service Packs for Outlook 2010=SP1 and 2007=SP3

In saying that would also check the Exchange server does have the latest Service Packs.

Also noteing your last comment about your AVG System
If this is on the Exchange Server, make sure its not setup to be scanning the Exchange Store
As this is known to cause issues
0
 

Author Comment

by:martialarts-classes
ID: 37869224
Many thanks for your advise, I will install all of the Service Packs on the workstations as you suggest and monitor it over the next few days to see if this helps.
0
 

Author Comment

by:martialarts-classes
ID: 37875178
I installed the SP's into all of the Workstations but again this morning all PC's had the AutoDiscover message and no email comes through until the Server is rebooted, once rebooted email starts to work again as normal.

I have even removed AVG completely from the server as a test just incase this is related to the problem, but it clearly isn't that either.

What else can I try as it does definitely seem related to the AutoDiscover message
0
 

Author Comment

by:martialarts-classes
ID: 37875283
Have been fiddling more this morning thinking I should add the auto discover to the DNS and came across a error message about 'The recieved certificate has expired', this was in the Exchange System Manager (as attached)

Would this be anything to do with this error?

Error message
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37875325
More than likely

Open IIS Manager
Click into Web Sites
Right click on Default Web Site
Go into Directory Security tab
Click on View Certificate - this is the one that's expired I think
See if the name on that matches the name of the server(probably doesn't matter either way as the cert is expired anyhow, but just verify)

You need to renew this cert - is it a self signed one or from 3rd party?
0
 

Author Comment

by:martialarts-classes
ID: 37875342
Excellent step by step guid thanks,

It states that the certificate has expired (as attached)

The certification path is www.thedomainname.com

I am not sure if the certificate is self assigned or not, how do I find out please?

Cert
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37875360
Click into Details tab and look at the issuer - this is who provided the cert(although the Issued by should show this as well, which means its probably a self-signed cert)

Is this the name of your domain?
0
 

Author Comment

by:martialarts-classes
ID: 37875365
It stated that our domain name is the issuer and it was valid from 4th Dec 2006 - 4th December 2011

The server was originally installed In Dec 06

Is there a way of renewing this certificate from the server please?
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37875398
Back in IIS where you clicked View Certificate
Click on the Server Certificate option above that
Choose option to Renew existing cert
Since this is a self-signed cert it will ask you to prepare the request and send later, or send the request immediately to online CA - this is your servers CA and when selected it should point to the CA automatically

Keep going and it will eventually finish(doing this from memory though so if i've missed anything my apologies...)

See if that will work...
0
 

Author Comment

by:martialarts-classes
ID: 37875403
Hi, clicked on the Server Certificate and get a Welcome to the Web Server Certificate Wizard, should I go through this Wizard?
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37875410
Yes sorry thats it, forgot to say its a wizard...proceed and see if you can see all the steps I mentioned...
0
 

Author Comment

by:martialarts-classes
ID: 37875421
OK did all of that and it created a certreq.txt...what do I do now as clicked back into the view certs and it still states it has expired?
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37875443
On the wizard after you select 'Renew cert..' - so you see the attached screen exactly like I've shown?

If not then you dont have a CA(Certificate Authority) installed on your server, which means you need to use a different method to renew...

See this link for step by step(saves me typing it all out)
Basically you need to get the SelfSSL program and create a new cert

http://blog.feutl.com/2011/05/25/self-signed-ssl-certificat-with-windows-sbs-2003/
self.JPG
0
 

Author Comment

by:martialarts-classes
ID: 37875451
Ok installing the software now and will update shortly
0
 

Author Comment

by:martialarts-classes
ID: 37875472
Following your blog it is not allowing me to create the certificate, this is what I am typing in:

C:\PROGRAM FILES\IIS RESOURCES\SELFSSL>/V:365 /N:CN=WWW.MYDOMAINNAME.COM /T

I get a message stating The filename, directory name, or volume label syntax is incorrect

What am I doing wrong please?
0
 

Author Comment

by:martialarts-classes
ID: 37875493
Just released that I needed to first type in selfSSL, have one this and replaced the one that was already there, it now stated the certificate is valid until 2015 :)

So do you think this will resolve the issues with the AutoDiscover?

Time will tell over the next few days so will monitor and advise if this has corrected the issue.

Many thanks for your help will reward points once I know the issue has been resolved and can mark the thread as closed.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37875502
Well if nothing else it will sort out the expired cert

Yes sure let us know if it resolves the issue, cheers
0
 

Author Comment

by:martialarts-classes
ID: 37875504
yes fingers crossed that this was the issue, thanks for you advise and will update in a few days, have a good weekend.
0
 

Author Comment

by:martialarts-classes
ID: 37879795
Unfortunately this didn't resolve the issue as today when logging into Outlook on one of the Workstations I was presented with the AutoDiscover message again.

I checked the certificates in more details this time and installed all 3 of them but even after doing this it didn't bring down the emails from the server.

Interesting though that the auto discover is pointing to a different issues than that of the Server?

I have attached some screen shots of the certificates that I was asked to installed and accept.
Screen-Shot-2012-04-23-at-08.55..png
Screen-Shot-2012-04-23-at-09.02..png
Screen-Shot-2012-04-23-at-09.02..png
Screen-Shot-2012-04-23-at-09.02..png
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37879828
Ok I just re-read the entire post - who is your host(that you mentioned at the start who said it was your server that was the issue)?

This looks like a 3rd party cert which obviously doesn't match your domain name(unless your domain is secure-secure.co.uk)

Also do you have an autodiscover SRV record in public DNS - if so does it point to your public IP for the Exchange server? This will be on your hosting side in the Control Panel, DNS section
0
 

Author Comment

by:martialarts-classes
ID: 37879870
I have contacted the host who said that the domain name is just pointed to the Exchange server so are saying it is nothing to do with them.

The host is not secure-secure.co.uk so not sure why that is coming up.

There is nothing in the SRV record on the DNS for the domain name?
0
 

Author Comment

by:martialarts-classes
ID: 37879875
this is the screen shot of the setting for the DNS

DNS
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37879891
Ok so you dont have an autodiscover/SRV record then?

Ok, lets go back to Outlook and see how its setup.
Outlook 2010(dont have 2007 in front of me)

Click File - Account settings
Go into the account and click Change option
On first screen click More Settings button down on bottom right corner of the window
Click into Connection tab
First section should show 'Connect using LAN'

Down further is the Outlook Anywhere option enabled?
If so click into Exchange Proxy Settings
What options are selected/filled in there?
0
 

Author Comment

by:martialarts-classes
ID: 37879908
Just checked Outlook 2007 on a workstation and Outlook 2010 on another one and the 'Outlook Anywhere' option is not checked of either of them?
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37879925
Ok and on the same section in the Security tab(beside the Connection tab on last reply) what is selected?

Should be 'Encryption between Exchange and outlook' selected
Uncheck 'Prompt for user credentials'
Negociate Authentication

One last thing - can you post a screenshot of the dialog that is popping up with the autodiscover message? Didn't see that yet...
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37880053
If there is an option to add a SRV record to your DNS for the correct Autodiscover name you should add it...

NAME - Weight - Priority - Port - Result
_autodiscover._tcp - 1 - 1 - 443 - mail.yourserver.com

See attached of example from my hosting side.
srv-record.JPG
0
 

Author Comment

by:martialarts-classes
ID: 37880094
The settings on the Outlook were already set as you suggested, I will add the SRV to the DNS now and report back.

The attached is the message that appears on the workstations pretty well every day and this is when we have to restart the Server to get the email to start working again.

auto discover
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:martialarts-classes
ID: 37880148
I was just checking the exchange mailbox sizes etc.. and came across the attached screenshot, do you think this could have anything to do with the issue?

Exchange
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37880176
No, dont think so

Think I might know what is happening here, few things

1) Autodiscover isn't an Exchange 2003 feature, it came about with Ex2007 and 2010
2) You are using Outlook 2007/2010 clients who automatically look for an autodiscover entry
3) Since your DNS doesn't have an entry your client is defaulting to another IP for autodiscover
4) The cert error you are seeing is reporting its coming from *.secure-secure.co.uk(which must be your webserver cert?

Can you ping autodiscover.yourdomain.com from the client machine - is it reporting your mail server IP or something else?

At end of the day I think you have 2 choices

1) Disable autodiscover on client(as since you are on Ex2003 its irrelavant)
2) Create the DNS/SRV record so least it will resolve to the mail server
0
 

Author Comment

by:martialarts-classes
ID: 37880194
How do I disable autodiscover on the client Outlook and I will do this now, I have already updated the SRV records as suggested and will ping the auto discover on one of the workstations in a mo and report back...thanks for all your help by the way.
0
 

Author Comment

by:martialarts-classes
ID: 37880200
The ping auto discover is giving the following IP address:
 79.170.44.207
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37880213
What I thought...thats the * record in your DNS, which is why autodiscover is showing your cert from *.secure-secure.co.uk

Ok, with the addition of the DNS record for autodiscover this should be resolved

Not sure how to disable it on the client, will be back shortly as I have never had to do this before...
0
 

Author Comment

by:martialarts-classes
ID: 37890782
I though the problem had been resolved until this morning, on all of the PC I had to install the AutoDiscover certificates, the new one created from the DNS SVR settings, I have attached images of these.

Also I noticed that when the Autodiscover comes up outlook doesn't connect to the server, it is at this point that I have to reboot the server and then everything works OK for a day or two?
ad1.gif
ad2.gif
ad3.gif
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37892334
Ok, I've checked a number of sources online, apparently Microsoft doesn't have a way of disabling autodiscover on Outlook 2007/2010 so the only solution is to put this into your hosts file on each of the pc's you have this issues on

127.0.0.2 autodiscover.yourdomain.com

Hosts file is located in C:\Windows\System32\Drivers\etc

Add that line to the bottom of the file and save, then you should not get prompted anymore

See this forum for reference...
http://www.outlookforums.com/threads/71798-how-break-stop-autodiscover-outlook-2007-exchange-2003-using-dns/
0
 

Author Comment

by:martialarts-classes
ID: 37892356
Ok thanks I will give this a go now and report back
0
 

Author Comment

by:martialarts-classes
ID: 37892549
I know you have said that you feel the issue is with the PC's/Outlook and not with the server but how would this affect email being sent to the iPhone on a couple of the email accounts as when the auto discover comes up on the PC that persons email stops being sent to the iPhone as well which does not have the auto discover appearing? and those email start working again once the server has been rebooted?

I have added the line to the host file and will see if that helps...thnks
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37892620
Yes fully understand this, but can you also try something else, to eliminate the autodiscover issue

Have you Outlook 2003? Can you install it on a pc possibly and connect one of the accounts to exchange?

Basically due to the autodiscover issue its hard to say its not the cause, as emails only seem to stop when you get the message yes? So to take autodiscover out of this loop Outlook 2003 will work(as it doesn't use autodiscover) and we might get closer to the answer...not saying its isn't the server but just for reference have you during the outage checked the event logs - i assume the exchange store service is ok and still running/etc??
0
 

Author Comment

by:martialarts-classes
ID: 37892694
I will check the event log, I don't have Outlook 2003 to install on one of the PC's as these all run Outlook 2007 and 2010, Outlook 2007 has been installed on the Workstations for a few years now and it is only the last could of weeks that we have had this issue, I guess I would understand your thoughts more if this started happening if we had only recently upgraded to Outlook 2007 and Outlook 2010.
0
 

Author Comment

by:martialarts-classes
ID: 37892726
My thoughts were that perhaps the exchange server was disconnecting itself from the exchange email service every day or two and it was only when we reboot the server does it then work again for a while?, we never lose Internet connection on the Server just the Exchange email...but I am jus guessing at this of course
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37892769
Yes understand again, my thinking is more to do with you having to reboot the server - since Outlook 2003 doesn't use autodiscover, if and when you see the issue on existing pc's, if outlook 2003 is still connected and fine then we are getting closer to the conclusion that this is an autodiscover issue...

Ok, when it next happens check these on the server
Go to Services - check the SMTP Service - should be running

Check all the Exchange services, key ones being Information store(also if you check the column called Startup-Type it will show which services are set to Automatic) - if any of these are not running take note and start them
0
 

Author Comment

by:martialarts-classes
ID: 37892929
I have attached screen shots of all the services on the server servicesservicesservicesservices
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37893105
Cool, so when you see the issues on the clients double check the these services again, key ones being

Microsoft Exchange Information Store
Simple Mail Transfer Protocol

Do you use Outlook web access?
Try this from the client as well if you do
https://server/exchange - replace server with the name of your exchange server
You will probably get a cert warning page - ignore and continue
See if you can login with the client user/password there - if this works and Outlook isn't working this eliminates the server from the loop - i.e. if you can access OWA site and email then your server is fine, its a client issue...
0
 

Author Comment

by:martialarts-classes
ID: 37893125
OK will monitor this nest time it happens which will probably be tomorrow, we do not use Outlook web Access so cannot check this.

Will update.... many thanks again for your advise
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37893302
You also have SBS 2003 - normally there is a ClientApps folder on the server which holds a copy of Outlook 2003 - might be worth a look to see if you can test using that version
0
 

Author Comment

by:martialarts-classes
ID: 37901028
OK the Server stopped working again this morning, it was fine all day yesterday and the day before that.

I managed to get some screen shots from the Event Manager before anyone else in the office rebooted.

I checked the services that you mentioned to see if they were still running and they were, the auto discover message came up on each of the PC's again which we clicked YES to continue, 3 came up (as normal) and we chose not to be asked about these again but this does not appear to work as we always have to do this procedure each time the server email system stops working

Screen shots attached
Event ErrorsEvent errorevent erros
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37901056
Hi, did you happen to check the Microsoft Exchanege Information Store service?
It appears from the error that the store wasn't mounted...this could be due to a number of things

Have you any idea of the size of the exchange database? Possibly you are over the max limit, or the store is corrupted and needs repairing...

On server go into C;\Program Files\Exchsvr\MDBDATA folder - what size is priv.edb and pub.edb?
0
 

Author Comment

by:martialarts-classes
ID: 37901083
Yes the Microsoft Exchange Information Store was still running, I have looked at the folder to see what MDBDATA size is but the files you are asking about are not in the folder

MDBDATA
0
 

Author Comment

by:martialarts-classes
ID: 37901093
this is the list of folders I have under that section
folders
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37901173
Do u have a seperate data drive with the database on it? D drive?
Search that whole folder but also ur data drive if u have multiple partitons for the priv and pub files
0
 

Author Comment

by:martialarts-classes
ID: 37901270
Yes I found the folder with these file on the D: drive as attachedMDBDATA
0
 
LVL 24

Accepted Solution

by:
smckeown777 earned 500 total points
ID: 37901435
Have you ever increased the default limit from 18GB? Think that is the issue

See here - http://www.petri.co.il/change_store_size_limits_ex2003_sp2.htm

Up the limit to 75 and u should be good to go
0
 

Author Comment

by:martialarts-classes
ID: 37901479
Thanks for the info, this does sound like it could be the cause of things...hopfully so.

I have followed the instructions but cannot see the file to allow me to increase the database size, I have attached screen shots of what I have, could you point me in the right direction please?
server.gif
0
 

Author Comment

by:martialarts-classes
ID: 37901483
sorry other files...screenscreen
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37901514
You have to create the DWORD value

'Create a new DWORD entry called "Database Size Limit in Gb" and give it the appropriate value for maximum database size in GB.' as per his instructions on last link

Is that what you mean?

Once done you then stop the MS Information Store service in Services section, and start it up again(or wait until you have no users connected to exchange and do this)
0
 

Author Comment

by:martialarts-classes
ID: 37901521
OK have done this and will monitor and see if this has corrected the issue :)
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37901522
Here's a better view, shows the screens how they should look when done...
http://www.msexchange.org/tutorials/explaining-database-size-limit-changes-exchange-2003-service-pack-2.html
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37901524
Have you stopped/started the info store service? Will only take affect when u do that...
0
 

Author Comment

by:martialarts-classes
ID: 37901528
yes I stopped the service, waited for it to say it had stopped and then restarted the service...so time will tell!
0
 

Author Comment

by:martialarts-classes
ID: 37905565
Email working fine today so far it will be tomorrow that is the real test as it goes down every 2 days, this is an error messages in the Event viewer...is it anything to worry about?error
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37905583
Think it just means you have enabled Sender Filtering without actually adding a list of trusted hosts...

Open Exchange System Manager
Global Settings
Right click Message Delivery - Properties
Sender ID Filtering
You probably have it enabled but nothing configured, in terms of the existing issue no this will not have any real effect on things...
0
 

Author Comment

by:martialarts-classes
ID: 37905596
OK thanks and you are correct it is enabled but not configured, as long as it is not a problem then I am not bothered about the message.

Will report back tomorrow/Monday with good news hopefully :)
0
 

Author Closing Comment

by:martialarts-classes
ID: 37915357
Excellent advice, got there in the end and everything is working perfect again.

Many thanks
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 37916017
Good to hear, much appreciated...
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now