• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2617
  • Last Modified:

PXE-E53 No boot filename received trying on WDS Windows 2008 R2 x64

I am trying to set up PXE boot at our site.  I get the famous "PXE-E53 No boot filename received" message with trying to PXE boot from a laptop.  

Here's the steps I've got so far:
1)  On a Windows 2008 R2 x64 server:
     a) Installed SolarWinds TFTP Server.   Configured to point to directory with *.wim files
     b) Installed WDS Service.
2)  DHCP is running from Cisco switch.  
3)  There are three different VLANS involved:
     Switch - VLAN 10, 10.38.36.*)
     Servers - VLAN 30, 10.38.38.*
     Workstations - VLAN 201, 10.38.46.*
4)  DHCP setup for workstation VLAN 201:
     ip dhcp pool vlan_201
           network 10.38.46.0 255.255.255.0
           next-server 10.38.38.16  (IP of my TFTP server)
           default-router 10.38.46.1
           dns-server 10.38.38.17 10.38.0.134
5)  One boot image of Windows 7 32-bit (all workstations are running it) loaded in WDS.

Does anyone have ideas on my next steps to diagnose the problem?
0
tails71
Asked:
tails71
  • 8
  • 5
1 Solution
 
ryan80Commented:
did you configure the bootfile name in dhcp?
0
 
tails71Author Commented:
No the only thing I added in DHCP was the TFTP server IP address.
0
 
ryan80Commented:
I believe that I had the same issue before and the problem was that the bootfile name was not specified. It is option 67 for dhcp.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
tails71Author Commented:
Okay that helped.  I added the bootfile option on my cisco switch (dhcp server):

ip dhcp pool vlan_201
   network 10.38.46.0 255.255.255.0
   bootfile \build\windows7-32bit\sources\boot.wim
   next-server 10.38.38.16
   default-router 10.38.46.1
   dns-server 10.38.38.17 10.38.0.134
   domain-name dwight.k12.il.us
   lease 0 8

I'm now getting new errors:
PXE-T04:  Access violation
PXE-E36:  Error recieved from TFTP server


My TFTP server (2008 R2) has the following set up:
  The BUILD share (\\{servername}\BUILD) is not on the C: drive.  I don't know if that matters.  So the boot file is at \\{servername}\build\windows7-32bit\sources\boot.wim

I have tried about every available path syntax for bootfile.  Any ideas?
0
 
ryan80Commented:
I am not to familiar with PXE, but I believe that the file format for TFTP uses forward slashes? Maybe try  bootfile /build/windows7-32bit/sources/boot.wim
??
0
 
tails71Author Commented:
Here is more info:

I have identified my root path for my TFTP server as D:\BUILD in my TFTP config on my 2008 R2 server.  That directory is also shared as \\{servername}\BUILD.

I have tried forward slashes, backward slashes, double slashes,  adding the BUILD directory to the path, removing the BUILD directory to the path.
0
 
ryan80Commented:
I would think that /windows7-32bit/sources/boot.wim would be what you want and that you will need to allow anonymous access to the file. you could test it with a tftp client to see if you can access the file.
0
 
tails71Author Commented:
when I just use a TFTP client to copy a single file, I get an access violation
0
 
ryan80Commented:
I would look at the permissions of the tftp server and also the permissions of the file itself in windows. The tftp service credentials should have access to the directories and boot file.
0
 
tails71Author Commented:
The TFTP service is running under an id in the DOMAIN ADMINS group (for now).  I have checked the folder, and the DOMAIN ADMIN group has full rights for the folder.  I have restarted the service, and am still getting the error.  Any thoughts?
0
 
tails71Author Commented:
I have finally been able to get back to this issue.  I discovered a couple of things after some trial and error.

1)  Turned the Firewall off on the server.
2)  When I stopped the Windows Deployment Service (WDS), I was able to open a command prompt, and use the TFTP client to get a file from my TFTP server.
3)  When I restarted WDS, I get the access violation again.



Our DHCP is currently set up on our core switch (Cisco), NOT through a Windows Server.
0
 
tails71Author Commented:
Finally got WDS to work.  Successfully deploying machines.  Here's what I ended up doing:

1) Moved DHCP scopes from core switch to our Windows 2008 DC.  (included options 66 and 67 for boot file name and TFTP path).

2) On Cisco core switch, had to edit our VLANs as follows:
          ip helper-address 10.38.38.17   (our DHCP server)
          ip helper-address 10.38.38.27   (our TFTP server)

I had to put both entries in, even though I added options 66 & 67 in the DHCP scope.
I had to make sure that the DHCP server was listed first.  If the TFTP server was listed first, I got inconsistent results.
0
 
tails71Author Commented:
Things became much simpler to diagnose once the DHCP service was moved from the switch to a Windows server.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now