File sharing on windows 7 64 Bit

Every time I try to share a specific file on my computer, the entire user directory is shared.  We opearte on a network Domain.  When I unshare the User directory, nothing is shared, event the specific file I tried to share.  What am I doing worng, or failing to do?

Thanks
rvhortonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AnuroopsunddCommented:
sharing is done on the folder not on file base..

if you just want to share a file..
Create a new folder ..
share the new folder
put the filein this shared folder.

so in this case only one file will be shared.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BelushiLomaxCommented:
If the file can be moved, move it and share that folder.
Otherwise you will need to remove inherited ntfs permissions on all the files EXCEPT the one you want them to access, then remove the user and "Users" or "Everyone" from the read permissions. No need to set Deny, just take away rights to read the others. This can also be done thru icacls from elevated command prompt as local admin if there are TONS of other files in there.
0
uescompCommented:
That is because when you share a file, everyone means everyone, so in order to get to that directory, everyone needs to be able to access the path to get to that file which of course shares the path not necessarily the files.  I would just create a folder on the root (c:) share the folder with the people you want to have access and remove the everyone.  If you have a group of users that you want to share the file/files with, add that specific group to the share.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

rvhortonAuthor Commented:
Thanks for the assistance.  I did place the file in a folder that I shared.  It worked, but the USERS directory was still shared.  I than went into the users properites of the USERS directory, clicked on the Advanced Sharing button and unchecked the box for Share this folder.  This unshared the USERS directory and left the folder I wanted shared, shared.  Unless I am missing something, this does not seem to be better than under Windows XP!
0
BelushiLomaxCommented:
It isnt better than XP. It's NTFS permissions which are common from NT days thru Windows 8 although Win Server 8 will use Relilient File Services...
0
asher-is-meCommented:
It's easiest just go to to Computer-->Local Disc (C).  Create a directory in there called "Shared".  Then right-click on it and click "Share With", or after right-clicking go to Properties and click on the Sharing tab.  You may have to click on the Security tab and give permissions to "Guest" or "Everyone" depending on the details of what you want to do.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.