GPO Folder Redirection Not Working

I have two Windows Server 2008 R2 domain controllers. The domain & forest are at server 2008 r2 functionality. I have mostly windows xp workstations, but a few windows 7 also. We are also using windows 2003 terminal services.

I have set up folder redirection in GPO, but it is not taking.

I get the following when I do a gpupdate:
Windows failed to apply the Folder Redirection settings. Folder Redirection settings might have its own log file. Please click on the "More information" link.
Computer Policy update has completed successfully.

Open in new window

When I check the Event Log, I see the following:
Log Name: Application
Source: Microsoft-Windows-Folder Redirection
Date: 4/12/2012 2:44:37 PM
Event ID: 511
Task Category: None
Level: Error
Keywords: 
User: RCMHOSPITAL\\abryant
Computer: RCMHwsIT.rcmhospital.local
Description:
Failed to process policy info.
Error details: "The system cannot find the file specified.
".
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"&gt;
<System>
<Provider Name="Microsoft-Windows-Folder Redirection" Guid="{7D7B0C39-93F6-4100-BD96-4DDA859652C5}" />
<EventID>511</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2012-04-12T19:44:37.703171200Z" />
<EventRecordID>8428</EventRecordID>
<Correlation ActivityID="{E7DE2150-1E48-4B0B-A65E-AAB55BEADB6D}" />
<Execution ProcessID="240" ThreadID="3508" />
<Channel>Application</Channel>
<Computer>RCMHwsIT.rcmhospital.local</Computer>
<Security UserID="S-1-5-21-3460913004-1748156335-2774183333-1220" />
</System>
<EventData Name="EVENT_FDEPLOY_FailedToProcessPolicyInfo">
<Data Name="ErrorDetails">The system cannot find the file specified.
</Data>
</EventData>
</Event>

Open in new window

I'm not sure what file it is looking for and cannot find. Let me know what other information is need to figure this out. I'mj realitively new to GPO, AD, & Windows servers in general.

I have attached the result of a GP Modeling run on the domain.

I have also attached a file with the output from gpresult /v
rcmhospital-on-rcmhospital.htm
gpo.log
Alan BryantVolunteer Youth WorkerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GeodashCommented:
Is the policy not working on all clients or just windows XP or Windows 7? If its just XP, do you have the client side extensions installed, to pull GP's from 2008 DC?
Alan BryantVolunteer Youth WorkerAuthor Commented:
It is both XP & 7. But, yes, I do have the client side extensions installed.
GeodashCommented:
You get the same error doing a gpupdate /force from both XP and W7?
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

GeodashCommented:
It says that under "Denied GPO's" that it is disabled on the Folder Redirection Policy

The 5th one down
GeodashCommented:
Then the one under that - looks like a broken SID - {73F9C678-D10D-406F-90F9-E5DDC9C86463}

It says inaccessible

But the main Folder Redirect policy says it is disabled.
Alan BryantVolunteer Youth WorkerAuthor Commented:
Yeah, I saw that, but I assumed that since it was on the Computer Configuration part that it didn't have any effect, is that not correct?

Also, if it is in fact disabled, I don't know how I did it, or how to undo it.

Is there any way to find out what the broken SID might be?
Alan BryantVolunteer Youth WorkerAuthor Commented:
Ok, disable Computer Configuration settings was checked on the Folder Redirection GPO, not sure how that happened. I have unchecked it and will try again.
Alan BryantVolunteer Youth WorkerAuthor Commented:
Here is the result of gpupdate /force after removing the disabled bit.
gpo-force.log
Here is gpresult /v after removing the disabled bit:
gpo-notdisabled.log
GeodashCommented:
It says it applied - have you tested it to see? For future and for your safety, I would hide your domain name before posting on here. Just my opinion to make sure you are safe...



USER SETTINGS
--------------
    CN=Alan Bryant,CN=Users,DC=rcmhospital,DC=local
    Last time Group Policy was applied: 4/12/2012 at 4:28:40 PM
    Group Policy was applied from:      RCMHDC01.rcmhospital.local
    Group Policy slow link threshold:   500 kbps
    Domain Name:                        
    Domain Type:                        Windows 2000
   
    Applied Group Policy Objects
    -----------------------------
        Default Domain Policy
        Drives & Shortcuts
        Automatic Updates
        Folder Redirection
GeodashCommented:
Are you running Windows 2000 DC's?

Your gpo log said you are running Windows 2000 Domain  -

Domain Type:                        Windows 2000

But you are running w2k8r2 servers. What level is your domain running out. I am not sure if the log is just reporting incorrectly or not.
GeodashCommented:
Domain type is irrelevant, I just looked it up, sorry for confusion.

http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/5d944d78-5c53-48b8-9a07-6ce3deb4e069/
Alan BryantVolunteer Youth WorkerAuthor Commented:
No, it does not work even though it says it is being applied. Nothing is created on the share that I have set up in the GPO properties, and yes, the permissions are correct according to Technet.

I'm thinking the problem may be related to the bad SID. It references it being inaccessible, and the error in Event Log references a file not available.

I just don't know how to find out anything about the SID, if you can.
Alan BryantVolunteer Youth WorkerAuthor Commented:
Here is the report for the folder redirection GPO if this helps.
Folder-Redirection.htm
GeodashCommented:
GeodashCommented:
Do you have a test domain or is all of your testing have to be done in production?
Alan BryantVolunteer Youth WorkerAuthor Commented:
Following a link in this thread (http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/4e145bc8-c77b-4f01-8b99-88408caebcd0/), I did a little more digging.

In this article, it says that you should find the file "fdeploy.ini" in the directory User\Documents & Settings under the GPO GUID, so SYSVOL\{GPO GUID}\User\Documents & Settings\fdeploy.ini.

Once I found the GUID of my FOlder Redirection GPO, I looked there and that file is not there. Is this the problem?

I have tried with several different GPO's and the result is the same.

I have verified that the inaccessible GUID is not the FOlder Redirection GPO, I am not sure what it is. All of my other GPO's are working as expected.
GeodashCommented:
Yes I believe the file should be there. Have you tried disabling that current policy and creating a whole new one from scratch with a different name? Maybe name it with Test in front of it, just to see if the actually GP is causing it or the container
Alan BryantVolunteer Youth WorkerAuthor Commented:
Ok, so I actually found in another GPO that there had been some Folder Redirection Settings set for a specific group that no longer existed. I have removed that GPO, and any reference to Folder Redirection in ALL GPO's is set to not configured like the default settings.



The odd thing is that I am still getting the following in a gpupdate
Updating Policy...
User Policy update has completed successfully.

The following warnings were encountered during user policy processing:
Windows failed to apply the Folder Redirection settings. Folder Redirection settings might have its own log file. Please click on the "More information" link.
Computer Policy update has completed successfully.

For more detailed information, review the event log or run GPRESULT /H GPReport.html from the command line to access information about Group Policy results.

Open in new window


I am going to try with a new GPO and see if it works.
GeodashCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GeodashCommented:
Just so I remember, the policy is not working on any PC you log in to correct?
Alan BryantVolunteer Youth WorkerAuthor Commented:
That is correct.

Meanwhile, I don't have much in Group Policy defined, and what I do, I can easily add back later. I removed all custom GPO's and I followed the instructions in the link you last provided (I re-created the Default GPO's) and now the error for the Folder Redirection is gone.

I have added back my WSUS settings and still looking good.

I'm going to add back my Drive Mappings next. If all is still good, I will try Folder Redirection again and update this thread.
Alan BryantVolunteer Youth WorkerAuthor Commented:
It is working now!!

I wonder if it was not the conflict of two sets of Folder Redirection applying that somehow corrupted my Group Policy? It is odd how only Folder Redirection was affected.

Thank you Geodash for all your help, it is much appreciated!
GeodashCommented:
No problem at all, and awesome news! I am glad it is working now!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.