Disk Management

Hi Experts,

Strange one... we had a GPT partiton (first partition on single disk) - it was originally configured as type 07 (NTFS).  We changed the type via 'diskpart' to type 27 (OEM Recovery).

In Windows 'Disk Management' you see the partion without any letter assignment, in Windows Explorer however - it shows the partition with a letter assignment??  This is an issue for us as it is causing a lot low disk space alerts in our non-customisable monitoring platform.  It is only a 100Mb partition.  We can change the monitoring alerts.

Windows 2008 R2 hosted on VMWare

Any ideas?

Thanks.
LVL 1
BmusedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Remove the letter assignment, the problem that you have to deal with would be the shift in letter assignments may break the bootup such that you would need to repair the boot.
0
BmusedAuthor Commented:
Hi - thanks for the response...

Just how would one remove the letter assignment?

"In Windows 'Disk Management' you see the partion without any letter assignment,"

Only Windows Explorere "sees" the drive letter!

:-)
0
arnoldCommented:
In disk management, right click on the partition in question and see what letter is assigned to it. You can remove the letter assignment there.
Alternatively, you can set the attribute on the partition as hidden.
http://technet.microsoft.com/en-us/library/cc766465(v=ws.10).aspx

Problem I see is that it is the first primary partition and MIT be where the boot is stored.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

BmusedAuthor Commented:
Thanks again.... Windows 'Disk Management' = No drive letter assignment

there is nothing to change... right-click onlt presents 'Help' in the context menu.
I'm versed with diskpart commands....  the partition in question was created AFTER the OS was installed.... but no-one is owning upto it!!!


Grrr...
0
arnoldCommented:
Tis makes no sense, a partition with a drive letter assigned should appear in both.
What about changing the attribute to hidden?
Not seen a resource in disk management not having a drive letter, yet explorer reflects a drive letter.
I'm sure you would, but to be sure make sure to have a snapshot prior to making changes.
0
BmusedAuthor Commented:
Yep... that's why I turned to EE for some insight.

always take snapshots, but problem  (well actually its the same symptom on 2 boxes) - is they are both domain controllers!!!

Double Grrrrrr!
0
arnoldCommented:
oh, crap.
Check the uuid of the partition in question, then see whether it is seen in the registry

Presumably you tried the diskpart rescan.

http://www.techsupportforum.com/forums/f16/no-drive-letters-show-in-disk-management-355458.html
0
BmusedAuthor Commented:
Yup, have done the rescan.... I've actually come across a few other articles (elsewhere) with same problem...
0
arnoldCommented:
Could you post the disk management image?
Is this partiton reflected with system or any similar designation?
0
BmusedAuthor Commented:
See attached snip... oh, won't let me attach small .jpg   :-(
0
noxchoGlobal Support CoordinatorCommented:
Change the ID back to 07 then remove the drive letter and change the ID back to 27.
0
arnoldCommented:
regedit
HKLM\system\mounteddevices
here you should see two entries
one deals with the volume
the other deals with the drive letter.
Their data should match
volume1 23 23 23 23
\dosDevice\f: 23 23 23 23

use caution when deleting entries here.
0
BmusedAuthor Commented:
Thanks Noxcho... have already tried that - will not let me remove the drive letter....

Arnold - what are you suggesting??? delete the corresponding dosDevice drive letter (D:)?? - what is the impact of this?  What does this do?

:-)
0
arnoldCommented:
I've not seen it personally so can not say that it is the optimal approach.
Is the d:\ partition the one you are talking about and disk management does not indicate that there are any system, page file data nor boot section on it, you could try deleting the drive letter assignment from the registry.

You could take a snapshot and copy the VM to a workstation that is not connected to your existing network to see what would be the effect of the registry modification without the risk of corrupting one of your existing dc's. Once you've done it and saw the effect, you can trying one of the live systems giving both time to make sure something else does not go wrong.

The other approaches to create yet another vim properly partitioned an dallocated drviesm and then use the new one as another dc while decommissioning one of the current ones when replication is complete.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
noxchoGlobal Support CoordinatorCommented:
It won't let you remove drive letter even if you change the partition ID back to 07?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.