How configure a Linksys Wireless-N WRT120N as static router

I'm trying to configure a WRT120N as static router to allow communication between a bridge (in PPoE mode) and a watchguard appliance. Due I have to use an static IP to setup a load balancer, the installation of an static router seems to be the best way to proceed.

Unfortunately, the communication between the router and the watchguard is not working as should be. From the router to internet everything is working, but not the incoming connections. I already turn off the internal firewall, define a rule to forward all the traffic to one IP, and/or set all the traffic to one IP via DMZ. I'm not sure if something is missing or if the device is not able to do that...

Any ideas?
moralesrdAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
AnuroopsunddConnect With a Mentor Commented:
ISP is 255.255.255.248, however the system only let me add a 255.255.255.255 subnet

where is this you are trying to input....?

as from the router to Internet is fine then it shhould be ok.
on the 2nd internal interface of your router which is connecting to watchguard .. is the network subnet same....
0
 
AnuroopsunddCommented:
What is the setting for advanced routing?
disable NAT and enable Dynamic Routing (RIP)  and specify STATIC routes..
0
 
moralesrdAuthor Commented:
I already did it, and automatically there is a few routes added; however, there is two thing that are coming to my head; the first one is, the gateway IP is automatically added as main IP and as a gateway; the other thing is, the subnet provided by the ISP is 255.255.255.248, however the system only let me add a 255.255.255.255 subnet. Would be part of the problem or the static route should be to the local IP? could you provide an example?

Thanks,
0
 
moralesrdAuthor Commented:
I was trying to add an static route for one of the IP assigned by the ISP.

I tried with the router as DHCP server for the internal IP and manually assigned, in both cases the IP used is the same 192.168.1.100/24 GW: 192.168.1.1 (router IP).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.