printer spool will not start

I tried to change the virtual memory to let windows set the size.  After that, the spooler will not start.  So I went back in and set it back to 4606 for each drive.  Still will not work.  I went to the event logs and in "WINDOWS LOG APPLICATONS" I get "application error... Name spoolsv.exe exception coed 0xc0000005  offest 0x00000000 faulting process id 0X1cf4" or another time faulting process id 0x1e90.

Also in PRINTSERVICES ADMINISTRATION 3 errors occurr over and over.
1.  "initalize print provider failed for provider win32spl.dll ID 512this can occurr because of system instability or lack of system resorces."
2. "print spooler cannot start because the printer bus enumerater could not start.
error code 0xd.  id 509.  this can occurr because of system instability or lack of system resorces."
3. "initalize printprovider failure for provider win32sv.dll. this can occurr because of system instability or lack of system resorces."
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
The three suggestions all have a common feature: System Instability.

What virtual memory are you setting? Page size?  I have not seen that affect the spooler services (not that it couldn't).

Run System File Checker.  Open an admin command prompt and run SFC /SCANNOW. Allow to complete and restart. Run it again if there were errors not corrected the first time.

Then scan thoroughly for viruses and malware.

Please let us know. ... Thinkpads_User
Have you considered using the System Restore function to drop back to a snapshot of the operating system before the problems started?

How to Do a System Restore in Windows 7
grurbanAuthor Commented:
total size 9212 mb  C: 4606 d: 4606

ran sfc and it reported no errors.

I have tried to go back to 2 different restore points and they will not load.  I will try again and get the message for that.

attached Belarc profile.

going to run checkdisk shortly.

Heading to bed shortly also.  Anything else I can get.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Occasionally the system restore process will be stopped by other factors, such as security software.  Try booting into safe mode and running it from there.
JohnBusiness Consultant (Owner)Commented:
If SFC, System Restore, and then the Safe Mode suggestion all do not work, the next stup is to back up the system and do a Windows 7 repair install from the DVD.

It is (easily) possible to corrupt an operating system, so bear that in mind, because if "nothing works" then you ultimately may have to reinstall WIndows to get decent stability over the long haul. ... Thinkpads_User
grurbanAuthor Commented:
chkdsk does not show any errors.

In safe mode: restore error after it reboots
"System Restore failed to Extract the original copy of the directory from the restore point.

Source:  %SystemRoot%\Registration
Destination:  ComPlusStaging"

I will back up PST and Documents  before I try to Repair it.

I used widows backup to back up an image.  just not sure what day I did it on or how much I will loose.  

I'll check in the morning to see if any other ideas.  

Long day.  Thanks for your help tonight.  Getting a little fuzzy.
grurbanAuthor Commented:
Well, I had to reinstall win 7.  still loading programs.  trying to set my network printers up and the find drivers with windows update fails.  Say it can't connect....  I'm still updating with the normal windows update.  don't know how many more passes that will take.
JohnBusiness Consultant (Owner)Commented:
Also remember to do the Printers updates.

Go to Devices and Printers, Add a Printer, Local, Existing connection, Next. See the update button beside Have Disk. Click on Update and allow it to complete. This will update the list of printers and update the drivers that Windows 7 has available to install.

... Thinkpads_User
grurbanAuthor Commented:
That's the one that returns "cannot connect to windows update....  try later"
JohnBusiness Consultant (Owner)Commented:
That is indeed strange, since you have re-installed Windows 7.

Have you installed something not compatible with Windows 7?  
Can you disable any antivirus and try again?  

I just tested the update function here and it worked (always has).  

Run the System Readiness Tools to see if that will allow the update to work. for X64 for x86

Pick the one for your version of Windows 7 (32-bit or 64-bit)

.... Thinkpads_User
grurbanAuthor Commented:
I hope I did not lead you down the wrong path.  The spooler is now functional for the local printer.   The message I'm getting is when I try to install a network printer.  In the add printer wizard when you press "windows update" the exact message is "Windows was unable to get a list of devices from windows update.  Please try again later".  I went to the microsoft knowledge base and have read most everything there.  One poster call it a rather crude name due to the fact that they just tell everyone to do the same thing over and over and never come up with a fix.  Now trying to install printer using drivers found in "windows update catalog."  Only problem is I havev't yet found one for 32 bit hplaserjet 2605 dn pcl.  Running the hotfix you sent.  will let you know the results.
grurbanAuthor Commented:
Well here's the bottom line.  After reinstalling windows 7, down loading stand alone drivers for my HP printers, asking questions on multiple web sites, reading countless pages of computer chats,  here is what finally worked.

The spooler started working properly after the reinstall for local printers but the network printers would not load.

Finally, I ran a long usb cable from machine to laser printer and it installed automaticaly with no errors.  

I removed that device.

I added a new network printer the normal way and it installed correctly.

I then added the other network printer and it installed correctly.

so I'm going to check multiple soloutions.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
One way or another, I'm glad to hear that you're back in business again!
grurbanAuthor Commented:
I got lots of help, but in the end, just trying everything finaly worked.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.