WOL Fails from outside the LAN

Hi
I use WOL to wake up my home computers so I can remote into them from work.

WOL fails to wake up the machines when I send the magic from work

I have port forwarding set correctly & the magic packet sent from the remote (work) network IS received correctly on the home PC(s). (WOL Magic Packet sender has a receive mode where I can check this)

WOL is 100% effective on all my home PCs when the packet is deployed from the local network.

The only way I have of waking up a given home machine is to leave (any) 1 on and use that to do the waking up of the others.

I would like to be able to suspend them all because I hate wasting electricity and wearing out my fans etc.


I haven't specifically opened the port/s I am using for the UDP magic Packet in the (windows) firewalls on the PCs I am trying to wake.

Why can it wake from any PC on the local network but not from work even though the packet is received on the home PCwhen I send it from work (once its awake I can test).

Can anyone say how to sort this out?

PS the home PCs are not on a domain but OS include
WHS (spx -up to date)
W7 sp1
XP sp3
Vista (spx -up to date)
LVL 5
sir plusSales ManagementAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
TimotiStConnect With a Mentor Datacenter TechnicianCommented:
If a PC is asleep, it does not have an IP address, just a MAC address. If you send the magic packet through the internet, your home router does not have an ARP entry for your PC's IP/MAC address, so it can't send the packet to it.

The usual solution for this is that the last router converts the unicast IP packet to a local-broadcast (like 192.168.1.255), which goes to every PC on your home LAN. Problem is, home/soho grade routers usually can't do this. But you can try setting up the port-forward to point to the broadcast address, maybe it works on your router.

Tamas
0
 
mindwiseConnect With a Mentor Commented:
If you send the magic packet through the internet, your home router does not have an ARP entry for your PC's IP/MAC address, so it can't send the packet to it.

IF that is the problem, you can also try to add a static arp entry for your pc in your router, then your router does not need to arp it.

Kr,
0
The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

 
ts4673Connect With a Mentor Commented:
check out poweronmypc.com
0
 
sir plusSales ManagementAuthor Commented:
It definitely is that the router doesn't forward it when the PC is asleep!!!!

PC has a permenant IP assigned but that doesnt mean it knows
Router will not accept x.x.x.255 (darn :-/)

All answers were helpful to arrive at conclusion I need a proper router that can handle broadcast to LAN
0
 
sir plusSales ManagementAuthor Commented:
Use a new router (NP804n $62 on eBay) which is DD-WRT compatible.
Installed DD-WRT firmware, installed a hack in the initialise to install the sleepy computer IP in the ARP even though the PC is off.
h**p://www.dd-wrt.com/phpBB2/viewtopic.php?t=77351&highlight=magic+packet+broadcast
Will let you know
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.