ASA 5510 pppoe on bt infinity fails

Hi
I have a BT infinity line I am trying to connect to an asa 5510. The line does not appear to be initialising. Details below, anyone any ideas?

Config :-

interface Ethernet0/3
 nameif Infinity
 security-level 0
 pppoe client vpdn group Infinity
 ip address pppoe setroute

vpdn group Infinity request dialout pppoe
vpdn group Infinity localname C974463@hg70.btclick.com
vpdn group Infinity ppp authentication chap
vpdn username C974463@hg70.btclick.com password ***** store-local


Output from debug pppoe

PPPoE: send_padt:(Snd) Dest:0013.c482.3439 Src:0013.c482.3439 Type:0x8863=PPPoE-Discovery
PPPoE: Ver:1 Type:1 Code:A7=PADT Sess:345 Len:0
PPPoE: send_padi:(Snd) Dest:ffff.ffff.ffff Src:0013.c482.3439 Type:0x8863=PPPoE-Discovery
PPPoE: Ver:1 Type:1 Code:09=PADI Sess:0 Len:12
PPPoE: Type:0101:SVCNAME-Service Name Len:0
PPPoE: Type:0103:HOSTUNIQ-Host Unique Tag Len:4
PPPoE: 00000008
PPPoE: PPPoE:(Rcv) Dest:0013.c482.3439 Src:0030.8800.0006 Type:0x8863=PPPoE-Discovery
PPPoE: Ver:1 Type:1 Code:07=PADO Sess:0 Len:46
PPPoE: Type:0103:HOSTUNIQ-Host Unique Tag Len:4
PPPoE: 00000008
PPPoE: Type:0102:ACNAME-AC Name Len:30
PPPoE: bras-red6.bm-th-B2224060701971

PPPoE: Type:0101:SVCNAME-Service Name Len:0
PPPoE: PADO

PPPoE: send_padr:(Snd) Dest:0030.8800.0006 Src:0013.c482.3439 Type:0x8863=PPPoE-Discovery
PPPoE: Ver:1 Type:1 Code:19=PADR Sess:0 Len:46
PPPoE: Type:0103:HOSTUNIQ-Host Unique Tag Len:4
PPPoE: 00000008
PPPoE: Type:0102:ACNAME-AC Name Len:30
PPPoE: bras-red6.bm-th-B2224060701971

PPPoE: Type:0101:SVCNAME-Service Name Len:0
PPPoE: PPPoE:(Rcv) Dest:0013.c482.3439 Src:0030.8800.0006 Type:0x8863=PPPoE-Discovery
PPPoE: Ver:1 Type:1 Code:65=PADS Sess:2922 Len:46
PPPoE: Type:0103:HOSTUNIQ-Host Unique Tag Len:4
PPPoE: 00000008
PPPoE: Type:0101:SVCNAME-Service Name Len:0
PPPoE: Type:0102:ACNAME-AC Name Len:30
PPPoE: bras-red6.bm-th-B2224060701971

PPPoE: PADS

PPPoE: IN PADS from PPPoE tunnel

PPPoE: Opening PPP link and starting negotiations.

PPPoE: Shutting down client session

PPPoE: send_padt:(Snd) Dest:0013.c482.3439 Src:0013.c482.3439 Type:0x8863=PPPoE-Discovery
PPPoE: Ver:1 Type:1 Code:A7=PADT Sess:2922 Len:0
Jo CoxAsked:
Who is Participating?
 
PerarduaadastraCommented:
Back again.

Another thought:

Have you got multiple public IP addresses on this interface? If so, such a configuration may need more expertise than I have.

It might be helpful if you re-posted this question in the Cisco area of networking, as more expertise is available there than here; so far, it's just been me!
0
 
PerarduaadastraCommented:
How are you connecting the BT Infinity to the ASA?
0
 
Jo CoxAuthor Commented:
Directly to the bt white box (modem), not using the homehub. I have been testing the BT infinity line connected like this but to a cisco 1841 and it works fine so I know I have all the credentials correct and that the line works fine.

It's just connecting via asa that seems to be failing!
0
KuppingerCole Reviews AlgoSec in Executive Report

Leading analyst firm, KuppingerCole reviews AlgoSec's Security Policy Management Solution, and the security challenges faced by companies today in their Executive View report.

 
PerarduaadastraCommented:
The report seems to indicate that it all falls apart as soon as negotiations between the two ends of the connections start.

Have you tried different authentication methods? I know that in theory what works for the 1841 should work for the ASA, but they are very different bits of kit...
0
 
Jo CoxAuthor Commented:
Do you mean like pap?
0
 
PerarduaadastraCommented:
Yes; that's the only other one, really, as EAP is primarily used in wireless scenarios. However, PAP does seem unlikely as the password is transmitted in clear text - not a great idea!

Another thought has occurred to me; can the term "negotiations" refer to the link characteristics as well? If link speed or MTU size can't be agreed by the endpoints, that won't help much...
0
 
PerarduaadastraCommented:
I've just had a look at the connection of one of my clients who uses a completely different device for his connection, and that device provides an option for auto-negotiation of the link; does the ASA allow you to do this?
0
 
Jo CoxAuthor Commented:
The Only Auto things available are the speed and duplex.
I have tried fixing these at 100/full and auto. didn't seem to make any difference.
0
 
PerarduaadastraCommented:
I've just had a quick chat with my router, which is connected to BT's Infinity modem; the port speed is set to autosense, and the MTU size is default, which the greyed-out Custom field is showing as 1492 bytes.

I have found in the past that connectivity can be broken by specifying the wrong MTU size in the router/gateway/whatever appliance, so it's worth experimenting with at least the common values, unless BT can tell you definitively what it should be.
0
 
PerarduaadastraCommented:
I'm away from my computer for a few hours now, so I hope that someone else can get you up and running, even if it wasn't me!
0
 
Jo CoxAuthor Commented:
Hi Perarduaadastra
There are multiple connections as the asa is live with a lan a different WAN connection.

I'll take your suggestion and repost to Cisco area.
Thanks for your help.
Jo
0
 
Jo CoxAuthor Commented:
Not Resolved - reposted to the cisco area.
0
 
PerarduaadastraCommented:
jrb139

That's very generous of you, since my only useful suggestion was for you to ask someone else!

A better use of the points might have been to move the question rather than repost.

Perhaps a moderator can arrange this for you, as I feel rather uncomfortable about receiving points I didn't earn...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.